]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
add tests bcond (disabled, too many failures)
[packages/chef.git] / chef.spec
CommitLineData
8354a17e
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
e307965b
ER
5Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6Name: chef
68cfa14e 7Version: 11.4.4
bc8e6547 8Release: 0.12
e307965b
ER
9License: Apache v2.0
10Group: Development/Languages
e307965b 11Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
68cfa14e 12# Source0-md5: dc50aa6a4a7d4785a4c82fcaab3f9436
7abbc83b 13Patch0: platform-pld.patch
bc8e6547 14Patch1: FHS.patch
2a1bbc08 15URL: http://wiki.opscode.com/display/chef
303651f6
ER
16BuildRequires: rpm-rubyprov
17BuildRequires: rpmbuild(macros) >= 1.656
68cfa14e
ER
18BuildRequires: sed >= 4.0
19%if %{with tests}
8354a17e
ER
20BuildRequires: ruby-abstract
21BuildRequires: ruby-mixlib-authentication >= 1.3.0
68cfa14e
ER
22BuildRequires: ruby-rack
23BuildRequires: ruby-rake
8354a17e 24#BuildRequires: ruby-rdoc
68cfa14e
ER
25BuildRequires: ruby-rspec-core >= 2.12.0
26BuildRequires: ruby-rspec-expectations >= 2.12.0
27BuildRequires: ruby-rspec-mocks >= 2.12.0
8354a17e
ER
28BuildRequires: ruby-rest-client >= 1.0.4
29BuildRequires: ruby-net-ssh-multi >= 1.1.0
30#BuildRequires: ruby-rspec_junit_formatter
31#BuildRequires: ruby-sdoc
68cfa14e 32%endif
97e7edae 33Requires: lsb-release
bce16be1 34Requires: ruby-erubis
2a1bbc08 35Requires: ruby-highline >= 1.6.9
2a1bbc08
ER
36Requires: ruby-json >= 1.4.4
37Requires: ruby-mixlib-authentication >= 1.3.0
38Requires: ruby-mixlib-cli >= 1.3.0
bce16be1
ER
39Requires: ruby-mixlib-config >= 1.1.2
40Requires: ruby-mixlib-log >= 1.3.0
2a1bbc08
ER
41Requires: ruby-mixlib-shellout
42Requires: ruby-net-ssh >= 2.6
43Requires: ruby-net-ssh-multi >= 1.1.0
44Requires: ruby-ohai >= 0.6.0
2a1bbc08 45Requires: ruby-rest-client >= 1.0.4
bce16be1 46Requires: ruby-rubygems
2a1bbc08 47Requires: ruby-yajl >= 1.1
68cfa14e 48Requires: yum >= 3.4.3-7
e307965b
ER
49BuildArch: noarch
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%description
53A systems integration framework, built to bring the benefits of
54configuration management to your entire infrastructure.
55
56%prep
303651f6 57%setup -q
7abbc83b 58%patch0 -p1
bc8e6547 59%patch1 -p1
e307965b 60
68cfa14e
ER
61%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
62
8354a17e
ER
63%build
64%if %{with tests}
65rspec spec
66%endif
67
e307965b
ER
68%install
69rm -rf $RPM_BUILD_ROOT
bc8e6547
ER
70install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}} \
71 $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
68cfa14e 72cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 73cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
e307965b 74
303651f6 75
bce16be1
ER
76%clean
77rm -rf $RPM_BUILD_ROOT
78
e307965b
ER
79%files
80%defattr(644,root,root,755)
2a1bbc08 81%doc README.md CONTRIBUTING.md
303651f6 82%dir %{_sysconfdir}/%{name}
2a1bbc08 83%attr(755,root,root) %{_bindir}/chef-apply
e307965b 84%attr(755,root,root) %{_bindir}/chef-client
2a1bbc08 85%attr(755,root,root) %{_bindir}/chef-shell
e307965b
ER
86%attr(755,root,root) %{_bindir}/chef-solo
87%attr(755,root,root) %{_bindir}/knife
88%attr(755,root,root) %{_bindir}/shef
68cfa14e
ER
89%{ruby_vendorlibdir}/chef.rb
90%{ruby_vendorlibdir}/chef
303651f6 91
bc8e6547
ER
92%dir /var/lib/%{name}
93%dir /var/cache/%{name}
This page took 0.139406 seconds and 4 git commands to generate.