]> git.pld-linux.org Git - packages/chef.git/blob - chef.spec
add tests bcond (disabled, too many failures)
[packages/chef.git] / chef.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6 Name:           chef
7 Version:        11.4.4
8 Release:        0.12
9 License:        Apache v2.0
10 Group:          Development/Languages
11 Source0:        http://rubygems.org/downloads/%{name}-%{version}.gem
12 # Source0-md5:  dc50aa6a4a7d4785a4c82fcaab3f9436
13 Patch0:         platform-pld.patch
14 Patch1:         FHS.patch
15 URL:            http://wiki.opscode.com/display/chef
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.656
18 BuildRequires:  sed >= 4.0
19 %if %{with tests}
20 BuildRequires:  ruby-abstract
21 BuildRequires:  ruby-mixlib-authentication >= 1.3.0
22 BuildRequires:  ruby-rack
23 BuildRequires:  ruby-rake
24 #BuildRequires: ruby-rdoc
25 BuildRequires:  ruby-rspec-core >= 2.12.0
26 BuildRequires:  ruby-rspec-expectations >= 2.12.0
27 BuildRequires:  ruby-rspec-mocks >= 2.12.0
28 BuildRequires:  ruby-rest-client >= 1.0.4
29 BuildRequires:  ruby-net-ssh-multi >= 1.1.0
30 #BuildRequires: ruby-rspec_junit_formatter
31 #BuildRequires: ruby-sdoc
32 %endif
33 Requires:       lsb-release
34 Requires:       ruby-erubis
35 Requires:       ruby-highline >= 1.6.9
36 Requires:       ruby-json >= 1.4.4
37 Requires:       ruby-mixlib-authentication >= 1.3.0
38 Requires:       ruby-mixlib-cli >= 1.3.0
39 Requires:       ruby-mixlib-config >= 1.1.2
40 Requires:       ruby-mixlib-log >= 1.3.0
41 Requires:       ruby-mixlib-shellout
42 Requires:       ruby-net-ssh >= 2.6
43 Requires:       ruby-net-ssh-multi >= 1.1.0
44 Requires:       ruby-ohai >= 0.6.0
45 Requires:       ruby-rest-client >= 1.0.4
46 Requires:       ruby-rubygems
47 Requires:       ruby-yajl >= 1.1
48 Requires:       yum >= 3.4.3-7
49 BuildArch:      noarch
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 A systems integration framework, built to bring the benefits of
54 configuration management to your entire infrastructure.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59 %patch1 -p1
60
61 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
62
63 %build
64 %if %{with tests}
65 rspec spec
66 %endif
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}} \
71         $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
72 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
73 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
74
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README.md CONTRIBUTING.md
82 %dir %{_sysconfdir}/%{name}
83 %attr(755,root,root) %{_bindir}/chef-apply
84 %attr(755,root,root) %{_bindir}/chef-client
85 %attr(755,root,root) %{_bindir}/chef-shell
86 %attr(755,root,root) %{_bindir}/chef-solo
87 %attr(755,root,root) %{_bindir}/knife
88 %attr(755,root,root) %{_bindir}/shef
89 %{ruby_vendorlibdir}/chef.rb
90 %{ruby_vendorlibdir}/chef
91
92 %dir /var/lib/%{name}
93 %dir /var/cache/%{name}
This page took 0.082355 seconds and 3 git commands to generate.