]> git.pld-linux.org Git - packages/alpine.git/blame - alpine.spec
- change deafult index display: 24h time, nonUS mail sizes; typo fixed in
[packages/alpine.git] / alpine.spec
CommitLineData
ecdbf6cc
PG
1# TODO:
2# - backport man-pages from pine.spec
3# - alpine should obsolete pine, link pine -> alpine should be made
ecdbf6cc 4# - review patches from pine:
ffdc223c
PG
5# - home_etc support
6# - ....many more
02477d30 7Summary: University of Washington Pine mail user agent
84f5c30e 8Summary(pl.UTF-8): Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
02477d30 9Name: alpine
db14e620 10%define ver 0.9999
28b69314 11%define patchlevel 18
db14e620 12Version: %{ver}.%{patchlevel}
19f73470 13Release: 1
ecdbf6cc
PG
14Epoch: 1
15License: Apache License 2.0
02477d30 16Group: Applications/Mail
19f73470
PG
17# Main site:
18#Source0: ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19# Source with applied patches from http://staff.washington.edu/chappa/alpine/
db14e620 20Source0: http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
28b69314 21# Source0-md5: 888ecef4d50e15e4237f7a7a55793f68
ecdbf6cc 22Source1: pico.desktop
28b69314
PG
23Source2: %{name}.desktop
24Source3: %{name}.png
4db9f585 25Patch0: %{name}-thread_end.patch
02477d30 26URL: http://www.washington.edu/alpine
c85f8efa
PG
27BuildRequires: autoconf
28BuildRequires: automake
84f5c30e 29BuildRequires: krb5-devel
02477d30
AM
30BuildRequires: ncurses-devel
31BuildRequires: openldap-devel
32BuildRequires: openssl-devel
02477d30 33BuildRequires: pam-devel
84f5c30e 34BuildRequires: tcl-devel
02477d30
AM
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
ecdbf6cc
PG
37%define alpineconfdir /etc/%{name}
38
02477d30
AM
39%description
40Alpine -- an Alternatively Licensed Program for Internet News & Email
41-- is a tool for reading, sending, and managing electronic messages.
42Alpine is the successor to Pine and was developed by Computing &
43Communications at the University of Washington. Though originally
44designed for inexperienced email users, Alpine supports many advanced
45features, and an ever-growing number of configuration and
46personal-preference options.
47
84f5c30e
JB
48%description -l pl.UTF-8
49Alpine, czyli Alternatively Licensed Program for Internet News & Email
50(alternatywnie licencjonowany program do newsów i poczty internetowej)
51to narzędzie do czytania, wysyłania i zarządzania wiadomościami
52elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
53wydział Computing & Communications (Obliczeń i komunikacji) na
54Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
55zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
56wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
57ciągle rośnie.
58
ecdbf6cc
PG
59%package -n pico
60Summary: Simple text editor in the style of the Pine Composer
61Summary(pl.UTF-8): Prosty edytor tekstowy w stylu alpine
62Summary(pt_BR.UTF-8): Editor de textos para terminal simples e fácil de usar
63Group: Applications/Editors
64
65%description -n pico
66Pico is a simple, display-oriented text editor based on the Alpine
67message system composer. As with Pine, commands are displayed at the
68bottom of the screen, and context-sensitive help is provided. As
69characters are typed they are immediately inserted into the text.
70
71%description -n pico -l pl.UTF-8
72Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
73alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
74dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
75włączane do tekstu.
76
77%description -n pico -l pt_BR.UTF-8
78Pico é um editor de texto baseado no compositor de mensagens do Alpine.
79Assim como no Pine, comandos são mostrados na parte de baixo da tela,
80e ajuda de acordo com o contexto está disponível.
81
82%package -n pilot
83Summary: Simple file system browser in the style of the Alpine Composer
84Summary(pl.UTF-8): Prosta przeglądarka plików w stylu composera alpine
85Summary(pt_BR.UTF-8): Navegador de sistemas de arquivos no estilo do compositor do Alpine
86Group: Applications/Shells
87
88%description -n pilot
89Pilot is a simple, display-oriented file system browser based on the
90Alpine message system composer. As with Alpine, commands are displayed at
91the bottom of the screen, and context-sensitive help is provided.
92
93%description -n pilot -l pl.UTF-8
94Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
95stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
96dole ekranu oraz jest dostępna pomoc kontekstowa.
97
98%description -n pilot -l pt_BR.UTF-8
99Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
100como no Pine, comandos são apresentados na parte de baixo da tela, e
101ajuda de acordo com o contexto está disponível.
102
02477d30 103%prep
db14e620 104%setup -q -n %{name}-%{ver}
4db9f585 105%patch0 -p1
02477d30
AM
106
107%build
c85f8efa
PG
108%{__autoconf}
109%{__aclocal} -I m4
110%{__automake}
02477d30
AM
111%configure \
112 --enable-quotas \
113 --with-smtp-msa=%{_libdir}/sendmail \
114 --with-spellcheck-prog=aspell \
ecdbf6cc
PG
115 --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
116 --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
02477d30
AM
117 --with-krb5-dir=%{_prefix} \
118 --with-ldap-dir=%{_prefix} \
119 --with-system-mail-directory=/var/mail
120%{__make}
121
122%install
123rm -rf $RPM_BUILD_ROOT
28b69314 124install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
02477d30
AM
125
126%{__make} install \
127 DESTDIR=$RPM_BUILD_ROOT
128
ecdbf6cc 129install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
28b69314
PG
130install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
131install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
132
ecdbf6cc 133
02477d30
AM
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%files
138%defattr(644,root,root,755)
ecdbf6cc
PG
139%doc README doc/tech-notes.txt
140%dir %{alpineconfdir}
28b69314 141%attr(755,root,root) %{_bindir}/%{name}
02477d30
AM
142%attr(755,root,root) %{_bindir}/rpload
143%attr(755,root,root) %{_bindir}/rpdump
ecdbf6cc
PG
144#%attr(755,root,root) %{_bindir}/mailutil
145#%attr(2755,root,mail) %{_sbindir}/mlock
28b69314 146%{_mandir}/man1/%{name}.1*
ecdbf6cc
PG
147#%{_mandir}/man1/rpload.1*
148#%{_mandir}/man1/rpdump.1*
149#%{_mandir}/man1/mailutil.1*
28b69314
PG
150%{_desktopdir}/%{name}.desktop
151%{_pixmapsdir}/%{name}.png
ecdbf6cc
PG
152
153%files -n pico
154%defattr(644,root,root,755)
155%attr(755,root,root) %{_bindir}/pico
156%{_desktopdir}/pico.desktop
157%{_mandir}/man1/pico*
158
159%files -n pilot
160%defattr(644,root,root,755)
161%attr(755,root,root) %{_bindir}/pilot
162%{_mandir}/man1/pilot*
This page took 0.114521 seconds and 4 git commands to generate.