]> git.pld-linux.org Git - packages/lftp.git/blame - lftp.spec
- updated to 4.0.6
[packages/lftp.git] / lftp.spec
CommitLineData
4f313d5c
ER
1# TODO
2# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
2a0dc3cc 3#
4# Conditional build:
7b39c852
JB
5%bcond_without ssl # do not use SSL
6%bcond_with gnutls # use gnutls, otherwise openssl is used when ssl is on
117d16ec 7
8%if %{with ssl}
9%define with_openssl 1
10%endif
11
4f313d5c 12%if %{with gnutls} && %{with ssl}
117d16ec 13%undefine with_openssl
4f313d5c 14%endif
117d16ec 15
aa601f68 16Summary: Sophisticated command line FTP/HTTP client
b93576af
ER
17Summary(ko.UTF-8): 명령줄에서 돌아가는 FTP/HTTP 클라이언트
18Summary(pl.UTF-8): Zaawansowany klient FTP/HTTP
19Summary(pt_BR.UTF-8): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20Summary(zh_CN.UTF-8): lftp 客户端程序
be14979d 21Name: lftp
008c9d35 22Version: 4.0.6
3f10f8da 23Release: 1
474948d1 24License: GPL v3+
4e6de64c 25Group: Applications/Networking
255104e7 26Source0: ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.lzma
008c9d35 27# Source0-md5: f504a66ff9a4eeda2abda34c1409e33b
e84c29c9 28Source1: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
3dd56067 29# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
c37d8459 30Source2: %{name}.desktop
fbf2ab8a 31Source3: %{name}-icon.png
9ad5e40a 32Patch0: %{name}-home_etc.patch
f1d0e108 33Patch1: %{name}-makefile.patch
922a4344 34# ALWAYS send updated patch to lftp mailing lists
cc06dd55 35Patch2: %{name}-pl.po-update.patch
922a4344 36Patch3: %{name}-m4.patch
0d6c2643 37URL: http://lftp.yar.ru/
7e9d0681 38BuildRequires: autoconf >= 2.60
2a2b7922 39BuildRequires: automake
404c9e4b 40BuildRequires: gettext-devel >= 0.14.2
d4e96cc1 41%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
131b64b6 42BuildRequires: libstdc++-devel
6b77b6dc 43BuildRequires: libtool >= 1:1.4.2-9
eb634329 44BuildRequires: ncurses-devel >= 5.2
117d16ec 45%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
eb634329 46BuildRequires: readline-devel >= 4.2
4502d222 47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
0fcf33fd 48
fed66524 49%define _gcc_ver %(%{__cc} -dumpversion | cut -b 1)
50%if %{_gcc_ver} == 2
51%define __cxx "%{__cc}"
52%endif
f544d322 53
0fcf33fd 54%description
aa601f68 55LFTP is a shell-like command line FTP/HTTP client. The main two
b25ac3f9 56advantages over other FTP clients are reliability and ability to
c37d8459 57perform tasks in background. It will reconnect and reget the file
58being transferred if the connection broke. You can start a transfer in
b25ac3f9 59background and continue browsing on the FTP site. It does this all in
c37d8459 60one process. When you have started background jobs and feel you are
61done, you can just exit lftp and it automatically moves to nohup mode
62and completes the transfers. It has also such nice features as reput
63and mirror.
0fcf33fd 64
29127d3f 65%description -l pl.UTF-8
aa601f68 66Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
29127d3f
JR
67połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
68ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
69połączenia po tym jak się wylogujesz. Program ten honoruje komendy
70powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
71jako aplikacja do mirrorowania serwerów FTP.
0fcf33fd 72
29127d3f
JR
73%description -l pt_BR.UTF-8
74O lftp é um programa de transferência de arquivos por linha de
aa601f68 75comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
29127d3f
JR
76HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
77tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
c37d8459 78o arquivo FEATURES para uma lista mais detalhada.
be2d17d0 79
0fcf33fd 80%prep
6588894c 81%setup -q
4de3cc6d 82#%%patch0 -p1
43f4d1c2 83%patch1 -p1
922a4344
AM
84#%patch2 -p1
85%patch3 -p1
3225d16b 86
a41e3bec
JB
87rm -f po/stamp-po
88
33b4fdae
AM
89%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
90
0fcf33fd 91%build
dc2417fa 92%{__libtoolize}
07e8f8cb 93%{__gettextize}
29f4b0b0 94%{__aclocal} -I m4
cbf16d8c 95%{__autoconf}
96%{__automake}
8ad8d289 97CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
75461ea5 98%configure \
9f24e3d9 99 --with-modules \
117d16ec 100 --with%{!?with_openssl:out}-openssl \
4f313d5c
ER
101 --with%{!?with_gnutls:out}-gnutls
102
3579d696 103%{__make}
0fcf33fd 104
105%install
106rm -rf $RPM_BUILD_ROOT
10a3b210 107install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
3e02f0be 108
f8f85376
JB
109%{__make} install \
110 DESTDIR=$RPM_BUILD_ROOT
be14979d 111
aaea7f09 112install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
10a3b210 113install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
fbf2ab8a 114install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
aaea7f09 115
e84c29c9 116bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
d4e96cc1 117rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
42d7b58c 118rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
7ccee824 119
df169521 120%find_lang %{name}
165ff9f8 121
0fcf33fd 122%clean
123rm -rf $RPM_BUILD_ROOT
124
43f4d1c2
JB
125%post -p /sbin/ldconfig
126%postun -p /sbin/ldconfig
127
df169521 128%files -f %{name}.lang
be14979d 129%defattr(644,root,root,755)
e84c29c9 130%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
404c9e4b 131%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
42d7b58c
JB
132%attr(755,root,root) %{_bindir}/lftp
133%attr(755,root,root) %{_bindir}/lftpget
43f4d1c2 134%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
42d7b58c
JB
135%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
136%dir %{_libdir}/lftp
d81e41f6 137%attr(755,root,root) %{_libdir}/lftp/*.so
c37d8459 138%attr(755,root,root) %{_datadir}/lftp
42d7b58c
JB
139%{_mandir}/man1/lftp.1*
140%{_mandir}/man1/lftpget.1*
141%lang(pl) %{_mandir}/pl/man1/lftpget.1*
10a3b210 142%{_desktopdir}/lftp.desktop
c37d8459 143%{_pixmapsdir}/lftp.png
This page took 0.054991 seconds and 4 git commands to generate.