]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- updated release tags (use "+nptlonly" for no-linuxthreads, "tls-only" for all-tls...
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
40240acb
JB
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
12%bcond_with tls # use TLS in linuxthreads
757f96eb 13%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 14%bcond_with tests # perform "make test"
4cceaf33 15%bcond_with tests_nptl # perform NPTL tests on dual build (requires 2.6.x kernel)
0a85848c 16%bcond_without localedb # don't build localedb-all (is time consuming)
61918272 17
b287d865 18#
37cd6ebc
JB
19# TODO:
20# - localedb-gen man pages(?)
4acad1ec 21# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
22# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
23# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
24# - problem compiling with --enable-bounded (must be reported to libc-alpha)
25# (is this comment still valid???)
26
76f01b70 27#
61918272 28
3900e225 29%{!?min_kernel:%global min_kernel 2.4.6}
76131947 30%if "%{min_kernel}" < "2.6.0"
40240acb
JB
31%global nptl_min_kernel 2.6.0
32%else
33%global nptl_min_kernel %{min_kernel}
76131947 34%endif
40240acb
JB
35
36%if %{with nptl}
37# nptl on x86 uses cmpxchgl (available since i486)
38%ifnarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
39%undefine with_nptl
3900e225 40%endif
61918272 41%endif
61918272 42
f3f771b7 43%if %{with tls}
dd75ad7c 44%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 45%undefine with_tls
f3f771b7
AM
46%endif
47%endif
48
e24149ab
PS
49%ifarch sparc64
50%undefine with_memusage
51%endif
52
3e233c2a 53%ifarch sparc
05743f54 54# broken
19eda128 55%undefine with_tls
3e233c2a
MM
56%endif
57
40240acb
JB
58%if %{with linuxthreads} && %{with nptl}
59%define with_dual 1
60%endif
61
121eb47e 62%define llh_version 7:2.6.6.0
969145b1 63%define _snap 20041122
e8c60795 64
236a5027 65Summary: GNU libc
66Summary(de): GNU libc
4a04bb32 67Summary(es): GNU libc
236a5027 68Summary(fr): GNU libc
c5387ad5 69