]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- fix alpha asm syntax
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
fd1d4127 10%bcond_without dist_kernel # for above, allow non-distribution kernel
61918272 11%bcond_with nptl # use nptl instead of linuxthreads
87146167 12%bcond_with tls # use tls
c9d8e545 13%bcond_with tests # perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec
AM
18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
19#
76f01b70
JB
20# WARNING:
21# posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
22# in order to use this version!
23#
61918272 24
3900e225 25%{!?min_kernel:%global min_kernel 2.4.6}
61918272 26
27%if %{with nptl}
dc3eddd2 28# it seems that nptl uses cmpxchgl (available since i486) on x86
6c5bdc1d 29%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
76131947
AM
30%if "%{min_kernel}" < "2.6.0"
31%global min_kernel 2.6.0
32%endif
61918272 33%else
3900e225
AM
34%undefine with_nptl
35%endif
61918272 36%endif
61918272 37
f3f771b7 38%if %{with tls}
dc3eddd2 39%ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
f3f771b7
AM
40%undefine with_tls
41%endif
42%endif
43
e8c60795 44%define llh_version 7:2.6.4.0
1a5bd9bb 45%define _snap 20040603
e8c60795 46
236a5027 47Summary: GNU libc
48Summary(de): GNU libc
4a04bb32 49Summary(es): GNU libc
236a5027 50Summary(fr): GNU libc
c5387ad5 51