]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- make it dual (with a little help from SuSE .spec); builds on x86
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
02f7fa95 3# default is 2.4.6 for linuxthreads, 2.6.0 for NPTL
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127 7%bcond_without memusage # don't build memusage utility
a7536a5d 8%bcond_with kernelheaders # use headers from %{_kernelsrcdir} instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
40240acb
JB
10%bcond_without linuxthreads # don't build linuxthreads version (NPTL only)
11%bcond_without nptl # don't build NPTL version (linuxthreads only)
12%bcond_with tls # use TLS in linuxthreads
757f96eb 13%bcond_without selinux # without SELinux support (in nscd)
c9d8e545 14%bcond_with tests # perform "make test"
0a85848c 15%bcond_without localedb # don't build localedb-all (is time consuming)
61918272 16
b287d865 17#
37cd6ebc
JB
18# TODO:
19# - localedb-gen man pages(?)
4acad1ec 20# - fix what trojan broke while upgreading (getaddrinfo-workaround)
feca75cc
JB
21# - math/{test-fenv,test-tgmath,test-float,test-ifloat},
22# linuxthreads/tst-cancel8, debug/backtrace-tst(SEGV) fail on alpha
cfac0d25
JB
23# - problem compiling with --enable-bounded (must be reported to libc-alpha)
24# (is this comment still valid???)
25
76f01b70 26#
61918272 27
3900e225 28%{!?min_kernel:%global min_kernel 2.4.6}
76131947 29%if "%{min_kernel}" < "2.6.0"
40240acb
JB
30%global nptl_min_kernel 2.6.0
31%else
32%global nptl_min_kernel %{min_kernel}
76131947 33%endif
40240acb
JB
34
35%if %{with nptl}
36# nptl on x86 uses cmpxchgl (available since i486)
37%ifnarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 alpha s390 s390x sparcv9 ppc ppc64
38%undefine with_nptl
3900e225 39%endif
61918272 40%endif
61918272 41
f3f771b7 42%if %{with tls}
dd75ad7c 43%ifnarch %{ix86} amd64 ia64 alpha s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 44%undefine with_tls
f3f771b7
AM
45%endif
46%endif
47
e24149ab
PS
48%ifarch sparc64
49%undefine with_memusage
50%endif
51
3e233c2a 52%ifarch sparc
05743f54 53# broken
19eda128 54%undefine with_tls
3e233c2a
MM
55%endif
56
40240acb
JB
57%if %{with linuxthreads} && %{with nptl}
58%define with_dual 1
59%endif
60
121eb47e 61%define llh_version 7:2.6.6.0
969145b1 62%define _snap 20041122
e8c60795 63
236a5027 64Summary: GNU libc
65Summary(de): GNU libc
4a04bb32 66Summary(es): GNU libc
236a5027 67Summary(fr): GNU libc
c5387ad5 68