]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- fix min_kernel for nptl
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
b05916ae 6%bcond_without fp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
9 # glibc-kernel-headers (evil, breakage etc., don't use)
10%bcond_without dist_kernel # for above, allow non-distribution kernel
11%bcond_with idn # build with included libidn
61918272 12%bcond_with nptl # use nptl instead of linuxthreads
adfd3b3d 13%bcond_without tests # do not perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec
AM
18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
19#
76f01b70
JB
20# WARNING:
21# posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
22# in order to use this version!
23#
61918272 24
3900e225 25%{!?min_kernel:%global min_kernel 2.4.6}
61918272 26
27%if %{with nptl}
3900e225 28%ifarch i686 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
76131947
AM
29%if "%{min_kernel}" < "2.6.0"
30%global min_kernel 2.6.0
31%endif
61918272 32%else
3900e225
AM
33%undefine with_nptl
34%endif
61918272 35%endif
61918272 36
adfd3b3d 37%define gkh_version 7:2.6.0.3
236a5027 38Summary: GNU libc
39Summary(de): GNU libc
4a04bb32 40Summary(es): GNU libc
236a5027 41Summary(fr): GNU libc
c5387ad5 42