]> git.pld-linux.org Git - packages/glibc.git/blame - glibc.spec
- added alpha-mq,alpha-typo patches - linking problems gone
[packages/glibc.git] / glibc.spec
CommitLineData
98a7741e 1#
2# You can define min_kernel macro by "rpm --define 'min_kernel version'"
742b2751 3# default is 2.4.6
029d2051 4#
b287d865 5# Conditional build:
60cb42b4 6%bcond_with omitfp # build without frame pointer (pass \--enable-omitfp)
fd1d4127
JB
7%bcond_without memusage # don't build memusage utility
8%bcond_with kernelheaders # use headers from kernel-headers instead of
b2327ef2 9 # linux-libc-headers (evil, breakage etc., don't use)
fd1d4127 10%bcond_without dist_kernel # for above, allow non-distribution kernel
5f56f24b 11%bcond_with nptl # use nptl instead of linuxthreads (implies tls)
87146167 12%bcond_with tls # use tls
c9d8e545 13%bcond_with tests # perform "make test"
61918272 14
b287d865 15#
37cd6ebc
JB
16# TODO:
17# - localedb-gen man pages(?)
4acad1ec 18# - fix what trojan broke while upgreading (getaddrinfo-workaround)
d22b4284 19# - fix ld.so.conf (while upgrading glibc it do NOW mv ld.so.conf ld.so.conf.rpmsave)
4acad1ec 20#
76f01b70
JB
21# WARNING:
22# posix zoneinfo dir removed, /etc/rc.d/init.d/timezone must be changed
23# in order to use this version!
24#
61918272 25
3900e225 26%{!?min_kernel:%global min_kernel 2.4.6}
61918272 27
28%if %{with nptl}
dc3eddd2 29# it seems that nptl uses cmpxchgl (available since i486) on x86
6c5bdc1d 30%ifarch i486 i586 i686 pentium3 pentium4 athlon amd64 ia64 s390 s390x sparcv9 ppc ppc64
76131947
AM
31%if "%{min_kernel}" < "2.6.0"
32%global min_kernel 2.6.0
33%endif
5f56f24b
JB
34# NPTL requires TLS
35%define with_tls 1
61918272 36%else
5f56f24b 37%undefine with_nptl
3900e225 38%endif
61918272 39%endif
61918272 40
f3f771b7 41%if %{with tls}
dc3eddd2 42%ifnarch %{ix86} amd64 ia64 s390 s390x sparc sparcv9 ppc ppc64
5f56f24b 43%undefine with_tls
f3f771b7
AM
44%endif
45%endif
46
e24149ab
PS
47%ifarch sparc64
48%undefine with_memusage
49%endif
50
121eb47e 51%define llh_version 7:2.6.6.0
fd57f63f 52%define _snap 20040623
e8c60795 53
236a5027 54Summary: GNU libc
55Summary(de): GNU libc
4a04bb32 56Summary(es): GNU libc
236a5027 57Summary(fr): GNU libc
c5387ad5 58