]> git.pld-linux.org Git - packages/chef.git/blame - chef.spec
update poldek patch: make action upgrade to see new package versions
[packages/chef.git] / chef.spec
CommitLineData
8354a17e
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
e307965b
ER
5Summary: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
6Name: chef
68cfa14e 7Version: 11.4.4
fd17fe50 8Release: 4
e307965b
ER
9License: Apache v2.0
10Group: Development/Languages
e307965b 11Source0: http://rubygems.org/downloads/%{name}-%{version}.gem
68cfa14e 12# Source0-md5: dc50aa6a4a7d4785a4c82fcaab3f9436
5cb2f1b0 13Source1: %{name}.rb
7abbc83b 14Patch0: platform-pld.patch
bc8e6547 15Patch1: FHS.patch
31feaf16 16Patch2: https://github.com/glensc/chef/compare/poldek.patch
fd17fe50 17# Patch2-md5: de55627051f1e0486d29814eb305c7f4
7fbe09ae 18Patch3: https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
d261b596 19# Patch3-md5: bfc884469fad7b5aa46341402be5fccd
2a1bbc08 20URL: http://wiki.opscode.com/display/chef
303651f6
ER
21BuildRequires: rpm-rubyprov
22BuildRequires: rpmbuild(macros) >= 1.656
68cfa14e
ER
23BuildRequires: sed >= 4.0
24%if %{with tests}
8354a17e
ER
25BuildRequires: ruby-abstract
26BuildRequires: ruby-mixlib-authentication >= 1.3.0
55a45456 27BuildRequires: ruby-net-ssh-multi >= 1.1.0
68cfa14e
ER
28BuildRequires: ruby-rack
29BuildRequires: ruby-rake
8354a17e 30#BuildRequires: ruby-rdoc
55a45456 31BuildRequires: ruby-rest-client >= 1.0.4
68cfa14e
ER
32BuildRequires: ruby-rspec-core >= 2.12.0
33BuildRequires: ruby-rspec-expectations >= 2.12.0
34BuildRequires: ruby-rspec-mocks >= 2.12.0
8354a17e
ER
35#BuildRequires: ruby-rspec_junit_formatter
36#BuildRequires: ruby-sdoc
68cfa14e 37%endif
97e7edae 38Requires: lsb-release
31feaf16 39Requires: poldek >= 0.30
bce16be1 40Requires: ruby-erubis
2a1bbc08 41Requires: ruby-highline >= 1.6.9
2a1bbc08
ER
42Requires: ruby-json >= 1.4.4
43Requires: ruby-mixlib-authentication >= 1.3.0
44Requires: ruby-mixlib-cli >= 1.3.0
bce16be1
ER
45Requires: ruby-mixlib-config >= 1.1.2
46Requires: ruby-mixlib-log >= 1.3.0
2a1bbc08
ER
47Requires: ruby-mixlib-shellout
48Requires: ruby-net-ssh >= 2.6
49Requires: ruby-net-ssh-multi >= 1.1.0
50Requires: ruby-ohai >= 0.6.0
2a1bbc08 51Requires: ruby-rest-client >= 1.0.4
bce16be1 52Requires: ruby-rubygems
2a1bbc08 53Requires: ruby-yajl >= 1.1
e307965b
ER
54BuildArch: noarch
55BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57%description
58A systems integration framework, built to bring the benefits of
59configuration management to your entire infrastructure.
60
61%prep
303651f6 62%setup -q
7abbc83b 63%patch0 -p1
bc8e6547 64%patch1 -p1
31feaf16 65%patch2 -p1
7fbe09ae 66%patch3 -p1
e307965b 67
68cfa14e
ER
68%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
69
8354a17e
ER
70%build
71%if %{with tests}
72rspec spec
73%endif
74
e307965b
ER
75%install
76rm -rf $RPM_BUILD_ROOT
958b507e 77install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1} \
bc8e6547 78 $RPM_BUILD_ROOT{%{_sysconfdir},/var/{cache,lib}}/%{name}
68cfa14e 79cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
e307965b 80cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
958b507e 81cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
e307965b 82
5cb2f1b0 83cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
303651f6 84
bce16be1
ER
85%clean
86rm -rf $RPM_BUILD_ROOT
87
e307965b
ER
88%files
89%defattr(644,root,root,755)
2a1bbc08 90%doc README.md CONTRIBUTING.md
303651f6 91%dir %{_sysconfdir}/%{name}
5cb2f1b0 92%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/chef.rb
2a1bbc08 93%attr(755,root,root) %{_bindir}/chef-apply
e307965b 94%attr(755,root,root) %{_bindir}/chef-client
2a1bbc08 95%attr(755,root,root) %{_bindir}/chef-shell
e307965b
ER
96%attr(755,root,root) %{_bindir}/chef-solo
97%attr(755,root,root) %{_bindir}/knife
98%attr(755,root,root) %{_bindir}/shef
958b507e
ER
99%{_mandir}/man1/chef-shell.1*
100%{_mandir}/man1/knife-bootstrap.1*
101%{_mandir}/man1/knife-client.1*
102%{_mandir}/man1/knife-configure.1*
103%{_mandir}/man1/knife-cookbook-site.1*
104%{_mandir}/man1/knife-cookbook.1*
105%{_mandir}/man1/knife-data-bag.1*
106%{_mandir}/man1/knife-environment.1*
107%{_mandir}/man1/knife-exec.1*
108%{_mandir}/man1/knife-index.1*
109%{_mandir}/man1/knife-node.1*
110%{_mandir}/man1/knife-role.1*
111%{_mandir}/man1/knife-search.1*
112%{_mandir}/man1/knife-ssh.1*
113%{_mandir}/man1/knife-status.1*
114%{_mandir}/man1/knife-tag.1*
115%{_mandir}/man1/knife.1*
116%{_mandir}/man8/chef-client.8*
117%{_mandir}/man8/chef-expander.8*
118%{_mandir}/man8/chef-expanderctl.8*
119%{_mandir}/man8/chef-server-webui.8*
120%{_mandir}/man8/chef-server.8*
121%{_mandir}/man8/chef-solo.8*
122%{_mandir}/man8/chef-solr.8*
68cfa14e
ER
123%{ruby_vendorlibdir}/chef.rb
124%{ruby_vendorlibdir}/chef
303651f6 125
bc8e6547
ER
126%dir /var/lib/%{name}
127%dir /var/cache/%{name}
This page took 0.074804 seconds and 4 git commands to generate.