]> git.pld-linux.org Git - packages/PackageKit.git/blame - PackageKit.spec
- unconditional noarch subpackages
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
d05d9108
MB
4#
5# Conditional build:
53810c7c
JB
6%bcond_without doc # build without docs
7%bcond_without introspection # gobject introspection, time to time broken
aa278a7b
JB
8%bcond_without static_libs # static library
9%bcond_without python # Python binding (used by entropy and portage backends)
10%bcond_without vala # Vala binding
11# backends
d06070b1 12%bcond_with alpm # ALPM (Arch Linux package manager) backend
04e18045 13%bcond_with apt # APT (Debian/Ubuntu) backend using C++ API
49ea0764 14%bcond_with dnf # DNF (Fedora/RHEL) backend
04e18045 15%bcond_with entropy # Entropy (Sabayon) backend (Python)
aa278a7b 16%bcond_with nix # Nix (NixOS) backend [broken as of 1.2.0]
04e18045
JB
17%bcond_without poldek # Poldek (PLD) backend
18%bcond_with portage # portage (Gentoo) backend (Python)
49ea0764 19%bcond_with slack # Slack (Slackware) backend
aa278a7b 20%bcond_with zypp # ZYPP (openSUSE/SLE) backend [broken as of 1.2.0]
0e84469f 21
aa278a7b
JB
22%if %{without python}
23%undefine with_entropy
24%undefine with_portage
04e18045 25%endif
0e84469f 26
85d27e4f
JB
27Summary: System daemon that is a D-Bus abstraction layer for package management
28Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 29Name: PackageKit
8271f320 30Version: 1.2.1
783c79a3 31Release: 1
a2d83637 32License: GPL v2+
85d27e4f 33Group: Applications/System
90405068 34Source0: https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
8271f320 35# Source0-md5: a0a1f7c45d25901cf4ff4318405610c3
02b3d2d3
JB
36Patch0: %{name}-poldek.patch
37Patch1: %{name}-bashcomp.patch
aa278a7b 38Patch2: %{name}-meson.patch
bcd7526e 39Patch3: consolekit-fallback.patch
90405068 40URL: https://www.freedesktop.org/software/PackageKit/
49ea0764 41%{?with_apt:BuildRequires: AppStream-devel >= 0.11}
a2d83637 42BuildRequires: NetworkManager-devel >= 0.6.5
49ea0764
JB
43# pkgconfig(libalpm) >= 12.0.0
44%{?with_alpm:BuildRequires: alpm-devel >= 5.2}
45%{?with_dnf:BuildRequires: appstream-glib-devel}
46%{?with_apt:BuildRequires: apt-devel >= 1.7}
577193a4 47BuildRequires: connman-devel
49ea0764 48%{?with_slack:BuildRequires: curl-devel}
6808f644 49BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 50BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 51BuildRequires: docbook-dtd412-xml
52BuildRequires: docbook-dtd42-xml
dac2b5e1 53BuildRequires: fontconfig-devel
a0f1aeda 54BuildRequires: gettext-tools
49ea0764 55BuildRequires: glib2-devel >= 1:2.54.0
53810c7c 56%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
57BuildRequires: gstreamer-devel >= 1.0.0
58BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
dac2b5e1 59BuildRequires: gtk+3-devel >= 3.0.0
577193a4 60%{?with_doc:BuildRequires: gtk-doc >= 1.11}
78293e06 61BuildRequires: libarchive-devel
aa278a7b 62%{?with_dnf:BuildRequires: libdnf-devel >= 0.43.1}
49ea0764
JB
63%if %{with apt} || %{with nix}
64BuildRequires: libstdc++-devel >= 6:4.7
65%endif
66%{?with_slack:BuildRequires: libstdc++-devel >= 6:5}
dac2b5e1 67BuildRequires: libxslt-progs
3b18414e 68%{?with_zypp:BuildRequires: libzypp-devel >= 15}
aa278a7b
JB
69BuildRequires: meson >= 0.47.0
70BuildRequires: ninja >= 1.5
49ea0764
JB
71# nix-expr nix-main nix-store
72%{?with_nix:BuildRequires: nix-devel >= 1.12}
dac2b5e1 73BuildRequires: pango-devel
a2d83637 74BuildRequires: pkgconfig
49ea0764
JB
75# when released; just to detect which reboot modes to use (library not linked)
76#BuildRequires: plymouth-devel >= 0.9.5
7cd3cbcf 77%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
49ea0764
JB
78BuildRequires: polkit-devel >= 0.114
79# or 1:3.2
02b3d2d3 80%{?with_python:BuildRequires: python-devel >= 1:2.7}
827cd5e7 81BuildRequires: readline-devel
49ea0764 82%{?with_dnf:BuildRequires: rpm-devel >= 4.?}
a2d83637 83BuildRequires: rpm-pythonprov
aa278a7b
JB
84BuildRequires: rpmbuild(macros) >= 1.736
85BuildRequires: sed >= 4.0
577193a4 86BuildRequires: sqlite3-devel >= 3
49ea0764 87BuildRequires: systemd-devel >= 1:213
e216f3d9 88BuildRequires: tar >= 1:1.22
9ed4ca79 89BuildRequires: udev-glib-devel
8ad97aee 90%{?with_vala:BuildRequires: vala >= 2:0.16}
e216f3d9 91BuildRequires: xz
fcd0bc5c 92Requires(post,postun): shared-mime-info
0d5f415c 93Requires: %{name}-backend
a2d83637 94Requires: %{name}-libs = %{version}-%{release}
8d48627e 95Requires: crondaemon
49ea0764 96Requires: polkit >= 0.114
48178e4e 97Suggests: ConsoleKit-x11
aa278a7b
JB
98Obsoletes: PackageKit-backend-pisi
99Obsoletes: PackageKit-backend-ports
02b3d2d3 100Obsoletes: PackageKit-backend-smart
aa278a7b 101Obsoletes: PackageKit-backend-urpmi
02b3d2d3 102Obsoletes: PackageKit-backend-yum
7cd3cbcf 103Obsoletes: PackageKit-docs < 0.8.4
d113818a 104Obsoletes: pm-utils-packagekit
a2d83637
MB
105BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107%description
108PackageKit is a D-Bus abstraction layer that allows the session user
109to manage packages in a secure way using a cross-distro,
110cross-architecture API.
111
85d27e4f
JB
112%description -l pl.UTF-8
113PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
114sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
115zgodnego z wieloma dystrybucjami i architekturami.
116
a2d83637 117%package libs
d05d9108
MB
118Summary: packagekit-glib library
119Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 120Group: Libraries
49ea0764
JB
121Requires: glib2 >= 1:2.54.0
122Obsoletes: browser-plugin-packagekit < 1.1.0
a2d83637
MB
123
124%description libs
d05d9108 125packagekit-glib library.
a2d83637
MB
126
127%description libs -l pl.UTF-8
d05d9108 128Biblioteka packagekit-glib.
a2d83637
MB
129
130%package devel
d05d9108
MB
131Summary: Header files for packagekit-glib library
132Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
133Group: Development/Libraries
134Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 135Requires: dbus-devel >= 1.2.0
49ea0764 136Requires: glib2-devel >= 1:2.54.0
9ed4ca79 137Requires: sqlite3-devel
a2d83637
MB
138
139%description devel
d05d9108 140Header files for packagekit-glib library.
a2d83637
MB
141
142%description devel -l pl.UTF-8
d05d9108 143Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
144
145%package static
d05d9108
MB
146Summary: Static packagekit-glib library
147Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
148Group: Development/Libraries
149Requires: %{name}-devel = %{version}-%{release}
150
151%description static
d05d9108 152Static packagekit-glib library.
a2d83637
MB
153
154%description static -l pl.UTF-8
d05d9108
MB
155Statyczna biblioteka packagekit-glib.
156
8ad97aee
JB
157%package -n vala-packagekit
158Summary: Vala API for PackageKit library
159Summary(pl.UTF-8): API języka Vala do biblioteki PackageKitu
160Group: Development/Libraries
161Requires: %{name}-devel = %{version}-%{release}
162Requires: vala >= 2:0.16
0e84469f 163BuildArch: noarch
8ad97aee
JB
164
165%description -n vala-packagekit
166Vala API for PackageKit library.
167
168%description -n vala-packagekit -l pl.UTF-8
169API języka Vala do biblioteki PackageKitu.
170
16acf8d5
JB
171%package apidocs
172Summary: PackageKit library API documentation
173Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
174Group: Documentation
175Requires: gtk-doc-common
2aa4ef3d 176BuildArch: noarch
16acf8d5
JB
177
178%description apidocs
179PackageKit library API documentation.
180
181%description apidocs -l pl.UTF-8
182Dokumentacja API biblioteki PackageKit.
183
d06070b1
JB
184%package backend-alpm
185Summary: PackageKit ALPM backend
186Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece ALPM
187Group: Libraries
188Requires: %{name} = %{version}-%{release}
189Provides: %{name}-backend = %{version}-%{release}
d06070b1
JB
190
191%description backend-alpm
192A backend for PackageKit to enable Arch Linux packages via ALPM
193library.
194
195%description backend-alpm -l pl.UTF-8
196Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
197bibliotekę ALPM.
198
04e18045
JB
199%package backend-aptcc
200Summary: PackageKit APTcc backend
201Summary(pl.UTF-8): Backend PackageKit APTcc
202Group: Libraries
203Requires: %{name} = %{version}-%{release}
49ea0764 204Requires: AppStream >= 0.11
04e18045
JB
205Provides: %{name}-backend = %{version}-%{release}
206
207%description backend-aptcc
208A backend for PackageKit to enable APT support via C++ API.
209
210%description backend-aptcc -l pl.UTF-8
211Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
212C++.
213
49ea0764
JB
214%package backend-dnf
215Summary: PackageKit dnf backend
216Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece dnfhif
217Group: Libraries
218Requires: %{name} = %{version}-%{release}
219Provides: %{name}-backend = %{version}-%{release}
220Obsoletes: PackageKit-backend-hawkey
221Obsoletes: PackageKit-backend-hif
222
223%description backend-dnf
224A backend for PackageKit to enable RPM packages support via dnf
225library (used in Fedora).
226
227%description backend-dnf -l pl.UTF-8
228Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
229dnf (używaną w dystrybucji Fedora).
230
04e18045
JB
231%package backend-entropy
232Summary: PackageKit Entropy backend
233Summary(pl.UTF-8): Backend PackageKit Entropy
234Group: Libraries
235Requires: %{name} = %{version}-%{release}
236Requires: python-packagekit = %{version}-%{release}
237#Requires: python-entropy
238Provides: %{name}-backend = %{version}-%{release}
239
240%description backend-entropy
241A backend for PackageKit to enable Sabayon packages support through
242Entropy package manager.
243
244%description backend-entropy -l pl.UTF-8
245Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
246użyciu zarządcy pakietów Entropy.
247
49ea0764
JB
248%package backend-nix
249Summary: PackageKit Nix backend
250Summary(pl.UTF-8): Backend PackageKit oparty na zarządcy pakietów Nix
04e18045
JB
251Group: Libraries
252Requires: %{name} = %{version}-%{release}
49ea0764 253Requires: nix >= 1.12
04e18045
JB
254Provides: %{name}-backend = %{version}-%{release}
255
49ea0764
JB
256%description backend-nix
257A backend for PackageKit to enable Nix packages support (used in
258NixOS).
04e18045 259
49ea0764
JB
260%description backend-nix -l pl.UTF-8
261Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
04e18045 262
0d5f415c
ER
263%package backend-poldek
264Summary: PackageKit Poldek backend
16acf8d5 265Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
266Group: Libraries
267Requires: %{name} = %{version}-%{release}
7cd3cbcf 268Requires: poldek >= 0.30-1.rc6.4
16acf8d5 269Provides: %{name}-backend = %{version}-%{release}
0d5f415c
ER
270
271%description backend-poldek
04e18045
JB
272A backend for PackageKit to enable RPM packages support through Poldek
273- native PLD package manager.
0d5f415c 274
16acf8d5 275%description backend-poldek -l pl.UTF-8
04e18045
JB
276Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
277natywnego zarządcę pakietów dystrybucji PLD.
278
279%package backend-portage
280Summary: PackageKit Portage backend
281Summary(pl.UTF-8): Backend PackageKit Portage
282Group: Libraries
283Requires: %{name} = %{version}-%{release}
284Requires: python-packagekit = %{version}-%{release}
285#Requires: python-portage
286Provides: %{name}-backend = %{version}-%{release}
287
288%description backend-portage
289A backend for PackageKit to enable Gentoo Portage support.
290
291%description backend-portage -l pl.UTF-8
292Backend PackageKit dodający obsługę systemu Portage dystrybucji
293Gentoo.
294
49ea0764
JB
295%package backend-slack
296Summary: PackageKit Slack backend
297Summary(pl.UTF-8): Backend PackageKit Slack
298Group: Libraries
299Requires: %{name} = %{version}-%{release}
300Provides: %{name}-backend = %{version}-%{release}
301Obsoletes: PackageKit-backend-katja
302
303%description backend-slack
304Slack backend for PackageKit to enable Slackware repositories support.
305
306%description backend-slack -l pl.UTF-8
307Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
308
04e18045
JB
309%package backend-zypp
310Summary: PackageKit Zypp backend
311Summary(pl.UTF-8): Backend PackageKit Zypp
312Group: Libraries
313Requires: %{name} = %{version}-%{release}
3b18414e 314Requires: libzypp >= 15
04e18045
JB
315Provides: %{name}-backend = %{version}-%{release}
316
317%description backend-zypp
318A backend for PackageKit to enable RPM packages support through Zypp
319library (originated in openSUSE/SLE).
320
321%description backend-zypp -l pl.UTF-8
322Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
323Zypp (pochodzącą z dystrybucji openSUSE/SLE).
16acf8d5 324
d05d9108
MB
325%package gstreamer-plugin
326Summary: GStreamer codecs installer
327Summary(pl.UTF-8): Instalator kodeków GStreamera
328Group: Applications
329Requires: %{name} = %{version}-%{release}
aa278a7b 330Requires: %{name}-gtk3-module = %{version}-%{release}
d05d9108
MB
331
332%description gstreamer-plugin
333The PackageKit GStreamer plugin allows any GStreamer application to
334install codecs from configured repositories using PackageKit.
335
336%description gstreamer-plugin -l pl.UTF-8
337Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
338zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
339
dac2b5e1
AF
340%package gtk3-module
341Summary: GTK+ 3.x module to detect and install missing fonts
342Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
343Group: X11/Libraries
aa278a7b 344Obsoletes: PackageKit-gtk-module < 1.2.0
dac2b5e1
AF
345
346%description gtk3-module
347The PackageKit GTK+ 3.x module allows any pango application to install
348missing fonts from configured repositories using PackageKit.
349
350%description gtk3-module -l pl.UTF-8
351Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
352brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
353
a2d83637 354%package -n bash-completion-packagekit
16acf8d5
JB
355Summary: Bash completion for PackageKit console commands
356Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 357Group: Applications/Shells
577193a4
JB
358Requires: %{name} = %{version}-%{release}
359Requires: bash-completion >= 2
ead2d2f6 360BuildArch: noarch
a2d83637
MB
361
362%description -n bash-completion-packagekit
16acf8d5 363This package provides bash-completion for PackageKit console commands.
a2d83637
MB
364
365%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
366Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
367konsolowych PackageKit.
a2d83637 368
a2d83637
MB
369%package -n python-packagekit
370Summary: PackageKit Python bindings
371Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
372Group: Development/Languages/Python
373Requires: python-dbus
374Requires: python-pygobject
375
376%description -n python-packagekit
377PackageKit Python bindings.
378
86086d14 379%description -n python-packagekit -l pl.UTF-8
a2d83637
MB
380Wiązania PackageKit dla Pythona.
381
382%prep
383%setup -q
d113818a 384%patch0 -p1
02b3d2d3 385%patch1 -p1
aa278a7b 386%patch2 -p1
bcd7526e 387%patch3 -p1
a2d83637 388
aa278a7b
JB
389%if %{with static_libs}
390%{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
d5617342 391%endif
aa278a7b
JB
392
393%build
04e18045 394%{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
aa278a7b
JB
395%meson build \
396 -Dbash_command_not_found=false \
397 -Dbash_completion_dir=%{bash_compdir} \
398 %{!?with_introspection:-Dgobject_introspection=false} \
399 %{?with_doc:-Dgtk_doc=true} \
400 -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
401 %{!?with_python:-Dpython_backend=false} \
402 -Dpythonpackagedir=%{py_sitescriptdir} \
403 -Dsystemdsystemunitdir=%{systemdunitdir}
404
405# TODO:
406# -Ddnf_vendor=
407# -Dpackagekit_user=
408
409%ninja_build -C build
a2d83637
MB
410
411%install
412rm -rf $RPM_BUILD_ROOT
aa278a7b 413install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
a2d83637 414
aa278a7b
JB
415%ninja_install -C build
416
417%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
a2d83637 418
5059111f
JB
419%if %{without apt} && %{without entropy} && %{without portage}
420# common dir not created if no users built with PackageKit
421install -d $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers
422%endif
423
d05d9108 424# use pk-gstreamer-install as codec installer
aa278a7b 425ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
d05d9108 426
aa278a7b
JB
427install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
428ln -sf ../packagekit-offline-update.service \
429 $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
430
431%if %{with python}
432%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
433%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
dac2b5e1 434
a2d83637 435%py_postclean
aa278a7b 436%endif
a2d83637 437
6808f644
MB
438%find_lang %{name}
439
a2d83637
MB
440%clean
441rm -rf $RPM_BUILD_ROOT
442
fcd0bc5c
MB
443%post
444%update_mime_database
445
446%postun
447%update_mime_database
448
85d27e4f 449%post libs -p /sbin/ldconfig
a2d83637
MB
450%postun libs -p /sbin/ldconfig
451
6808f644 452%files -f %{name}.lang
a2d83637 453%defattr(644,root,root,755)
02b3d2d3 454%doc AUTHORS HACKING MAINTAINERS NEWS README
a2d83637
MB
455%attr(755,root,root) %{_bindir}/pkcon
456%attr(755,root,root) %{_bindir}/pkmon
50832223 457%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
02b3d2d3
JB
458%attr(755,root,root) %{_libexecdir}/packagekit-direct
459%attr(755,root,root) %{_libexecdir}/packagekitd
460%attr(755,root,root) %{_libexecdir}/pk-offline-update
a2d83637 461%dir %{_libdir}/packagekit-backend
aa278a7b 462%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
a2d83637
MB
463%dir %{_sysconfdir}/PackageKit
464%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 465%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
5baab3aa
ER
466%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
467/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
d05d9108 468%dir %{_datadir}/PackageKit
6e66a3a4 469%dir %{_datadir}/PackageKit/helpers
d05d9108 470%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 471%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 472%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 473%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
a2d83637 474%{_mandir}/man1/pkcon.1*
78293e06 475%{_mandir}/man1/pkmon.1*
53810c7c 476%{systemdunitdir}/packagekit.service
7cd3cbcf 477%{systemdunitdir}/packagekit-offline-update.service
02b3d2d3 478%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
78293e06
MB
479%dir /var/cache/PackageKit
480%dir /var/cache/PackageKit/downloads
a2d83637 481%dir /var/lib/PackageKit
d05d9108 482%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
483
484%files libs
485%defattr(644,root,root,755)
74872af2 486%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
02b3d2d3 487%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
dac2b5e1 488%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
2ab9cd42
JB
489# NOTE: dbus interface xmls are commonly used:
490# - at runtime by packagekitd
491# - for development of applications using PK dbus interface
492%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
493%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 494
a2d83637
MB
495%files devel
496%defattr(644,root,root,755)
74872af2 497%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 498%{_pkgconfigdir}/packagekit-glib2.pc
d05d9108 499%dir %{_includedir}/PackageKit
74872af2 500%{_includedir}/PackageKit/packagekit-glib2
dac2b5e1 501%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
08c67dac 502
a2d83637
MB
503%files static
504%defattr(644,root,root,755)
74872af2 505%{_libdir}/libpackagekit-glib2.a
d05d9108 506
8ad97aee
JB
507%if %{with vala}
508%files -n vala-packagekit
509%defattr(644,root,root,755)
aa278a7b 510%{_datadir}/vala/vapi/packagekit-glib2.deps
8ad97aee
JB
511%{_datadir}/vala/vapi/packagekit-glib2.vapi
512%endif
513
16acf8d5
JB
514%files apidocs
515%defattr(644,root,root,755)
516%{_gtkdocdir}/PackageKit
517
d06070b1
JB
518%if %{with alpm}
519%files backend-alpm
0d5f415c 520%defattr(644,root,root,755)
d06070b1
JB
521%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
522%dir %{_sysconfdir}/PackageKit/alpm.d
523%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
524%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
525%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
0d5f415c
ER
526%endif
527
04e18045
JB
528%if %{with apt}
529%files backend-aptcc
530%defattr(644,root,root,755)
531%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
532%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
533%dir %{_datadir}/PackageKit/helpers/aptcc
534%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
535%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
536%{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
537%endif
538
49ea0764
JB
539%if %{with dnf}
540%files backend-dnf
541%defattr(644,root,root,755)
542%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
543%endif
544
04e18045
JB
545%if %{with entropy}
546%files backend-entropy
547%defattr(644,root,root,755)
548%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
549%dir %{_datadir}/PackageKit/helpers/entropy
550%attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
551%endif
552
49ea0764
JB
553%if %{with nix}
554%files backend-nix
ee375c30 555%defattr(644,root,root,755)
49ea0764 556%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
04e18045
JB
557%endif
558
d06070b1
JB
559%if %{with poldek}
560%files backend-poldek
561%defattr(644,root,root,755)
562%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
563%endif
564
04e18045
JB
565%if %{with portage}
566%files backend-portage
567%defattr(644,root,root,755)
568%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
569%dir %{_datadir}/PackageKit/helpers/portage
570%attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
571%endif
572
49ea0764
JB
573%if %{with slack}
574%files backend-slack
575%defattr(644,root,root,755)
576%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
577%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
578%dir /var/cache/PackageKit/metadata
579%ghost /var/cache/PackageKit/metadata/metadata.db
580%endif
581
04e18045
JB
582%if %{with zypp}
583%files backend-zypp
584%defattr(644,root,root,755)
585%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
586%endif
587
d05d9108
MB
588%files gstreamer-plugin
589%defattr(644,root,root,755)
590%doc contrib/gstreamer-plugin/README
aa278a7b 591%attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
02b3d2d3 592%attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
d05d9108 593
dac2b5e1
AF
594%files gtk3-module
595%defattr(644,root,root,755)
aa278a7b 596%doc contrib/gtk-module/{GLASS.txt,README}
dac2b5e1 597%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 598%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 599
a2d83637
MB
600%files -n bash-completion-packagekit
601%defattr(644,root,root,755)
577193a4 602%{bash_compdir}/pkcon
a2d83637 603
02b3d2d3 604%if %{with python}
a2d83637
MB
605%files -n python-packagekit
606%defattr(644,root,root,755)
607%dir %{py_sitescriptdir}/packagekit
608%{py_sitescriptdir}/packagekit/*.py[co]
02b3d2d3 609%endif
This page took 0.239279 seconds and 4 git commands to generate.