- updated to 0.8.11
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108 1# TODO:
577193a4 2# - send poldek patch upstream
d05d9108
MB
3# - BASH command-not-found functionality disabled for now as it needs patched bash
4# (details in bash from Fedora Rawhide)
d05d9108
MB
5#
6# Conditional build:
9b8153ef 7%bcond_without doc # build without docs
dac2b5e1 8%bcond_without gir # gobject introspection, time to time broken
616fad64
ER
9%bcond_without poldek # build Poldek backend
10%bcond_without smart # build SMART backend
7cd3cbcf 11%bcond_without yum # build YUM backend
616fad64 12%bcond_with browser # build browser plugin (patrys says: it's flawed by concept)
dc10d5ba 13
0d5f415c 14# default backend, configurable at runtime
dc10d5ba 15%define backend poldek
48a22c3c 16
85d27e4f
JB
17Summary: System daemon that is a D-Bus abstraction layer for package management
18Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 19Name: PackageKit
577193a4
JB
20Version: 0.8.11
21Release: 1
a2d83637 22License: GPL v2+
85d27e4f 23Group: Applications/System
e216f3d9 24Source0: http://www.packagekit.org/releases/%{name}-%{version}.tar.xz
577193a4
JB
25# Source0-md5: 676ebf95830373b84d5599f4e5039b72
26Patch0: %{name}-poldek.patch
d05d9108 27Patch1: %{name}-PLD.patch
36ca2380 28Patch2: bashism.patch
d6bb3abf 29Patch3: smart-at-fix.patch
577193a4
JB
30Patch4: %{name}-gstreamer.patch
31Patch5: %{name}-bashcomp.patch
32Patch6: %{name}-connman.patch
a2d83637
MB
33URL: http://www.packagekit.org/
34BuildRequires: NetworkManager-devel >= 0.6.5
600be41c 35BuildRequires: autoconf >= 2.65
577193a4
JB
36BuildRequires: automake >= 1:1.11
37BuildRequires: connman-devel
6808f644 38BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 39BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 40BuildRequires: docbook-dtd412-xml
41BuildRequires: docbook-dtd42-xml
dac2b5e1 42BuildRequires: fontconfig-devel
a2d83637 43BuildRequires: gettext-devel
577193a4
JB
44BuildRequires: glib2-devel >= 1:2.30.0
45%{?with_gir:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
46BuildRequires: gstreamer-devel >= 1.0.0
47BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
d05d9108 48BuildRequires: gtk+2-devel >= 2:2.14.0
dac2b5e1 49BuildRequires: gtk+3-devel >= 3.0.0
577193a4 50%{?with_doc:BuildRequires: gtk-doc >= 1.11}
d05d9108 51BuildRequires: intltool >= 0.35.0
78293e06 52BuildRequires: libarchive-devel
a2d83637 53BuildRequires: libtool
dac2b5e1
AF
54BuildRequires: libxslt-progs
55BuildRequires: pango-devel
a2d83637 56BuildRequires: pkgconfig
bdd8c0ca 57BuildRequires: pm-utils
7cd3cbcf 58%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
577193a4
JB
59BuildRequires: polkit-devel >= 0.98
60BuildRequires: python-devel >= 1:2.7
827cd5e7 61BuildRequires: readline-devel
a2d83637 62BuildRequires: rpm-pythonprov
85d27e4f 63BuildRequires: rpmbuild(macros) >= 1.311
577193a4
JB
64BuildRequires: sqlite3-devel >= 3
65BuildRequires: systemd-devel
e216f3d9 66BuildRequires: tar >= 1:1.22
9ed4ca79 67BuildRequires: udev-glib-devel
e216f3d9 68BuildRequires: xz
dac2b5e1
AF
69%if %{with browser}
70BuildRequires: cairo-devel
a92a33f7
ŁK
71BuildRequires: nspr-devel >= 4.8
72BuildRequires: xulrunner-devel >= 8.0
dac2b5e1 73%endif
fcd0bc5c 74Requires(post,postun): shared-mime-info
0d5f415c 75Requires: %{name}-backend
a2d83637 76Requires: %{name}-libs = %{version}-%{release}
5d2bfc22 77Requires: ConsoleKit-x11
8d48627e 78Requires: crondaemon
9ed4ca79 79Requires: polkit >= 0.92
7cd3cbcf 80Obsoletes: PackageKit-docs < 0.8.4
a2d83637
MB
81BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83%description
84PackageKit is a D-Bus abstraction layer that allows the session user
85to manage packages in a secure way using a cross-distro,
86cross-architecture API.
87
85d27e4f
JB
88%description -l pl.UTF-8
89PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
90sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
91zgodnego z wieloma dystrybucjami i architekturami.
92
a2d83637 93%package libs
d05d9108
MB
94Summary: packagekit-glib library
95Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 96Group: Libraries
577193a4 97Requires: glib2 >= 1:2.30.0
a2d83637
MB
98
99%description libs
d05d9108 100packagekit-glib library.
a2d83637
MB
101
102%description libs -l pl.UTF-8
d05d9108 103Biblioteka packagekit-glib.
a2d83637
MB
104
105%package devel
d05d9108
MB
106Summary: Header files for packagekit-glib library
107Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
108Group: Development/Libraries
109Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 110Requires: dbus-devel >= 1.2.0
577193a4 111Requires: glib2-devel >= 1:2.30.0
9ed4ca79 112Requires: sqlite3-devel
a2d83637
MB
113
114%description devel
d05d9108 115Header files for packagekit-glib library.
a2d83637
MB
116
117%description devel -l pl.UTF-8
d05d9108 118Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
119
120%package static
d05d9108
MB
121Summary: Static packagekit-glib library
122Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
123Group: Development/Libraries
124Requires: %{name}-devel = %{version}-%{release}
125
126%description static
d05d9108 127Static packagekit-glib library.
a2d83637
MB
128
129%description static -l pl.UTF-8
d05d9108
MB
130Statyczna biblioteka packagekit-glib.
131
0d5f415c
ER
132%package backend-poldek
133Summary: PackageKit Poldek backend
134Group: Libraries
135Requires: %{name} = %{version}-%{release}
7cd3cbcf 136Requires: poldek >= 0.30-1.rc6.4
0d5f415c
ER
137Provides: %{name}-backend
138Conflicts: %{name} < 0.6.8-3
139
140%description backend-poldek
141A backend for PackageKit to enable Poldek functionality.
142
616fad64
ER
143%package backend-smart
144Summary: PackageKit SMART backend
145Group: Libraries
146Requires: %{name} = %{version}-%{release}
147Requires: smart
148
149%description backend-smart
150A backend for PackageKit to enable SMART functionality.
151
152%package backend-yum
153Summary: PackageKit YUM backend
154Group: Libraries
155Requires: %{name} = %{version}-%{release}
156Requires: python-packagekit = %{version}-%{release}
157Requires: yum >= 3.2.19
158Provides: %{name}-backend
159
160%description backend-yum
161A backend for PackageKit to enable yum functionality.
162
a2d83637
MB
163%package apidocs
164Summary: PackageKit library API documentation
165Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
166Group: Documentation
167Requires: gtk-doc-common
168
169%description apidocs
170PackageKit library API documentation.
171
172%description apidocs -l pl.UTF-8
173Dokumentacja API biblioteki PackageKit.
174
d05d9108
MB
175%package gstreamer-plugin
176Summary: GStreamer codecs installer
177Summary(pl.UTF-8): Instalator kodeków GStreamera
178Group: Applications
179Requires: %{name} = %{version}-%{release}
5baab3aa 180Requires: %{name}-gtk-module = %{version}-%{release}
d05d9108
MB
181
182%description gstreamer-plugin
183The PackageKit GStreamer plugin allows any GStreamer application to
184install codecs from configured repositories using PackageKit.
185
186%description gstreamer-plugin -l pl.UTF-8
187Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
188zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
189
190%package gtk-module
191Summary: GTK+ module to detect and install missing fonts
192Summary(pl.UTF-8): Moduł GTK+ do wykrywania i instalowania brakujących czcionek
193Group: X11/Libraries
194
195%description gtk-module
196The PackageKit GTK+ module allows any pango application to install
197missing fonts from configured repositories using PackageKit.
198
199%description gtk-module -l pl.UTF-8
200Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
201brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
202
dac2b5e1
AF
203%package gtk3-module
204Summary: GTK+ 3.x module to detect and install missing fonts
205Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
206Group: X11/Libraries
207
208%description gtk3-module
209The PackageKit GTK+ 3.x module allows any pango application to install
210missing fonts from configured repositories using PackageKit.
211
212%description gtk3-module -l pl.UTF-8
213Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
214brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
215
a2d83637
MB
216%package -n bash-completion-packagekit
217Summary: bash-completion for PackageKit
218Summary(pl.UTF-8): bashowe uzupełnianie nazw dla PackageKit
219Group: Applications/Shells
577193a4
JB
220Requires: %{name} = %{version}-%{release}
221Requires: bash-completion >= 2
a2d83637
MB
222
223%description -n bash-completion-packagekit
224This package provides bash-completion for PackageKit.
225
226%description -n bash-completion-packagekit -l pl.UTF-8
227Pakiet ten dostarcza bashowe uzupełnianie nazw dla PackageKit.
228
229%package -n pm-utils-packagekit
230Summary: PackageKit script for pm-utils
85d27e4f 231Summary(pl.UTF-8): Skrypt PackageKit dla pm-utils
a2d83637
MB
232Group: Applications/System
233Requires: pm-utils
234
235%description -n pm-utils-packagekit
236PackageKit script for pm-utils.
237
85d27e4f
JB
238%description -n pm-utils-packagekit -l pl.UTF-8
239Skrypt PackageKit dla pm-utils.
240
a2d83637
MB
241%package -n python-packagekit
242Summary: PackageKit Python bindings
243Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
244Group: Development/Languages/Python
245Requires: python-dbus
246Requires: python-pygobject
247
248%description -n python-packagekit
249PackageKit Python bindings.
250
86086d14 251%description -n python-packagekit -l pl.UTF-8
a2d83637
MB
252Wiązania PackageKit dla Pythona.
253
dac2b5e1
AF
254%package -n browser-plugin-packagekit
255Summary: PackageKit's browser plugin
256Summary(pl.UTF-8): Wtyczka PackageKit do przeglądarek WWW
257Group: X11/Libraries
258Requires: %{name} = %{version}-%{release}
259Requires: browser-plugins >= 2.0
260Requires: browser-plugins(%{_target_base_arch})
261
262%description -n browser-plugin-packagekit
263PackageKit's plugin for browsers.
264
265%description -n browser-plugin-packagekit -l pl.UTF-8
266Wtyczka PackageKit do przeglądarek WWW.
267
a2d83637
MB
268%prep
269%setup -q
577193a4 270%patch0 -p1
d05d9108 271%patch1 -p1
36ca2380 272%patch2 -p1
7333f3ce 273%patch3 -p0
7cd3cbcf
MB
274%patch4 -p1
275%patch5 -p1
577193a4 276%patch6 -p1
a2d83637
MB
277
278%build
9b8153ef 279%if %{with doc}
d05d9108 280%{__gtkdocize}
d5617342 281%endif
58e98be4 282%{__intltoolize}
a2d83637 283%{__libtoolize}
d05d9108 284%{__aclocal} -I m4
a2d83637
MB
285%{__autoconf}
286%{__autoheader}
287%{__automake}
288%configure \
d05d9108 289 --disable-command-not-found \
577193a4
JB
290 --disable-dummy \
291 %{!?with_doc:--disable-gtk-doc} \
6e66a3a4 292 %{!?with_gir:--disable-introspection} \
577193a4
JB
293 --disable-silent-rules \
294 --enable-bash-completion=%{bash_compdir} \
dac2b5e1
AF
295 %{__enable_disable browser browser-plugin} \
296 %{__enable_disable poldek} \
616fad64 297 %{__enable_disable smart} \
dac2b5e1 298 %{__enable_disable yum} \
dac2b5e1 299 --with-default-backend=%{backend} \
577193a4
JB
300 --with-html-dir=%{_gtkdocdir} \
301 --with-mozilla-plugin-dir=%{_browserpluginsdir} \
302 --with-security-framework=polkit
a2d83637
MB
303%{__make}
304
305%install
306rm -rf $RPM_BUILD_ROOT
307
308%{__make} install \
309 DESTDIR=$RPM_BUILD_ROOT
310
d05d9108
MB
311# use pk-gstreamer-install as codec installer
312ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
313
684bfa1d 314install -d $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d
aa2113f5 315install -p contrib/pm-utils/95packagekit $RPM_BUILD_ROOT%{_libdir}/pm-utils/sleep.d
684bfa1d 316
dac2b5e1
AF
317%{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
318%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
319%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
7cd3cbcf 320%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-plugins/*.{la,a}
dac2b5e1
AF
321%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
322%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
323
324%if %{with browser}
325%{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.{la,a}
326%endif
a2d83637 327
8c9d69e0
ER
328%if %{with yum}
329# yumBackend.py can't be compiled (invoked directly), other should be compiled
330%py_comp $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum
331%py_ocomp $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum
dac2b5e1
AF
332%{__rm} $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum/yum{Comps,Filter}.py
333%{__rm} $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum/yumBackend.py[co]
8c9d69e0
ER
334%endif
335
577193a4 336# outdated copy of it
a92a33f7 337%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/it_IT
9fced724 338
a2d83637
MB
339%py_postclean
340
6808f644
MB
341%find_lang %{name}
342
a2d83637
MB
343%clean
344rm -rf $RPM_BUILD_ROOT
345
fcd0bc5c
MB
346%post
347%update_mime_database
348
349%postun
350%update_mime_database
351
85d27e4f 352%post libs -p /sbin/ldconfig
a2d83637
MB
353%postun libs -p /sbin/ldconfig
354
dac2b5e1
AF
355%post -n browser-plugin-packagekit
356%update_browser_plugins
357
358%postun -n browser-plugin-packagekit
359if [ "$1" = 0 ]; then
360 %update_browser_plugins
361fi
362
6808f644 363%files -f %{name}.lang
a2d83637 364%defattr(644,root,root,755)
577193a4 365%doc AUTHORS HACKING MAINTAINERS NEWS README TODO
a2d83637 366%attr(755,root,root) %{_bindir}/packagekit-bugreport.sh
a2d83637 367%attr(755,root,root) %{_bindir}/pkcon
78293e06 368%attr(755,root,root) %{_bindir}/pkgenpack
a2d83637 369%attr(755,root,root) %{_bindir}/pkmon
a382d619 370%attr(755,root,root) %{_bindir}/pk-debuginfo-install
8d48627e 371%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
a2d83637 372%dir %{_libdir}/packagekit-backend
7cd3cbcf
MB
373%dir %{_libdir}/packagekit-plugins
374%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-check-shared-libraries-in-use.so
375%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-clear-firmware-requests.so
7cd3cbcf 376%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-no-update-process.so
577193a4 377%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-require-restart.so
7cd3cbcf
MB
378%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-scan-desktop-files.so
379%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-systemd-updates.so
380%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-update-check-processes.so
381%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-update-package-cache.so
382%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin_scripts.so
aa2113f5 383%attr(755,root,root) %{_libdir}/packagekitd
7cd3cbcf
MB
384%attr(755,root,root) %{_libdir}/pk-clear-offline-update
385%attr(755,root,root) %{_libdir}/pk-offline-update
386%attr(755,root,root) %{_libdir}/pk-trigger-offline-update
9ed4ca79 387%attr(755,root,root) %{_sbindir}/pk-device-rebind
a2d83637
MB
388%dir %{_sysconfdir}/PackageKit
389%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 390%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
dac2b5e1
AF
391%dir %{_sysconfdir}/PackageKit/events
392%{_sysconfdir}/PackageKit/events/post-transaction.d
393%{_sysconfdir}/PackageKit/events/pre-transaction.d
5baab3aa
ER
394%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
395/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
d05d9108 396%dir %{_datadir}/PackageKit
6e66a3a4 397%dir %{_datadir}/PackageKit/helpers
d05d9108 398%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 399%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 400%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
7cd3cbcf
MB
401%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
402%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
a2d83637 403%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
d05d9108 404%{_datadir}/mime/packages/packagekit-catalog.xml
08c67dac 405%{_datadir}/mime/packages/packagekit-package-list.xml
406%{_datadir}/mime/packages/packagekit-servicepack.xml
a2d83637 407%{_mandir}/man1/pkcon.1*
f058dba9 408%{_mandir}/man1/pk-debuginfo-install.1*
9ed4ca79 409%{_mandir}/man1/pk-device-rebind.1*
78293e06
MB
410%{_mandir}/man1/pkgenpack.1*
411%{_mandir}/man1/pkmon.1*
7cd3cbcf 412%{systemdunitdir}/packagekit-offline-update.service
78293e06
MB
413%dir /var/cache/PackageKit
414%dir /var/cache/PackageKit/downloads
a2d83637 415%dir /var/lib/PackageKit
d05d9108 416%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
417
418%files libs
419%defattr(644,root,root,755)
74872af2 420%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
7cd3cbcf 421%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.16
dac2b5e1 422%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
7cd3cbcf 423%{_libdir}/girepository-1.0/PackageKitPlugin-1.0.typelib
08c67dac 424
a2d83637
MB
425%files devel
426%defattr(644,root,root,755)
74872af2 427%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 428%{_pkgconfigdir}/packagekit-glib2.pc
7cd3cbcf 429%{_pkgconfigdir}/packagekit-plugin.pc
d05d9108 430%dir %{_includedir}/PackageKit
74872af2 431%{_includedir}/PackageKit/packagekit-glib2
7cd3cbcf 432%{_includedir}/PackageKit/plugin
dac2b5e1 433%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
7cd3cbcf 434%{_datadir}/gir-1.0/PackageKitPlugin-1.0.gir
08c67dac 435
a2d83637
MB
436%files static
437%defattr(644,root,root,755)
74872af2 438%{_libdir}/libpackagekit-glib2.a
d05d9108 439
0d5f415c
ER
440%if %{with poldek}
441%files backend-poldek
442%defattr(644,root,root,755)
443%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
444%endif
445
616fad64
ER
446%if %{with smart}
447%files backend-smart
448%defattr(644,root,root,755)
449%{_libdir}/packagekit-backend/libpk_backend_smart.so
450%dir %{_datadir}/PackageKit/helpers/smart
9a97bfb7 451%attr(755,root,root) %{_datadir}/PackageKit/helpers/smart/smartBackend.py
616fad64
ER
452%endif
453
0d5f415c
ER
454%if %{with yum}
455%files backend-yum
456%defattr(644,root,root,755)
457%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Yum.conf
458%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_yum.so
459%dir %{_datadir}/PackageKit/helpers/yum
460%{_datadir}/PackageKit/helpers/yum/licenses.txt
461%{_datadir}/PackageKit/helpers/yum/yum-comps-groups.conf
462%attr(755,root,root) %{_datadir}/PackageKit/helpers/yum/yumBackend.py
463%{_datadir}/PackageKit/helpers/yum/yumComps.py[co]
464%{_datadir}/PackageKit/helpers/yum/yumFilter.py[co]
465
466# yum plugin
467%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/refresh-packagekit.conf
468%{_prefix}/lib/yum-plugins/refresh-packagekit.py
469%endif
470
a2d83637
MB
471%files apidocs
472%defattr(644,root,root,755)
473%{_gtkdocdir}/PackageKit
474
d05d9108
MB
475%files gstreamer-plugin
476%defattr(644,root,root,755)
477%doc contrib/gstreamer-plugin/README
478%attr(755,root,root) %{_libdir}/gst-install-plugins-helper
479%attr(755,root,root) %{_libdir}/pk-gstreamer-install
480
481%files gtk-module
482%defattr(644,root,root,755)
483%doc contrib/gtk-module/{GLASS.txt,README}
484%attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
485
dac2b5e1
AF
486%files gtk3-module
487%defattr(644,root,root,755)
488%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 489%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 490
a2d83637
MB
491%files -n bash-completion-packagekit
492%defattr(644,root,root,755)
577193a4 493%{bash_compdir}/pkcon
a2d83637
MB
494
495%files -n pm-utils-packagekit
496%defattr(644,root,root,755)
d05d9108 497%attr(755,root,root) %{_libdir}/pm-utils/sleep.d/95packagekit
a2d83637
MB
498
499%files -n python-packagekit
500%defattr(644,root,root,755)
501%dir %{py_sitescriptdir}/packagekit
502%{py_sitescriptdir}/packagekit/*.py[co]
dac2b5e1
AF
503
504%if %{with browser}
505%files -n browser-plugin-packagekit
506%defattr(644,root,root,755)
507%attr(755,root,root) %{_browserpluginsdir}/packagekit-plugin.so
508%endif
This page took 0.190807 seconds and 4 git commands to generate.