]> git.pld-linux.org Git - packages/PackageKit.git/blame - PackageKit.spec
- drop system-update.target.wants - it belongs to systemd.spec
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
d05d9108
MB
4#
5# Conditional build:
53810c7c
JB
6%bcond_without doc # build without docs
7%bcond_without introspection # gobject introspection, time to time broken
d06070b1 8%bcond_with alpm # ALPM (Arch Linux package manager) backend
04e18045
JB
9%bcond_with apt # APT (Debian/Ubuntu) backend using C++ API
10%bcond_with entropy # Entropy (Sabayon) backend (Python)
11%bcond_with hif # HIF (Fedora/RHEL) backend
12%bcond_with katja # Katja (Slackware) backend
13%bcond_with pisi # PiSi (Pardus) backend (Python)
14%bcond_without poldek # Poldek (PLD) backend
15%bcond_with portage # portage (Gentoo) backend (Python)
16%bcond_with ports # ports (FreeBSD) backend (Ruby)
17%bcond_with urpmi # urpmi (Mandriva/Mageia) backend (Perl)
18%bcond_with zypp # ZYPP (openSUSE/SLE) backend
19%bcond_without python # Python binding (only for a few backends)
8ad97aee 20%bcond_without vala # Vala binding
53810c7c 21%bcond_with browser # browser plugin (patrys says: it's flawed by concept)
0e84469f
ER
22
23# Python binding is built when building any python binding
04e18045
JB
24%if %{without entropy} && %{without pisi} && %{without ports}
25%undefine with_python
26%endif
0e84469f 27
85d27e4f
JB
28Summary: System daemon that is a D-Bus abstraction layer for package management
29Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 30Name: PackageKit
3b18414e 31Version: 1.0.11
0e84469f 32Release: 2
a2d83637 33License: GPL v2+
85d27e4f 34Group: Applications/System
66e86606 35Source0: http://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
3b18414e 36# Source0-md5: f7ab847e87328d4bee155bcada10dcba
02b3d2d3
JB
37Patch0: %{name}-poldek.patch
38Patch1: %{name}-bashcomp.patch
04e18045 39Patch2: %{name}-format.patch
bcd7526e 40Patch3: consolekit-fallback.patch
3b18414e 41Patch4: %{name}-zypp.patch
a2d83637
MB
42URL: http://www.packagekit.org/
43BuildRequires: NetworkManager-devel >= 0.6.5
d06070b1
JB
44# pkgconfig(libalpm) >= 8.2.0
45%{?with_alpm:BuildRequires: alpm-devel >= 4}
ee375c30 46%{?with_hif:BuildRequires: appstream-glib-devel}
04e18045 47%{?with_apt:BuildRequires: apt-devel >= 0.7}
600be41c 48BuildRequires: autoconf >= 2.65
577193a4
JB
49BuildRequires: automake >= 1:1.11
50BuildRequires: connman-devel
04e18045 51%{?with_katja:BuildRequires: curl-devel}
6808f644 52BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 53BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 54BuildRequires: docbook-dtd412-xml
55BuildRequires: docbook-dtd42-xml
dac2b5e1 56BuildRequires: fontconfig-devel
a0f1aeda 57BuildRequires: gettext-tools
53810c7c
JB
58BuildRequires: glib2-devel >= 1:2.32.0
59%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
60BuildRequires: gstreamer-devel >= 1.0.0
61BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
d05d9108 62BuildRequires: gtk+2-devel >= 2:2.14.0
dac2b5e1 63BuildRequires: gtk+3-devel >= 3.0.0
577193a4 64%{?with_doc:BuildRequires: gtk-doc >= 1.11}
d05d9108 65BuildRequires: intltool >= 0.35.0
78293e06 66BuildRequires: libarchive-devel
ee375c30 67%{?with_hif:BuildRequires: libhif-devel >= 0.1.7}
a2d83637 68BuildRequires: libtool
dac2b5e1 69BuildRequires: libxslt-progs
3b18414e 70%{?with_zypp:BuildRequires: libzypp-devel >= 15}
dac2b5e1 71BuildRequires: pango-devel
a2d83637 72BuildRequires: pkgconfig
7cd3cbcf 73%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
577193a4 74BuildRequires: polkit-devel >= 0.98
02b3d2d3 75%{?with_python:BuildRequires: python-devel >= 1:2.7}
827cd5e7 76BuildRequires: readline-devel
a2d83637 77BuildRequires: rpm-pythonprov
85d27e4f 78BuildRequires: rpmbuild(macros) >= 1.311
577193a4 79BuildRequires: sqlite3-devel >= 3
8ad97aee 80BuildRequires: systemd-devel >= 1:209
e216f3d9 81BuildRequires: tar >= 1:1.22
9ed4ca79 82BuildRequires: udev-glib-devel
8ad97aee 83%{?with_vala:BuildRequires: vala >= 2:0.16}
e216f3d9 84BuildRequires: xz
dac2b5e1
AF
85%if %{with browser}
86BuildRequires: cairo-devel
a92a33f7 87BuildRequires: nspr-devel >= 4.8
04e18045 88BuildRequires: pango-devel
a92a33f7 89BuildRequires: xulrunner-devel >= 8.0
dac2b5e1 90%endif
fcd0bc5c 91Requires(post,postun): shared-mime-info
0d5f415c 92Requires: %{name}-backend
a2d83637 93Requires: %{name}-libs = %{version}-%{release}
8d48627e 94Requires: crondaemon
53810c7c 95Requires: polkit >= 0.98
48178e4e 96Suggests: ConsoleKit-x11
02b3d2d3
JB
97Obsoletes: PackageKit-backend-smart
98Obsoletes: PackageKit-backend-yum
7cd3cbcf 99Obsoletes: PackageKit-docs < 0.8.4
d113818a 100Obsoletes: pm-utils-packagekit
a2d83637
MB
101BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103%description
104PackageKit is a D-Bus abstraction layer that allows the session user
105to manage packages in a secure way using a cross-distro,
106cross-architecture API.
107
85d27e4f
JB
108%description -l pl.UTF-8
109PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
110sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
111zgodnego z wieloma dystrybucjami i architekturami.
112
a2d83637 113%package libs
d05d9108
MB
114Summary: packagekit-glib library
115Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 116Group: Libraries
53810c7c 117Requires: glib2 >= 1:2.32.0
a2d83637
MB
118
119%description libs
d05d9108 120packagekit-glib library.
a2d83637
MB
121
122%description libs -l pl.UTF-8
d05d9108 123Biblioteka packagekit-glib.
a2d83637
MB
124
125%package devel
d05d9108
MB
126Summary: Header files for packagekit-glib library
127Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
128Group: Development/Libraries
129Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 130Requires: dbus-devel >= 1.2.0
53810c7c 131Requires: glib2-devel >= 1:2.32.0
9ed4ca79 132Requires: sqlite3-devel
a2d83637
MB
133
134%description devel
d05d9108 135Header files for packagekit-glib library.
a2d83637
MB
136
137%description devel -l pl.UTF-8
d05d9108 138Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
139
140%package static
d05d9108
MB
141Summary: Static packagekit-glib library
142Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
143Group: Development/Libraries
144Requires: %{name}-devel = %{version}-%{release}
145
146%description static
d05d9108 147Static packagekit-glib library.
a2d83637
MB
148
149%description static -l pl.UTF-8
d05d9108
MB
150Statyczna biblioteka packagekit-glib.
151
8ad97aee
JB
152%package -n vala-packagekit
153Summary: Vala API for PackageKit library
154Summary(pl.UTF-8): API języka Vala do biblioteki PackageKitu
155Group: Development/Libraries
156Requires: %{name}-devel = %{version}-%{release}
157Requires: vala >= 2:0.16
0e84469f
ER
158%if "%{_rpmversion}" >= "5"
159BuildArch: noarch
160%endif
8ad97aee
JB
161
162%description -n vala-packagekit
163Vala API for PackageKit library.
164
165%description -n vala-packagekit -l pl.UTF-8
166API języka Vala do biblioteki PackageKitu.
167
16acf8d5
JB
168%package apidocs
169Summary: PackageKit library API documentation
170Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
171Group: Documentation
172Requires: gtk-doc-common
2aa4ef3d
ER
173%if "%{_rpmversion}" >= "5"
174BuildArch: noarch
175%endif
16acf8d5
JB
176
177%description apidocs
178PackageKit library API documentation.
179
180%description apidocs -l pl.UTF-8
181Dokumentacja API biblioteki PackageKit.
182
d06070b1
JB
183%package backend-alpm
184Summary: PackageKit ALPM backend
185Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece ALPM
186Group: Libraries
187Requires: %{name} = %{version}-%{release}
188Provides: %{name}-backend = %{version}-%{release}
d06070b1
JB
189
190%description backend-alpm
191A backend for PackageKit to enable Arch Linux packages via ALPM
192library.
193
194%description backend-alpm -l pl.UTF-8
195Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
196bibliotekę ALPM.
197
04e18045
JB
198%package backend-aptcc
199Summary: PackageKit APTcc backend
200Summary(pl.UTF-8): Backend PackageKit APTcc
201Group: Libraries
202Requires: %{name} = %{version}-%{release}
203Provides: %{name}-backend = %{version}-%{release}
204
205%description backend-aptcc
206A backend for PackageKit to enable APT support via C++ API.
207
208%description backend-aptcc -l pl.UTF-8
209Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
210C++.
211
212%package backend-entropy
213Summary: PackageKit Entropy backend
214Summary(pl.UTF-8): Backend PackageKit Entropy
215Group: Libraries
216Requires: %{name} = %{version}-%{release}
217Requires: python-packagekit = %{version}-%{release}
218#Requires: python-entropy
219Provides: %{name}-backend = %{version}-%{release}
220
221%description backend-entropy
222A backend for PackageKit to enable Sabayon packages support through
223Entropy package manager.
224
225%description backend-entropy -l pl.UTF-8
226Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
227użyciu zarządcy pakietów Entropy.
228
ee375c30
JB
229%package backend-hif
230Summary: PackageKit hif backend
231Summary(pl.UTF-8): Backend PackageKit oparty na bibliotece hif
232Group: Libraries
233Requires: %{name} = %{version}-%{release}
234Requires: libhif >= 0.1.7
235Provides: %{name}-backend = %{version}-%{release}
236Obsoletes: PackageKit-backend-hawkey
ee375c30
JB
237
238%description backend-hif
04e18045
JB
239A backend for PackageKit to enable RPM packages support via hif
240library (used in Fedora).
ee375c30
JB
241
242%description backend-hif -l pl.UTF-8
04e18045
JB
243Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
244hif (używaną w dystrybucji Fedora).
245
246%package backend-katja
247Summary: PackageKit Katja backend
248Summary(pl.UTF-8): Backend PackageKit Katja
249Group: Libraries
250Requires: %{name} = %{version}-%{release}
251Provides: %{name}-backend = %{version}-%{release}
252
253%description backend-katja
48178e4e 254Katja backend for PackageKit to enable Slackware repositories support.
04e18045
JB
255
256%description backend-katja -l pl.UTF-8
257Backend PackageKit Katja dodający obsługę repozytoriów Slackware.
258
259%package backend-pisi
260Summary: PackageKit PiSi backend
261Summary(pl.UTF-8): Backend PackageKit PiSi
262Group: Libraries
263Requires: %{name} = %{version}-%{release}
264Requires: python-packagekit = %{version}-%{release}
265#Requires: python-piksemel
266#Requires: python-pisi
267Provides: %{name}-backend = %{version}-%{release}
268
269%description backend-pisi
270A backend for PackageKit to enable PiSi packages support. PiSi
271packages are originated in Pardus distribution.
272
273%description backend-pisi -l pl.UTF-8
274Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
275wywodzą się z dystrybucji Pardus.
ee375c30 276
0d5f415c
ER
277%package backend-poldek
278Summary: PackageKit Poldek backend
16acf8d5 279Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
280Group: Libraries
281Requires: %{name} = %{version}-%{release}
7cd3cbcf 282Requires: poldek >= 0.30-1.rc6.4
16acf8d5 283Provides: %{name}-backend = %{version}-%{release}
0d5f415c
ER
284
285%description backend-poldek
04e18045
JB
286A backend for PackageKit to enable RPM packages support through Poldek
287- native PLD package manager.
0d5f415c 288
16acf8d5 289%description backend-poldek -l pl.UTF-8
04e18045
JB
290Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
291natywnego zarządcę pakietów dystrybucji PLD.
292
293%package backend-portage
294Summary: PackageKit Portage backend
295Summary(pl.UTF-8): Backend PackageKit Portage
296Group: Libraries
297Requires: %{name} = %{version}-%{release}
298Requires: python-packagekit = %{version}-%{release}
299#Requires: python-portage
300Provides: %{name}-backend = %{version}-%{release}
301
302%description backend-portage
303A backend for PackageKit to enable Gentoo Portage support.
304
305%description backend-portage -l pl.UTF-8
306Backend PackageKit dodający obsługę systemu Portage dystrybucji
307Gentoo.
308
309%package backend-ports
310Summary: PackageKit Ports backend
311Summary(pl.UTF-8): Backend PackageKit Ports
312Group: Libraries
313Requires: %{name} = %{version}-%{release}
314#Requires: ruby-pkgtools
315Provides: %{name}-backend = %{version}-%{release}
316
317%description backend-ports
318A backend for PackageKit to enable FreeBSD Ports support.
319
320%description backend-ports -l pl.UTF-8
321Backend PackageKit dodający obsługę portów systemu FreeBSD.
322
323%package backend-urpmi
324Summary: PackageKit URPMI backend
325Summary(pl.UTF-8): Backend PackageKit URPMI
326Group: Libraries
327Requires: %{name} = %{version}-%{release}
328#Requires: perl-URPM
329Provides: %{name}-backend = %{version}-%{release}
330
331%description backend-urpmi
332A backend for PackageKit to enable RPM packages support through URPMI
333package manager (originated in Mandriva).
334
335%description backend-urpmi -l pl.UTF-8
336Backend PackageKit dodający obsługę pakietów RPM poprzez zarządcę
337URPMI (pochodzącego z dystrybucji Mandriva).
338
339%package backend-zypp
340Summary: PackageKit Zypp backend
341Summary(pl.UTF-8): Backend PackageKit Zypp
342Group: Libraries
343Requires: %{name} = %{version}-%{release}
3b18414e 344Requires: libzypp >= 15
04e18045
JB
345Provides: %{name}-backend = %{version}-%{release}
346
347%description backend-zypp
348A backend for PackageKit to enable RPM packages support through Zypp
349library (originated in openSUSE/SLE).
350
351%description backend-zypp -l pl.UTF-8
352Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
353Zypp (pochodzącą z dystrybucji openSUSE/SLE).
16acf8d5 354
d05d9108
MB
355%package gstreamer-plugin
356Summary: GStreamer codecs installer
357Summary(pl.UTF-8): Instalator kodeków GStreamera
358Group: Applications
359Requires: %{name} = %{version}-%{release}
5baab3aa 360Requires: %{name}-gtk-module = %{version}-%{release}
d05d9108
MB
361
362%description gstreamer-plugin
363The PackageKit GStreamer plugin allows any GStreamer application to
364install codecs from configured repositories using PackageKit.
365
366%description gstreamer-plugin -l pl.UTF-8
367Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
368zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
369
370%package gtk-module
371Summary: GTK+ module to detect and install missing fonts
372Summary(pl.UTF-8): Moduł GTK+ do wykrywania i instalowania brakujących czcionek
373Group: X11/Libraries
374
375%description gtk-module
376The PackageKit GTK+ module allows any pango application to install
377missing fonts from configured repositories using PackageKit.
378
379%description gtk-module -l pl.UTF-8
380Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
381brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
382
dac2b5e1
AF
383%package gtk3-module
384Summary: GTK+ 3.x module to detect and install missing fonts
385Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
386Group: X11/Libraries
387
388%description gtk3-module
389The PackageKit GTK+ 3.x module allows any pango application to install
390missing fonts from configured repositories using PackageKit.
391
392%description gtk3-module -l pl.UTF-8
393Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
394brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
395
a2d83637 396%package -n bash-completion-packagekit
16acf8d5
JB
397Summary: Bash completion for PackageKit console commands
398Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 399Group: Applications/Shells
577193a4
JB
400Requires: %{name} = %{version}-%{release}
401Requires: bash-completion >= 2
ead2d2f6
ER
402%if "%{_rpmversion}" >= "5"
403BuildArch: noarch
404%endif
a2d83637
MB
405
406%description -n bash-completion-packagekit
16acf8d5 407This package provides bash-completion for PackageKit console commands.
a2d83637
MB
408
409%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
410Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
411konsolowych PackageKit.
a2d83637 412
a2d83637
MB
413%package -n python-packagekit
414Summary: PackageKit Python bindings
415Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
416Group: Development/Languages/Python
417Requires: python-dbus
418Requires: python-pygobject
419
420%description -n python-packagekit
421PackageKit Python bindings.
422
86086d14 423%description -n python-packagekit -l pl.UTF-8
a2d83637
MB
424Wiązania PackageKit dla Pythona.
425
dac2b5e1
AF
426%package -n browser-plugin-packagekit
427Summary: PackageKit's browser plugin
428Summary(pl.UTF-8): Wtyczka PackageKit do przeglądarek WWW
429Group: X11/Libraries
430Requires: %{name} = %{version}-%{release}
431Requires: browser-plugins >= 2.0
432Requires: browser-plugins(%{_target_base_arch})
433
434%description -n browser-plugin-packagekit
435PackageKit's plugin for browsers.
436
437%description -n browser-plugin-packagekit -l pl.UTF-8
438Wtyczka PackageKit do przeglądarek WWW.
439
a2d83637
MB
440%prep
441%setup -q
d113818a 442%patch0 -p1
02b3d2d3 443%patch1 -p1
04e18045 444%patch2 -p1
bcd7526e 445%patch3 -p1
3b18414e 446%patch4 -p1
a2d83637
MB
447
448%build
9b8153ef 449%if %{with doc}
d05d9108 450%{__gtkdocize}
d5617342 451%endif
58e98be4 452%{__intltoolize}
a2d83637 453%{__libtoolize}
d05d9108 454%{__aclocal} -I m4
a2d83637
MB
455%{__autoconf}
456%{__autoheader}
457%{__automake}
04e18045 458%{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
a2d83637 459%configure \
d05d9108 460 --disable-command-not-found \
577193a4
JB
461 --disable-dummy \
462 %{!?with_doc:--disable-gtk-doc} \
53810c7c 463 %{!?with_introspection:--disable-introspection} \
577193a4
JB
464 --disable-silent-rules \
465 --enable-bash-completion=%{bash_compdir} \
d06070b1 466 %{__enable_disable alpm} \
04e18045 467 %{__enable_disable apt aptcc} \
dac2b5e1 468 %{__enable_disable browser browser-plugin} \
04e18045 469 %{__enable_disable entropy} \
ee375c30 470 %{__enable_disable hif} \
04e18045
JB
471 %{__enable_disable katja} \
472 %{__enable_disable pisi} \
dac2b5e1 473 %{__enable_disable poldek} \
04e18045
JB
474 %{__enable_disable portage} \
475 %{__enable_disable ports} \
476 %{__enable_disable urpmi} \
477 %{__enable_disable zypp} \
577193a4
JB
478 --with-html-dir=%{_gtkdocdir} \
479 --with-mozilla-plugin-dir=%{_browserpluginsdir} \
480 --with-security-framework=polkit
a2d83637
MB
481%{__make}
482
483%install
484rm -rf $RPM_BUILD_ROOT
485
486%{__make} install \
487 DESTDIR=$RPM_BUILD_ROOT
488
d05d9108
MB
489# use pk-gstreamer-install as codec installer
490ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
491
dac2b5e1
AF
492%{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
493%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
494%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
495%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
496%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
497
498%if %{with browser}
499%{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.{la,a}
500%endif
a2d83637 501
02b3d2d3
JB
502# empty version of bg
503%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bg_BG
504# empty version of fa (empty as well BTW)
505%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/fa_IR
506# outdated copy of it
507%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/it_IT
9fced724 508
a2d83637
MB
509%py_postclean
510
6808f644
MB
511%find_lang %{name}
512
a2d83637
MB
513%clean
514rm -rf $RPM_BUILD_ROOT
515
fcd0bc5c
MB
516%post
517%update_mime_database
518
519%postun
520%update_mime_database
521
85d27e4f 522%post libs -p /sbin/ldconfig
a2d83637
MB
523%postun libs -p /sbin/ldconfig
524
dac2b5e1
AF
525%post -n browser-plugin-packagekit
526%update_browser_plugins
527
528%postun -n browser-plugin-packagekit
529if [ "$1" = 0 ]; then
530 %update_browser_plugins
531fi
532
6808f644 533%files -f %{name}.lang
a2d83637 534%defattr(644,root,root,755)
02b3d2d3 535%doc AUTHORS HACKING MAINTAINERS NEWS README
a2d83637
MB
536%attr(755,root,root) %{_bindir}/pkcon
537%attr(755,root,root) %{_bindir}/pkmon
50832223 538%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
02b3d2d3
JB
539%attr(755,root,root) %{_libexecdir}/packagekit-direct
540%attr(755,root,root) %{_libexecdir}/packagekitd
541%attr(755,root,root) %{_libexecdir}/pk-offline-update
a2d83637 542%dir %{_libdir}/packagekit-backend
a2d83637
MB
543%dir %{_sysconfdir}/PackageKit
544%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 545%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
5baab3aa
ER
546%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
547/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
d05d9108 548%dir %{_datadir}/PackageKit
6e66a3a4 549%dir %{_datadir}/PackageKit/helpers
d05d9108 550%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 551%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 552%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 553%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
a2d83637 554%{_mandir}/man1/pkcon.1*
78293e06 555%{_mandir}/man1/pkmon.1*
53810c7c 556%{systemdunitdir}/packagekit.service
7cd3cbcf 557%{systemdunitdir}/packagekit-offline-update.service
02b3d2d3 558%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
78293e06
MB
559%dir /var/cache/PackageKit
560%dir /var/cache/PackageKit/downloads
a2d83637 561%dir /var/lib/PackageKit
d05d9108 562%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
563
564%files libs
565%defattr(644,root,root,755)
74872af2 566%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
02b3d2d3 567%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
dac2b5e1 568%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
2ab9cd42
JB
569# NOTE: dbus interface xmls are commonly used:
570# - at runtime by packagekitd
571# - for development of applications using PK dbus interface
572%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
573%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 574
a2d83637
MB
575%files devel
576%defattr(644,root,root,755)
74872af2 577%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 578%{_pkgconfigdir}/packagekit-glib2.pc
d05d9108 579%dir %{_includedir}/PackageKit
74872af2 580%{_includedir}/PackageKit/packagekit-glib2
dac2b5e1 581%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
08c67dac 582
a2d83637
MB
583%files static
584%defattr(644,root,root,755)
74872af2 585%{_libdir}/libpackagekit-glib2.a
d05d9108 586
8ad97aee
JB
587%if %{with vala}
588%files -n vala-packagekit
589%defattr(644,root,root,755)
590%{_datadir}/vala/vapi/packagekit-glib2.vapi
591%endif
592
16acf8d5
JB
593%files apidocs
594%defattr(644,root,root,755)
595%{_gtkdocdir}/PackageKit
596
d06070b1
JB
597%if %{with alpm}
598%files backend-alpm
0d5f415c 599%defattr(644,root,root,755)
d06070b1
JB
600%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
601%dir %{_sysconfdir}/PackageKit/alpm.d
602%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
603%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
604%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
0d5f415c
ER
605%endif
606
04e18045
JB
607%if %{with apt}
608%files backend-aptcc
609%defattr(644,root,root,755)
610%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
611%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
612%dir %{_datadir}/PackageKit/helpers/aptcc
613%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
614%attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
615%{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
616%endif
617
618%if %{with entropy}
619%files backend-entropy
620%defattr(644,root,root,755)
621%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
622%dir %{_datadir}/PackageKit/helpers/entropy
623%attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
624%endif
625
ee375c30
JB
626%if %{with hif}
627%files backend-hif
628%defattr(644,root,root,755)
629%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_hif.so
630%endif
631
04e18045
JB
632%if %{with katja}
633%files backend-katja
634%defattr(644,root,root,755)
635%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_katja.so
636%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Katja.conf
637%dir /var/cache/PackageKit/metadata
638%ghost /var/cache/PackageKit/metadata/metadata.db
639%endif
640
641%if %{with pisi}
642%files backend-pisi
643%defattr(644,root,root,755)
644%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
645%dir %{_datadir}/PackageKit/helpers/pisi
646%attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
647%endif
648
d06070b1
JB
649%if %{with poldek}
650%files backend-poldek
651%defattr(644,root,root,755)
652%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
653%endif
654
04e18045
JB
655%if %{with portage}
656%files backend-portage
657%defattr(644,root,root,755)
658%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
659%dir %{_datadir}/PackageKit/helpers/portage
660%attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
661%endif
662
663%if %{with ports}
664%files backend-ports
665%defattr(644,root,root,755)
666%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_ports.so
667%dir %{_datadir}/PackageKit/helpers/ports
668%attr(755,root,root) %{_datadir}/PackageKit/helpers/ports/portsBackend.rb
669%{_datadir}/PackageKit/helpers/ports/ruby_packagekit
670%endif
671
672%if %{with urpmi}
673%files backend-urpmi
674%defattr(644,root,root,755)
675%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_urpmi.so
676%dir %{_datadir}/PackageKit/helpers/urpmi
677%attr(755,root,root) %{_datadir}/PackageKit/helpers/urpmi/urpmi-dispatched-backend.pl
678%{_datadir}/PackageKit/helpers/urpmi/perl_packagekit
679%{_datadir}/PackageKit/helpers/urpmi/urpmi_backend
680%endif
681
682%if %{with zypp}
683%files backend-zypp
684%defattr(644,root,root,755)
685%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
686%endif
687
d05d9108
MB
688%files gstreamer-plugin
689%defattr(644,root,root,755)
690%doc contrib/gstreamer-plugin/README
02b3d2d3
JB
691%attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
692%attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
d05d9108
MB
693
694%files gtk-module
695%defattr(644,root,root,755)
696%doc contrib/gtk-module/{GLASS.txt,README}
697%attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
698
dac2b5e1
AF
699%files gtk3-module
700%defattr(644,root,root,755)
701%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 702%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 703
a2d83637
MB
704%files -n bash-completion-packagekit
705%defattr(644,root,root,755)
577193a4 706%{bash_compdir}/pkcon
a2d83637 707
02b3d2d3 708%if %{with python}
a2d83637
MB
709%files -n python-packagekit
710%defattr(644,root,root,755)
711%dir %{py_sitescriptdir}/packagekit
712%{py_sitescriptdir}/packagekit/*.py[co]
02b3d2d3 713%endif
dac2b5e1
AF
714
715%if %{with browser}
716%files -n browser-plugin-packagekit
717%defattr(644,root,root,755)
718%attr(755,root,root) %{_browserpluginsdir}/packagekit-plugin.so
719%endif
This page took 0.261513 seconds and 4 git commands to generate.