noarch apidocs
[packages/PackageKit.git] / PackageKit.spec
CommitLineData
d05d9108
MB
1# TODO:
2# - BASH command-not-found functionality disabled for now as it needs patched bash
3# (details in bash from Fedora Rawhide)
d05d9108
MB
4#
5# Conditional build:
53810c7c
JB
6%bcond_without doc # build without docs
7%bcond_without introspection # gobject introspection, time to time broken
8%bcond_without poldek # Poldek backend
9%bcond_without smart # SMART backend
10%bcond_without yum # YUM backend
d113818a 11%bcond_with hawkey # Hawkey backend
53810c7c 12%bcond_with browser # browser plugin (patrys says: it's flawed by concept)
dc10d5ba 13
0d5f415c 14# default backend, configurable at runtime
dc10d5ba 15%define backend poldek
48a22c3c 16
85d27e4f
JB
17Summary: System daemon that is a D-Bus abstraction layer for package management
18Summary(pl.UTF-8): Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
a2d83637 19Name: PackageKit
66e86606 20Version: 0.8.17
2aa4ef3d 21Release: 2
a2d83637 22License: GPL v2+
85d27e4f 23Group: Applications/System
66e86606
JB
24Source0: http://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
25# Source0-md5: a2b1a602fee21430b735e52aaf33bd1a
d113818a 26Patch0: %{name}-hawkey-rpm5.patch
d6bb3abf 27Patch3: smart-at-fix.patch
577193a4
JB
28Patch4: %{name}-gstreamer.patch
29Patch5: %{name}-bashcomp.patch
30Patch6: %{name}-connman.patch
a2d83637
MB
31URL: http://www.packagekit.org/
32BuildRequires: NetworkManager-devel >= 0.6.5
600be41c 33BuildRequires: autoconf >= 2.65
577193a4
JB
34BuildRequires: automake >= 1:1.11
35BuildRequires: connman-devel
6808f644 36BuildRequires: dbus-devel >= 1.2.0
f5f5e3ff 37BuildRequires: dbus-glib-devel >= 0.76
bdd8c0ca 38BuildRequires: docbook-dtd412-xml
39BuildRequires: docbook-dtd42-xml
dac2b5e1 40BuildRequires: fontconfig-devel
a2d83637 41BuildRequires: gettext-devel
53810c7c
JB
42BuildRequires: glib2-devel >= 1:2.32.0
43%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.9}
7cd3cbcf
MB
44BuildRequires: gstreamer-devel >= 1.0.0
45BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
d05d9108 46BuildRequires: gtk+2-devel >= 2:2.14.0
dac2b5e1 47BuildRequires: gtk+3-devel >= 3.0.0
577193a4 48%{?with_doc:BuildRequires: gtk-doc >= 1.11}
66e86606 49%{?with_hawkey:BuildRequires: hawkey-devel >= 0.4.6}
d05d9108 50BuildRequires: intltool >= 0.35.0
78293e06 51BuildRequires: libarchive-devel
66e86606 52%{?with_hawkey:BuildRequires: librepo-devel >= 0.1.5}
a2d83637 53BuildRequires: libtool
dac2b5e1
AF
54BuildRequires: libxslt-progs
55BuildRequires: pango-devel
a2d83637 56BuildRequires: pkgconfig
7cd3cbcf 57%{?with_poldek:BuildRequires: poldek-devel >= 0.30-1.rc6.4}
577193a4
JB
58BuildRequires: polkit-devel >= 0.98
59BuildRequires: python-devel >= 1:2.7
827cd5e7 60BuildRequires: readline-devel
d113818a 61%{?with_hawkey:BuildRequires: rpm-devel >= 4.11.0}
a2d83637 62BuildRequires: rpm-pythonprov
85d27e4f 63BuildRequires: rpmbuild(macros) >= 1.311
577193a4
JB
64BuildRequires: sqlite3-devel >= 3
65BuildRequires: systemd-devel
e216f3d9 66BuildRequires: tar >= 1:1.22
9ed4ca79 67BuildRequires: udev-glib-devel
e216f3d9 68BuildRequires: xz
dac2b5e1
AF
69%if %{with browser}
70BuildRequires: cairo-devel
a92a33f7
ŁK
71BuildRequires: nspr-devel >= 4.8
72BuildRequires: xulrunner-devel >= 8.0
dac2b5e1 73%endif
fcd0bc5c 74Requires(post,postun): shared-mime-info
0d5f415c 75Requires: %{name}-backend
a2d83637 76Requires: %{name}-libs = %{version}-%{release}
5d2bfc22 77Requires: ConsoleKit-x11
8d48627e 78Requires: crondaemon
53810c7c 79Requires: polkit >= 0.98
7cd3cbcf 80Obsoletes: PackageKit-docs < 0.8.4
d113818a 81Obsoletes: pm-utils-packagekit
a2d83637
MB
82BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84%description
85PackageKit is a D-Bus abstraction layer that allows the session user
86to manage packages in a secure way using a cross-distro,
87cross-architecture API.
88
85d27e4f
JB
89%description -l pl.UTF-8
90PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
91sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
92zgodnego z wieloma dystrybucjami i architekturami.
93
a2d83637 94%package libs
d05d9108
MB
95Summary: packagekit-glib library
96Summary(pl.UTF-8): Biblioteka packagekit-glib
a2d83637 97Group: Libraries
53810c7c 98Requires: glib2 >= 1:2.32.0
a2d83637
MB
99
100%description libs
d05d9108 101packagekit-glib library.
a2d83637
MB
102
103%description libs -l pl.UTF-8
d05d9108 104Biblioteka packagekit-glib.
a2d83637
MB
105
106%package devel
d05d9108
MB
107Summary: Header files for packagekit-glib library
108Summary(pl.UTF-8): Pliki nagłówkowe biblioteki packagekit-glib
a2d83637
MB
109Group: Development/Libraries
110Requires: %{name}-libs = %{version}-%{release}
9ed4ca79 111Requires: dbus-devel >= 1.2.0
53810c7c 112Requires: glib2-devel >= 1:2.32.0
9ed4ca79 113Requires: sqlite3-devel
a2d83637
MB
114
115%description devel
d05d9108 116Header files for packagekit-glib library.
a2d83637
MB
117
118%description devel -l pl.UTF-8
d05d9108 119Pliki nagłówkowe biblioteki packagekit-glib.
a2d83637
MB
120
121%package static
d05d9108
MB
122Summary: Static packagekit-glib library
123Summary(pl.UTF-8): Statyczna biblioteka packagekit-glib
a2d83637
MB
124Group: Development/Libraries
125Requires: %{name}-devel = %{version}-%{release}
126
127%description static
d05d9108 128Static packagekit-glib library.
a2d83637
MB
129
130%description static -l pl.UTF-8
d05d9108
MB
131Statyczna biblioteka packagekit-glib.
132
16acf8d5
JB
133%package apidocs
134Summary: PackageKit library API documentation
135Summary(pl.UTF-8): Dokumentacja API biblioteki PackageKit
136Group: Documentation
137Requires: gtk-doc-common
2aa4ef3d
ER
138%if "%{_rpmversion}" >= "5"
139BuildArch: noarch
140%endif
16acf8d5
JB
141
142%description apidocs
143PackageKit library API documentation.
144
145%description apidocs -l pl.UTF-8
146Dokumentacja API biblioteki PackageKit.
147
d113818a
JB
148%package backend-hawkey
149Summary: PackageKit Hawkey backend
150Summary(pl.UTF-8): Backend PackageKit oparty na Hawkeyu
151Group: Libraries
152Requires: %{name} = %{version}-%{release}
66e86606
JB
153Requires: hawkey >= 0.4.6
154Requires: librepo >= 0.1.5
d113818a 155Provides: %{name}-backend = %{version}-%{release}
3bbb3225 156Obsoletes: PackageKit-backend-zif < 0.8.14
d113818a
JB
157
158%description backend-hawkey
159A backend for PackageKit to enable Hawkey functionality.
160
161%description backend-hawkey -l pl.UTF-8
162Backend PackageKit dodający obsługę Hawkeya.
163
0d5f415c
ER
164%package backend-poldek
165Summary: PackageKit Poldek backend
16acf8d5 166Summary(pl.UTF-8): Backend PackageKit oparty na Poldku
0d5f415c
ER
167Group: Libraries
168Requires: %{name} = %{version}-%{release}
7cd3cbcf 169Requires: poldek >= 0.30-1.rc6.4
16acf8d5
JB
170Provides: %{name}-backend = %{version}-%{release}
171Conflicts: PackageKit < 0.6.8-3
0d5f415c
ER
172
173%description backend-poldek
174A backend for PackageKit to enable Poldek functionality.
175
16acf8d5
JB
176%description backend-poldek -l pl.UTF-8
177Backend PackageKit dodający obsługę Poldka.
178
616fad64
ER
179%package backend-smart
180Summary: PackageKit SMART backend
16acf8d5 181Summary(pl.UTF-8): Backend PackageKit oparty na zarządcy pakietów SMART
616fad64
ER
182Group: Libraries
183Requires: %{name} = %{version}-%{release}
184Requires: smart
185
186%description backend-smart
187A backend for PackageKit to enable SMART functionality.
188
16acf8d5
JB
189%description backend-smart -l pl.UTF-8
190Backend PackageKit dodający obsługę zarządcy pakietów SMART.
191
616fad64
ER
192%package backend-yum
193Summary: PackageKit YUM backend
16acf8d5 194Summary(pl.UTF-8): Backend PackageKit oparty na Yumie
616fad64
ER
195Group: Libraries
196Requires: %{name} = %{version}-%{release}
197Requires: python-packagekit = %{version}-%{release}
198Requires: yum >= 3.2.19
16acf8d5 199Provides: %{name}-backend = %{version}-%{release}
616fad64
ER
200
201%description backend-yum
202A backend for PackageKit to enable yum functionality.
203
16acf8d5
JB
204%description backend-yum -l pl.UTF-8
205Backend PackageKit dodający obsługę Yuma.
a2d83637 206
d05d9108
MB
207%package gstreamer-plugin
208Summary: GStreamer codecs installer
209Summary(pl.UTF-8): Instalator kodeków GStreamera
210Group: Applications
211Requires: %{name} = %{version}-%{release}
5baab3aa 212Requires: %{name}-gtk-module = %{version}-%{release}
d05d9108
MB
213
214%description gstreamer-plugin
215The PackageKit GStreamer plugin allows any GStreamer application to
216install codecs from configured repositories using PackageKit.
217
218%description gstreamer-plugin -l pl.UTF-8
219Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
220zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
221
222%package gtk-module
223Summary: GTK+ module to detect and install missing fonts
224Summary(pl.UTF-8): Moduł GTK+ do wykrywania i instalowania brakujących czcionek
225Group: X11/Libraries
226
227%description gtk-module
228The PackageKit GTK+ module allows any pango application to install
229missing fonts from configured repositories using PackageKit.
230
231%description gtk-module -l pl.UTF-8
232Moduł GTK+ pozwala każdej aplikacji używającej pango zainstalować
233brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
234
dac2b5e1
AF
235%package gtk3-module
236Summary: GTK+ 3.x module to detect and install missing fonts
237Summary(pl.UTF-8): Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
238Group: X11/Libraries
239
240%description gtk3-module
241The PackageKit GTK+ 3.x module allows any pango application to install
242missing fonts from configured repositories using PackageKit.
243
244%description gtk3-module -l pl.UTF-8
245Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
246brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
247
a2d83637 248%package -n bash-completion-packagekit
16acf8d5
JB
249Summary: Bash completion for PackageKit console commands
250Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
a2d83637 251Group: Applications/Shells
577193a4
JB
252Requires: %{name} = %{version}-%{release}
253Requires: bash-completion >= 2
ead2d2f6
ER
254%if "%{_rpmversion}" >= "5"
255BuildArch: noarch
256%endif
a2d83637
MB
257
258%description -n bash-completion-packagekit
16acf8d5 259This package provides bash-completion for PackageKit console commands.
a2d83637
MB
260
261%description -n bash-completion-packagekit -l pl.UTF-8
16acf8d5
JB
262Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
263konsolowych PackageKit.
a2d83637 264
a2d83637
MB
265%package -n python-packagekit
266Summary: PackageKit Python bindings
267Summary(pl.UTF-8): Wiązania PackageKit dla Pythona
268Group: Development/Languages/Python
269Requires: python-dbus
270Requires: python-pygobject
271
272%description -n python-packagekit
273PackageKit Python bindings.
274
86086d14 275%description -n python-packagekit -l pl.UTF-8
a2d83637
MB
276Wiązania PackageKit dla Pythona.
277
dac2b5e1
AF
278%package -n browser-plugin-packagekit
279Summary: PackageKit's browser plugin
280Summary(pl.UTF-8): Wtyczka PackageKit do przeglądarek WWW
281Group: X11/Libraries
282Requires: %{name} = %{version}-%{release}
283Requires: browser-plugins >= 2.0
284Requires: browser-plugins(%{_target_base_arch})
285
286%description -n browser-plugin-packagekit
287PackageKit's plugin for browsers.
288
289%description -n browser-plugin-packagekit -l pl.UTF-8
290Wtyczka PackageKit do przeglądarek WWW.
291
a2d83637
MB
292%prep
293%setup -q
d113818a 294%patch0 -p1
7333f3ce 295%patch3 -p0
7cd3cbcf
MB
296%patch4 -p1
297%patch5 -p1
577193a4 298%patch6 -p1
a2d83637
MB
299
300%build
9b8153ef 301%if %{with doc}
d05d9108 302%{__gtkdocize}
d5617342 303%endif
58e98be4 304%{__intltoolize}
a2d83637 305%{__libtoolize}
d05d9108 306%{__aclocal} -I m4
a2d83637
MB
307%{__autoconf}
308%{__autoheader}
309%{__automake}
310%configure \
d05d9108 311 --disable-command-not-found \
577193a4
JB
312 --disable-dummy \
313 %{!?with_doc:--disable-gtk-doc} \
53810c7c 314 %{!?with_introspection:--disable-introspection} \
577193a4
JB
315 --disable-silent-rules \
316 --enable-bash-completion=%{bash_compdir} \
dac2b5e1 317 %{__enable_disable browser browser-plugin} \
d113818a 318 %{__enable_disable hawkey} \
dac2b5e1 319 %{__enable_disable poldek} \
616fad64 320 %{__enable_disable smart} \
dac2b5e1 321 %{__enable_disable yum} \
dac2b5e1 322 --with-default-backend=%{backend} \
577193a4
JB
323 --with-html-dir=%{_gtkdocdir} \
324 --with-mozilla-plugin-dir=%{_browserpluginsdir} \
325 --with-security-framework=polkit
a2d83637
MB
326%{__make}
327
328%install
329rm -rf $RPM_BUILD_ROOT
330
331%{__make} install \
332 DESTDIR=$RPM_BUILD_ROOT
333
d05d9108
MB
334# use pk-gstreamer-install as codec installer
335ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libdir}/gst-install-plugins-helper
336
dac2b5e1
AF
337%{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-{2,3}.0/modules/*.{la,a}
338%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/*.{la,a}
339%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
7cd3cbcf 340%{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-plugins/*.{la,a}
dac2b5e1
AF
341%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
342%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
343
344%if %{with browser}
345%{__rm} $RPM_BUILD_ROOT%{_browserpluginsdir}/*.{la,a}
346%endif
a2d83637 347
8c9d69e0
ER
348%if %{with yum}
349# yumBackend.py can't be compiled (invoked directly), other should be compiled
350%py_comp $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum
351%py_ocomp $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum
dac2b5e1
AF
352%{__rm} $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum/yum{Comps,Filter}.py
353%{__rm} $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/yum/yumBackend.py[co]
8c9d69e0
ER
354%endif
355
53810c7c
JB
356# outdated copies of bg,it
357%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{bg_BG,it_IT}
358# fa_IR uses short dir name
359%{__mv} $RPM_BUILD_ROOT%{_localedir}/{fa_IR,fa}
9fced724 360
a2d83637
MB
361%py_postclean
362
6808f644
MB
363%find_lang %{name}
364
a2d83637
MB
365%clean
366rm -rf $RPM_BUILD_ROOT
367
fcd0bc5c
MB
368%post
369%update_mime_database
370
371%postun
372%update_mime_database
373
85d27e4f 374%post libs -p /sbin/ldconfig
a2d83637
MB
375%postun libs -p /sbin/ldconfig
376
dac2b5e1
AF
377%post -n browser-plugin-packagekit
378%update_browser_plugins
379
380%postun -n browser-plugin-packagekit
381if [ "$1" = 0 ]; then
382 %update_browser_plugins
383fi
384
6808f644 385%files -f %{name}.lang
a2d83637 386%defattr(644,root,root,755)
577193a4 387%doc AUTHORS HACKING MAINTAINERS NEWS README TODO
a2d83637 388%attr(755,root,root) %{_bindir}/packagekit-bugreport.sh
a2d83637
MB
389%attr(755,root,root) %{_bindir}/pkcon
390%attr(755,root,root) %{_bindir}/pkmon
a382d619 391%attr(755,root,root) %{_bindir}/pk-debuginfo-install
50832223 392%attr(750,root,root) /etc/cron.daily/packagekit-background.cron
a2d83637 393%dir %{_libdir}/packagekit-backend
7cd3cbcf 394%dir %{_libdir}/packagekit-plugins
7cd3cbcf
MB
395%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-scan-desktop-files.so
396%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-systemd-updates.so
7cd3cbcf
MB
397%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin-update-package-cache.so
398%attr(755,root,root) %{_libdir}/packagekit-plugins/libpk_plugin_scripts.so
aa2113f5 399%attr(755,root,root) %{_libdir}/packagekitd
7cd3cbcf
MB
400%attr(755,root,root) %{_libdir}/pk-clear-offline-update
401%attr(755,root,root) %{_libdir}/pk-offline-update
402%attr(755,root,root) %{_libdir}/pk-trigger-offline-update
a2d83637
MB
403%dir %{_sysconfdir}/PackageKit
404%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
d05d9108 405%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
dac2b5e1
AF
406%dir %{_sysconfdir}/PackageKit/events
407%{_sysconfdir}/PackageKit/events/post-transaction.d
408%{_sysconfdir}/PackageKit/events/pre-transaction.d
5baab3aa
ER
409%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
410/etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
d05d9108 411%dir %{_datadir}/PackageKit
6e66a3a4 412%dir %{_datadir}/PackageKit/helpers
d05d9108 413%attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
f058dba9 414%{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
577193a4 415%{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
a2d83637 416%{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
a2d83637 417%{_mandir}/man1/pkcon.1*
f058dba9 418%{_mandir}/man1/pk-debuginfo-install.1*
78293e06 419%{_mandir}/man1/pkmon.1*
53810c7c 420%{systemdunitdir}/packagekit.service
7cd3cbcf 421%{systemdunitdir}/packagekit-offline-update.service
78293e06
MB
422%dir /var/cache/PackageKit
423%dir /var/cache/PackageKit/downloads
a2d83637 424%dir /var/lib/PackageKit
d05d9108 425%ghost /var/lib/PackageKit/transactions.db
a2d83637
MB
426
427%files libs
428%defattr(644,root,root,755)
74872af2 429%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
7cd3cbcf 430%attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.16
dac2b5e1 431%{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
7cd3cbcf 432%{_libdir}/girepository-1.0/PackageKitPlugin-1.0.typelib
2ab9cd42
JB
433# NOTE: dbus interface xmls are commonly used:
434# - at runtime by packagekitd
435# - for development of applications using PK dbus interface
436%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
437%{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
08c67dac 438
a2d83637
MB
439%files devel
440%defattr(644,root,root,755)
74872af2 441%attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
74872af2 442%{_pkgconfigdir}/packagekit-glib2.pc
7cd3cbcf 443%{_pkgconfigdir}/packagekit-plugin.pc
d05d9108 444%dir %{_includedir}/PackageKit
74872af2 445%{_includedir}/PackageKit/packagekit-glib2
7cd3cbcf 446%{_includedir}/PackageKit/plugin
dac2b5e1 447%{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
7cd3cbcf 448%{_datadir}/gir-1.0/PackageKitPlugin-1.0.gir
08c67dac 449
a2d83637
MB
450%files static
451%defattr(644,root,root,755)
74872af2 452%{_libdir}/libpackagekit-glib2.a
d05d9108 453
16acf8d5
JB
454%files apidocs
455%defattr(644,root,root,755)
456%{_gtkdocdir}/PackageKit
457
d113818a
JB
458%if %{with hawkey}
459%files backend-hawkey
460%defattr(644,root,root,755)
461%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_hawkey.so
462%endif
463
0d5f415c
ER
464%if %{with poldek}
465%files backend-poldek
466%defattr(644,root,root,755)
467%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
468%endif
469
616fad64
ER
470%if %{with smart}
471%files backend-smart
472%defattr(644,root,root,755)
473%{_libdir}/packagekit-backend/libpk_backend_smart.so
474%dir %{_datadir}/PackageKit/helpers/smart
9a97bfb7 475%attr(755,root,root) %{_datadir}/PackageKit/helpers/smart/smartBackend.py
616fad64
ER
476%endif
477
0d5f415c
ER
478%if %{with yum}
479%files backend-yum
480%defattr(644,root,root,755)
0d5f415c
ER
481%attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_yum.so
482%dir %{_datadir}/PackageKit/helpers/yum
483%{_datadir}/PackageKit/helpers/yum/licenses.txt
484%{_datadir}/PackageKit/helpers/yum/yum-comps-groups.conf
485%attr(755,root,root) %{_datadir}/PackageKit/helpers/yum/yumBackend.py
486%{_datadir}/PackageKit/helpers/yum/yumComps.py[co]
487%{_datadir}/PackageKit/helpers/yum/yumFilter.py[co]
488
489# yum plugin
490%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/yum/pluginconf.d/refresh-packagekit.conf
491%{_prefix}/lib/yum-plugins/refresh-packagekit.py
492%endif
493
d05d9108
MB
494%files gstreamer-plugin
495%defattr(644,root,root,755)
496%doc contrib/gstreamer-plugin/README
497%attr(755,root,root) %{_libdir}/gst-install-plugins-helper
498%attr(755,root,root) %{_libdir}/pk-gstreamer-install
499
500%files gtk-module
501%defattr(644,root,root,755)
502%doc contrib/gtk-module/{GLASS.txt,README}
503%attr(755,root,root) %{_libdir}/gtk-2.0/modules/libpk-gtk-module.so
504
dac2b5e1
AF
505%files gtk3-module
506%defattr(644,root,root,755)
507%attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
7cd3cbcf 508%{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
dac2b5e1 509
a2d83637
MB
510%files -n bash-completion-packagekit
511%defattr(644,root,root,755)
577193a4 512%{bash_compdir}/pkcon
a2d83637 513
a2d83637
MB
514%files -n python-packagekit
515%defattr(644,root,root,755)
516%dir %{py_sitescriptdir}/packagekit
517%{py_sitescriptdir}/packagekit/*.py[co]
dac2b5e1
AF
518
519%if %{with browser}
520%files -n browser-plugin-packagekit
521%defattr(644,root,root,755)
522%attr(755,root,root) %{_browserpluginsdir}/packagekit-plugin.so
523%endif
This page took 0.340229 seconds and 4 git commands to generate.