]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
- unconditional noarch subpackages
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 #
5 # Conditional build:
6 %bcond_without  doc             # build without docs
7 %bcond_without  introspection   # gobject introspection, time to time broken
8 %bcond_without  static_libs     # static library
9 %bcond_without  python          # Python binding (used by entropy and portage backends)
10 %bcond_without  vala            # Vala binding
11 # backends
12 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
13 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
14 %bcond_with     dnf             # DNF (Fedora/RHEL) backend
15 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
16 %bcond_with     nix             # Nix (NixOS) backend [broken as of 1.2.0]
17 %bcond_without  poldek          # Poldek (PLD) backend
18 %bcond_with     portage         # portage (Gentoo) backend (Python)
19 %bcond_with     slack           # Slack (Slackware) backend
20 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend [broken as of 1.2.0]
21
22 %if %{without python}
23 %undefine       with_entropy
24 %undefine       with_portage
25 %endif
26
27 Summary:        System daemon that is a D-Bus abstraction layer for package management
28 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
29 Name:           PackageKit
30 Version:        1.2.1
31 Release:        1
32 License:        GPL v2+
33 Group:          Applications/System
34 Source0:        https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
35 # Source0-md5:  a0a1f7c45d25901cf4ff4318405610c3
36 Patch0:         %{name}-poldek.patch
37 Patch1:         %{name}-bashcomp.patch
38 Patch2:         %{name}-meson.patch
39 Patch3:         consolekit-fallback.patch
40 URL:            https://www.freedesktop.org/software/PackageKit/
41 %{?with_apt:BuildRequires:      AppStream-devel >= 0.11}
42 BuildRequires:  NetworkManager-devel >= 0.6.5
43 # pkgconfig(libalpm) >= 12.0.0
44 %{?with_alpm:BuildRequires:     alpm-devel >= 5.2}
45 %{?with_dnf:BuildRequires:      appstream-glib-devel}
46 %{?with_apt:BuildRequires:      apt-devel >= 1.7}
47 BuildRequires:  connman-devel
48 %{?with_slack:BuildRequires:    curl-devel}
49 BuildRequires:  dbus-devel >= 1.2.0
50 BuildRequires:  dbus-glib-devel >= 0.76
51 BuildRequires:  docbook-dtd412-xml
52 BuildRequires:  docbook-dtd42-xml
53 BuildRequires:  fontconfig-devel
54 BuildRequires:  gettext-tools
55 BuildRequires:  glib2-devel >= 1:2.54.0
56 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
57 BuildRequires:  gstreamer-devel >= 1.0.0
58 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
59 BuildRequires:  gtk+3-devel >= 3.0.0
60 %{?with_doc:BuildRequires:      gtk-doc >= 1.11}
61 BuildRequires:  libarchive-devel
62 %{?with_dnf:BuildRequires:      libdnf-devel >= 0.43.1}
63 %if %{with apt} || %{with nix}
64 BuildRequires:  libstdc++-devel >= 6:4.7
65 %endif
66 %{?with_slack:BuildRequires:    libstdc++-devel >= 6:5}
67 BuildRequires:  libxslt-progs
68 %{?with_zypp:BuildRequires:     libzypp-devel >= 15}
69 BuildRequires:  meson >= 0.47.0
70 BuildRequires:  ninja >= 1.5
71 # nix-expr nix-main nix-store
72 %{?with_nix:BuildRequires:      nix-devel >= 1.12}
73 BuildRequires:  pango-devel
74 BuildRequires:  pkgconfig
75 # when released; just to detect which reboot modes to use (library not linked)
76 #BuildRequires: plymouth-devel >= 0.9.5
77 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
78 BuildRequires:  polkit-devel >= 0.114
79 # or 1:3.2
80 %{?with_python:BuildRequires:   python-devel >= 1:2.7}
81 BuildRequires:  readline-devel
82 %{?with_dnf:BuildRequires:      rpm-devel >= 4.?}
83 BuildRequires:  rpm-pythonprov
84 BuildRequires:  rpmbuild(macros) >= 1.736
85 BuildRequires:  sed >= 4.0
86 BuildRequires:  sqlite3-devel >= 3
87 BuildRequires:  systemd-devel >= 1:213
88 BuildRequires:  tar >= 1:1.22
89 BuildRequires:  udev-glib-devel
90 %{?with_vala:BuildRequires:     vala >= 2:0.16}
91 BuildRequires:  xz
92 Requires(post,postun):  shared-mime-info
93 Requires:       %{name}-backend
94 Requires:       %{name}-libs = %{version}-%{release}
95 Requires:       crondaemon
96 Requires:       polkit >= 0.114
97 Suggests:       ConsoleKit-x11
98 Obsoletes:      PackageKit-backend-pisi
99 Obsoletes:      PackageKit-backend-ports
100 Obsoletes:      PackageKit-backend-smart
101 Obsoletes:      PackageKit-backend-urpmi
102 Obsoletes:      PackageKit-backend-yum
103 Obsoletes:      PackageKit-docs < 0.8.4
104 Obsoletes:      pm-utils-packagekit
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %description
108 PackageKit is a D-Bus abstraction layer that allows the session user
109 to manage packages in a secure way using a cross-distro,
110 cross-architecture API.
111
112 %description -l pl.UTF-8
113 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
114 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
115 zgodnego z wieloma dystrybucjami i architekturami.
116
117 %package libs
118 Summary:        packagekit-glib library
119 Summary(pl.UTF-8):      Biblioteka packagekit-glib
120 Group:          Libraries
121 Requires:       glib2 >= 1:2.54.0
122 Obsoletes:      browser-plugin-packagekit < 1.1.0
123
124 %description libs
125 packagekit-glib library.
126
127 %description libs -l pl.UTF-8
128 Biblioteka packagekit-glib.
129
130 %package devel
131 Summary:        Header files for packagekit-glib library
132 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
133 Group:          Development/Libraries
134 Requires:       %{name}-libs = %{version}-%{release}
135 Requires:       dbus-devel >= 1.2.0
136 Requires:       glib2-devel >= 1:2.54.0
137 Requires:       sqlite3-devel
138
139 %description devel
140 Header files for packagekit-glib library.
141
142 %description devel -l pl.UTF-8
143 Pliki nagłówkowe biblioteki packagekit-glib.
144
145 %package static
146 Summary:        Static packagekit-glib library
147 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150
151 %description static
152 Static packagekit-glib library.
153
154 %description static -l pl.UTF-8
155 Statyczna biblioteka packagekit-glib.
156
157 %package -n vala-packagekit
158 Summary:        Vala API for PackageKit library
159 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
160 Group:          Development/Libraries
161 Requires:       %{name}-devel = %{version}-%{release}
162 Requires:       vala >= 2:0.16
163 BuildArch:      noarch
164
165 %description -n vala-packagekit
166 Vala API for PackageKit library.
167
168 %description -n vala-packagekit -l pl.UTF-8
169 API języka Vala do biblioteki PackageKitu.
170
171 %package apidocs
172 Summary:        PackageKit library API documentation
173 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
174 Group:          Documentation
175 Requires:       gtk-doc-common
176 BuildArch:      noarch
177
178 %description apidocs
179 PackageKit library API documentation.
180
181 %description apidocs -l pl.UTF-8
182 Dokumentacja API biblioteki PackageKit.
183
184 %package backend-alpm
185 Summary:        PackageKit ALPM backend
186 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
187 Group:          Libraries
188 Requires:       %{name} = %{version}-%{release}
189 Provides:       %{name}-backend = %{version}-%{release}
190
191 %description backend-alpm
192 A backend for PackageKit to enable Arch Linux packages via ALPM
193 library.
194
195 %description backend-alpm -l pl.UTF-8
196 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
197 bibliotekę ALPM.
198
199 %package backend-aptcc
200 Summary:        PackageKit APTcc backend
201 Summary(pl.UTF-8):      Backend PackageKit APTcc
202 Group:          Libraries
203 Requires:       %{name} = %{version}-%{release}
204 Requires:       AppStream >= 0.11
205 Provides:       %{name}-backend = %{version}-%{release}
206
207 %description backend-aptcc
208 A backend for PackageKit to enable APT support via C++ API.
209
210 %description backend-aptcc -l pl.UTF-8
211 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
212 C++.
213
214 %package backend-dnf
215 Summary:        PackageKit dnf backend
216 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece dnfhif
217 Group:          Libraries
218 Requires:       %{name} = %{version}-%{release}
219 Provides:       %{name}-backend = %{version}-%{release}
220 Obsoletes:      PackageKit-backend-hawkey
221 Obsoletes:      PackageKit-backend-hif
222
223 %description backend-dnf
224 A backend for PackageKit to enable RPM packages support via dnf
225 library (used in Fedora).
226
227 %description backend-dnf -l pl.UTF-8
228 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
229 dnf (używaną w dystrybucji Fedora).
230
231 %package backend-entropy
232 Summary:        PackageKit Entropy backend
233 Summary(pl.UTF-8):      Backend PackageKit Entropy
234 Group:          Libraries
235 Requires:       %{name} = %{version}-%{release}
236 Requires:       python-packagekit = %{version}-%{release}
237 #Requires:      python-entropy
238 Provides:       %{name}-backend = %{version}-%{release}
239
240 %description backend-entropy
241 A backend for PackageKit to enable Sabayon packages support through
242 Entropy package manager.
243
244 %description backend-entropy -l pl.UTF-8
245 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
246 użyciu zarządcy pakietów Entropy.
247
248 %package backend-nix
249 Summary:        PackageKit Nix backend
250 Summary(pl.UTF-8):      Backend PackageKit oparty na zarządcy pakietów Nix
251 Group:          Libraries
252 Requires:       %{name} = %{version}-%{release}
253 Requires:       nix >= 1.12
254 Provides:       %{name}-backend = %{version}-%{release}
255
256 %description backend-nix
257 A backend for PackageKit to enable Nix packages support (used in
258 NixOS).
259
260 %description backend-nix -l pl.UTF-8
261 Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
262
263 %package backend-poldek
264 Summary:        PackageKit Poldek backend
265 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
266 Group:          Libraries
267 Requires:       %{name} = %{version}-%{release}
268 Requires:       poldek >= 0.30-1.rc6.4
269 Provides:       %{name}-backend = %{version}-%{release}
270
271 %description backend-poldek
272 A backend for PackageKit to enable RPM packages support through Poldek
273 - native PLD package manager.
274
275 %description backend-poldek -l pl.UTF-8
276 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
277 natywnego zarządcę pakietów dystrybucji PLD.
278
279 %package backend-portage
280 Summary:        PackageKit Portage backend
281 Summary(pl.UTF-8):      Backend PackageKit Portage
282 Group:          Libraries
283 Requires:       %{name} = %{version}-%{release}
284 Requires:       python-packagekit = %{version}-%{release}
285 #Requires:      python-portage
286 Provides:       %{name}-backend = %{version}-%{release}
287
288 %description backend-portage
289 A backend for PackageKit to enable Gentoo Portage support.
290
291 %description backend-portage -l pl.UTF-8
292 Backend PackageKit dodający obsługę systemu Portage dystrybucji
293 Gentoo.
294
295 %package backend-slack
296 Summary:        PackageKit Slack backend
297 Summary(pl.UTF-8):      Backend PackageKit Slack
298 Group:          Libraries
299 Requires:       %{name} = %{version}-%{release}
300 Provides:       %{name}-backend = %{version}-%{release}
301 Obsoletes:      PackageKit-backend-katja
302
303 %description backend-slack
304 Slack backend for PackageKit to enable Slackware repositories support.
305
306 %description backend-slack -l pl.UTF-8
307 Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
308
309 %package backend-zypp
310 Summary:        PackageKit Zypp backend
311 Summary(pl.UTF-8):      Backend PackageKit Zypp
312 Group:          Libraries
313 Requires:       %{name} = %{version}-%{release}
314 Requires:       libzypp >= 15
315 Provides:       %{name}-backend = %{version}-%{release}
316
317 %description backend-zypp
318 A backend for PackageKit to enable RPM packages support through Zypp
319 library (originated in openSUSE/SLE).
320
321 %description backend-zypp -l pl.UTF-8
322 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
323 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
324
325 %package gstreamer-plugin
326 Summary:        GStreamer codecs installer
327 Summary(pl.UTF-8):      Instalator kodeków GStreamera
328 Group:          Applications
329 Requires:       %{name} = %{version}-%{release}
330 Requires:       %{name}-gtk3-module = %{version}-%{release}
331
332 %description gstreamer-plugin
333 The PackageKit GStreamer plugin allows any GStreamer application to
334 install codecs from configured repositories using PackageKit.
335
336 %description gstreamer-plugin -l pl.UTF-8
337 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
338 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
339
340 %package gtk3-module
341 Summary:        GTK+ 3.x module to detect and install missing fonts
342 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
343 Group:          X11/Libraries
344 Obsoletes:      PackageKit-gtk-module < 1.2.0
345
346 %description gtk3-module
347 The PackageKit GTK+ 3.x module allows any pango application to install
348 missing fonts from configured repositories using PackageKit.
349
350 %description gtk3-module -l pl.UTF-8
351 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
352 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
353
354 %package -n bash-completion-packagekit
355 Summary:        Bash completion for PackageKit console commands
356 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
357 Group:          Applications/Shells
358 Requires:       %{name} = %{version}-%{release}
359 Requires:       bash-completion >= 2
360 BuildArch:      noarch
361
362 %description -n bash-completion-packagekit
363 This package provides bash-completion for PackageKit console commands.
364
365 %description -n bash-completion-packagekit -l pl.UTF-8
366 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
367 konsolowych PackageKit.
368
369 %package -n python-packagekit
370 Summary:        PackageKit Python bindings
371 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
372 Group:          Development/Languages/Python
373 Requires:       python-dbus
374 Requires:       python-pygobject
375
376 %description -n python-packagekit
377 PackageKit Python bindings.
378
379 %description -n python-packagekit -l pl.UTF-8
380 Wiązania PackageKit dla Pythona.
381
382 %prep
383 %setup -q
384 %patch0 -p1
385 %patch1 -p1
386 %patch2 -p1
387 %patch3 -p1
388
389 %if %{with static_libs}
390 %{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
391 %endif
392
393 %build
394 %{?with_zypp:CPPFLAGS="%{rpmcppflags} -D_RPM_5 -I/usr/include/rpm"}
395 %meson build \
396         -Dbash_command_not_found=false \
397         -Dbash_completion_dir=%{bash_compdir} \
398         %{!?with_introspection:-Dgobject_introspection=false} \
399         %{?with_doc:-Dgtk_doc=true} \
400         -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
401         %{!?with_python:-Dpython_backend=false} \
402         -Dpythonpackagedir=%{py_sitescriptdir} \
403         -Dsystemdsystemunitdir=%{systemdunitdir}
404
405 # TODO:
406 # -Ddnf_vendor=
407 # -Dpackagekit_user=
408
409 %ninja_build -C build
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413 install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
414
415 %ninja_install -C build
416
417 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
418
419 %if %{without apt} && %{without entropy} && %{without portage}
420 # common dir not created if no users built with PackageKit
421 install -d $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers
422 %endif
423
424 # use pk-gstreamer-install as codec installer
425 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
426
427 install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
428 ln -sf ../packagekit-offline-update.service \
429         $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
430
431 %if %{with python}
432 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
433 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
434
435 %py_postclean
436 %endif
437
438 %find_lang %{name}
439
440 %clean
441 rm -rf $RPM_BUILD_ROOT
442
443 %post
444 %update_mime_database
445
446 %postun
447 %update_mime_database
448
449 %post   libs -p /sbin/ldconfig
450 %postun libs -p /sbin/ldconfig
451
452 %files -f %{name}.lang
453 %defattr(644,root,root,755)
454 %doc AUTHORS HACKING MAINTAINERS NEWS README
455 %attr(755,root,root) %{_bindir}/pkcon
456 %attr(755,root,root) %{_bindir}/pkmon
457 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
458 %attr(755,root,root) %{_libexecdir}/packagekit-direct
459 %attr(755,root,root) %{_libexecdir}/packagekitd
460 %attr(755,root,root) %{_libexecdir}/pk-offline-update
461 %dir %{_libdir}/packagekit-backend
462 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
463 %dir %{_sysconfdir}/PackageKit
464 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
465 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
466 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
467 /etc/dbus-1/system.d/org.freedesktop.PackageKit.conf
468 %dir %{_datadir}/PackageKit
469 %dir %{_datadir}/PackageKit/helpers
470 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
471 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
472 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
473 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
474 %{_mandir}/man1/pkcon.1*
475 %{_mandir}/man1/pkmon.1*
476 %{systemdunitdir}/packagekit.service
477 %{systemdunitdir}/packagekit-offline-update.service
478 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
479 %dir /var/cache/PackageKit
480 %dir /var/cache/PackageKit/downloads
481 %dir /var/lib/PackageKit
482 %ghost /var/lib/PackageKit/transactions.db
483
484 %files libs
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
487 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
488 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
489 # NOTE: dbus interface xmls are commonly used:
490 # - at runtime by packagekitd
491 # - for development of applications using PK dbus interface
492 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
493 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
494
495 %files devel
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
498 %{_pkgconfigdir}/packagekit-glib2.pc
499 %dir %{_includedir}/PackageKit
500 %{_includedir}/PackageKit/packagekit-glib2
501 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
502
503 %files static
504 %defattr(644,root,root,755)
505 %{_libdir}/libpackagekit-glib2.a
506
507 %if %{with vala}
508 %files -n vala-packagekit
509 %defattr(644,root,root,755)
510 %{_datadir}/vala/vapi/packagekit-glib2.deps
511 %{_datadir}/vala/vapi/packagekit-glib2.vapi
512 %endif
513
514 %files apidocs
515 %defattr(644,root,root,755)
516 %{_gtkdocdir}/PackageKit
517
518 %if %{with alpm}
519 %files backend-alpm
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
522 %dir %{_sysconfdir}/PackageKit/alpm.d
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
526 %endif
527
528 %if %{with apt}
529 %files backend-aptcc
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
532 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
533 %dir %{_datadir}/PackageKit/helpers/aptcc
534 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
535 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
536 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
537 %endif
538
539 %if %{with dnf}
540 %files backend-dnf
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
543 %endif
544
545 %if %{with entropy}
546 %files backend-entropy
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
549 %dir %{_datadir}/PackageKit/helpers/entropy
550 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
551 %endif
552
553 %if %{with nix}
554 %files backend-nix
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
557 %endif
558
559 %if %{with poldek}
560 %files backend-poldek
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
563 %endif
564
565 %if %{with portage}
566 %files backend-portage
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
569 %dir %{_datadir}/PackageKit/helpers/portage
570 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
571 %endif
572
573 %if %{with slack}
574 %files backend-slack
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
577 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
578 %dir /var/cache/PackageKit/metadata
579 %ghost /var/cache/PackageKit/metadata/metadata.db
580 %endif
581
582 %if %{with zypp}
583 %files backend-zypp
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
586 %endif
587
588 %files gstreamer-plugin
589 %defattr(644,root,root,755)
590 %doc contrib/gstreamer-plugin/README
591 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
592 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
593
594 %files gtk3-module
595 %defattr(644,root,root,755)
596 %doc contrib/gtk-module/{GLASS.txt,README}
597 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
598 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
599
600 %files -n bash-completion-packagekit
601 %defattr(644,root,root,755)
602 %{bash_compdir}/pkcon
603
604 %if %{with python}
605 %files -n python-packagekit
606 %defattr(644,root,root,755)
607 %dir %{py_sitescriptdir}/packagekit
608 %{py_sitescriptdir}/packagekit/*.py[co]
609 %endif
This page took 0.243146 seconds and 4 git commands to generate.