]> git.pld-linux.org Git - packages/PackageKit.git/blob - PackageKit.spec
Release 2 (by relup.sh)
[packages/PackageKit.git] / PackageKit.spec
1 # TODO:
2 # - BASH command-not-found functionality disabled for now as it needs patched bash
3 #   (details in bash from Fedora Rawhide)
4 # - setup dnf vendor properly? (see meson command)
5 # - daemon user (see meson command)
6 #
7 # Conditional build:
8 %bcond_without  apidocs         # API documentation
9 %bcond_without  introspection   # gobject introspection, time to time broken
10 %bcond_without  static_libs     # static library
11 %bcond_without  python          # Python binding (used by entropy and portage backends)
12 %bcond_without  vala            # Vala binding
13 # backends
14 %bcond_with     alpm            # ALPM (Arch Linux package manager) backend
15 %bcond_with     apt             # APT (Debian/Ubuntu) backend using C++ API
16 %bcond_without  dnf             # DNF (Fedora/RHEL/Mageia/OpenMandriva/OpenSUSE/Rosa) backend
17 %bcond_with     entropy         # Entropy (Sabayon) backend (Python)
18 %bcond_with     nix             # Nix (NixOS) backend [broken as of 1.2.0-1.2.5]
19 %bcond_with     pisi            # PiSi (Pardus) backend (Python)
20 %bcond_without  poldek          # Poldek (PLD) backend
21 %bcond_with     portage         # portage (Gentoo) backend (Python)
22 %bcond_with     slack           # Slack (Slackware) backend
23 %bcond_with     zypp            # ZYPP (openSUSE/SLE) backend
24
25 %if %{without python}
26 %undefine       with_entropy
27 %undefine       with_pisi
28 %undefine       with_portage
29 %endif
30
31 Summary:        System daemon that is a D-Bus abstraction layer for package management
32 Summary(pl.UTF-8):      Demon systemowy będący warstwą abstrakcji D-Bus do zarządzania pakietami
33 Name:           PackageKit
34 Version:        1.2.8
35 Release:        2
36 License:        GPL v2+
37 Group:          Applications/System
38 Source0:        https://www.freedesktop.org/software/PackageKit/releases/%{name}-%{version}.tar.xz
39 # Source0-md5:  78cb918f4128a57bfc8a454b60f5a3c1
40 Patch0:         %{name}-poldek.patch
41 Patch2:         %{name}-meson.patch
42 Patch3:         consolekit-fallback.patch
43 URL:            https://www.freedesktop.org/software/PackageKit/
44 %{?with_dnf:BuildRequires:      AppStream-devel >= 0.14.0}
45 %{?with_apt:BuildRequires:      AppStream-devel >= 0.16.0}
46 BuildRequires:  NetworkManager-devel >= 0.6.5
47 # pkgconfig(libalpm) >= 13.0.0
48 %{?with_alpm:BuildRequires:     alpm-devel >= 6.0}
49 %{?with_apt:BuildRequires:      apt-devel >= 1.9.2}
50 BuildRequires:  bash-completion-devel >= 1:2.0
51 BuildRequires:  connman-devel
52 %{?with_slack:BuildRequires:    curl-devel}
53 BuildRequires:  dbus-devel >= 1.2.0
54 BuildRequires:  dbus-glib-devel >= 0.76
55 BuildRequires:  docbook-dtd412-xml
56 BuildRequires:  docbook-dtd42-xml
57 BuildRequires:  docbook-style-xsl-nons
58 BuildRequires:  fontconfig-devel
59 BuildRequires:  gettext-tools
60 BuildRequires:  glib2-devel >= 1:2.62
61 %{?with_introspection:BuildRequires:    gobject-introspection-devel >= 0.9.9}
62 BuildRequires:  gstreamer-devel >= 1.0.0
63 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
64 BuildRequires:  gtk+3-devel >= 3.0.0
65 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.11}
66 BuildRequires:  libarchive-devel
67 %{?with_dnf:BuildRequires:      libdnf-devel >= 0.43.1}
68 %if %{with apt} || %{with nix}
69 BuildRequires:  libstdc++-devel >= 6:4.7
70 %endif
71 %{?with_slack:BuildRequires:    libstdc++-devel >= 6:5}
72 BuildRequires:  libxslt-progs
73 %{?with_zypp:BuildRequires:     libzypp-devel >= 17.31.0}
74 BuildRequires:  meson >= 0.50
75 BuildRequires:  ninja >= 1.5
76 # nix-expr nix-main nix-store
77 %{?with_nix:BuildRequires:      nix-devel >= 2.9}
78 BuildRequires:  pango-devel
79 BuildRequires:  pkgconfig
80 # just to detect which reboot modes to use (library not linked)
81 #BuildRequires: plymouth-devel >= 0.9.5
82 %{?with_poldek:BuildRequires:   poldek-devel >= 0.30-1.rc6.4}
83 BuildRequires:  polkit-devel >= 0.114
84 %{?with_python:BuildRequires:   python3-devel >= 1:3.2}
85 BuildRequires:  readline-devel
86 BuildRequires:  rpm-build >= 4.6
87 %{?with_dnf:BuildRequires:      rpm-devel >= 1:4.6}
88 BuildRequires:  rpm-pythonprov
89 BuildRequires:  rpmbuild(macros) >= 1.736
90 BuildRequires:  sed >= 4.0
91 BuildRequires:  sqlite3-devel >= 3
92 # or elogind >= 229.4
93 BuildRequires:  systemd-devel >= 1:213
94 BuildRequires:  tar >= 1:1.22
95 BuildRequires:  udev-glib-devel
96 %{?with_vala:BuildRequires:     vala >= 2:0.16}
97 BuildRequires:  xz
98 Requires(post,postun):  shared-mime-info
99 Requires:       %{name}-backend
100 Requires:       %{name}-libs = %{version}-%{release}
101 Requires:       crondaemon
102 Requires:       polkit >= 0.114
103 Suggests:       ConsoleKit-x11
104 Obsoletes:      PackageKit-backend-ports < 1.2
105 Obsoletes:      PackageKit-backend-smart < 1.0
106 Obsoletes:      PackageKit-backend-urpmi < 1.2
107 Obsoletes:      PackageKit-backend-yum < 1.2
108 Obsoletes:      PackageKit-docs < 0.8.4
109 Obsoletes:      pm-utils-packagekit < 0.8.15
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %description
113 PackageKit is a D-Bus abstraction layer that allows the session user
114 to manage packages in a secure way using a cross-distro,
115 cross-architecture API.
116
117 %description -l pl.UTF-8
118 PackageKit to warstwa abstrakcji D-Bus pozwalająca użytkownikowi
119 sesyjnemu w bezpieczny sposob zarządzać pakietami przy użyciu API
120 zgodnego z wieloma dystrybucjami i architekturami.
121
122 %package libs
123 Summary:        packagekit-glib library
124 Summary(pl.UTF-8):      Biblioteka packagekit-glib
125 Group:          Libraries
126 Requires:       glib2 >= 1:2.62
127 Obsoletes:      browser-plugin-packagekit < 1.1.0
128
129 %description libs
130 packagekit-glib library.
131
132 %description libs -l pl.UTF-8
133 Biblioteka packagekit-glib.
134
135 %package devel
136 Summary:        Header files for packagekit-glib library
137 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki packagekit-glib
138 Group:          Development/Libraries
139 Requires:       %{name}-libs = %{version}-%{release}
140 Requires:       dbus-devel >= 1.2.0
141 Requires:       glib2-devel >= 1:2.62
142 Requires:       sqlite3-devel
143
144 %description devel
145 Header files for packagekit-glib library.
146
147 %description devel -l pl.UTF-8
148 Pliki nagłówkowe biblioteki packagekit-glib.
149
150 %package static
151 Summary:        Static packagekit-glib library
152 Summary(pl.UTF-8):      Statyczna biblioteka packagekit-glib
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155
156 %description static
157 Static packagekit-glib library.
158
159 %description static -l pl.UTF-8
160 Statyczna biblioteka packagekit-glib.
161
162 %package -n vala-packagekit
163 Summary:        Vala API for PackageKit library
164 Summary(pl.UTF-8):      API języka Vala do biblioteki PackageKitu
165 Group:          Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167 Requires:       vala >= 2:0.16
168 BuildArch:      noarch
169
170 %description -n vala-packagekit
171 Vala API for PackageKit library.
172
173 %description -n vala-packagekit -l pl.UTF-8
174 API języka Vala do biblioteki PackageKitu.
175
176 %package apidocs
177 Summary:        PackageKit library API documentation
178 Summary(pl.UTF-8):      Dokumentacja API biblioteki PackageKit
179 Group:          Documentation
180 Requires:       gtk-doc-common
181 BuildArch:      noarch
182
183 %description apidocs
184 PackageKit library API documentation.
185
186 %description apidocs -l pl.UTF-8
187 Dokumentacja API biblioteki PackageKit.
188
189 %package backend-alpm
190 Summary:        PackageKit ALPM backend
191 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece ALPM
192 Group:          Libraries
193 Requires:       %{name} = %{version}-%{release}
194 Provides:       %{name}-backend = %{version}-%{release}
195
196 %description backend-alpm
197 A backend for PackageKit to enable Arch Linux packages via ALPM
198 library.
199
200 %description backend-alpm -l pl.UTF-8
201 Backend PackageKit dodający obsługę pakietów Arch Linuksa poprzez
202 bibliotekę ALPM.
203
204 %package backend-aptcc
205 Summary:        PackageKit APTcc backend
206 Summary(pl.UTF-8):      Backend PackageKit APTcc
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       AppStream >= 0.12
210 Requires:       apt >= 1.9.2
211 Provides:       %{name}-backend = %{version}-%{release}
212
213 %description backend-aptcc
214 A backend for PackageKit to enable APT support via C++ API.
215
216 %description backend-aptcc -l pl.UTF-8
217 Backend PackageKit dodający obsługę zarządcy pakietów APT poprzez API
218 C++.
219
220 %package backend-dnf
221 Summary:        PackageKit dnf backend
222 Summary(pl.UTF-8):      Backend PackageKit oparty na bibliotece dnfhif
223 Group:          Libraries
224 Requires:       %{name} = %{version}-%{release}
225 Requires:       libdnf >= 0.43.1
226 Requires:       rpm >= 1:4.6
227 Provides:       %{name}-backend = %{version}-%{release}
228 Obsoletes:      PackageKit-backend-hawkey < 1.0
229 Obsoletes:      PackageKit-backend-hif < 1.2
230
231 %description backend-dnf
232 A backend for PackageKit to enable RPM packages support via dnf
233 library (used in Fedora).
234
235 %description backend-dnf -l pl.UTF-8
236 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
237 dnf (używaną w dystrybucji Fedora).
238
239 %package backend-entropy
240 Summary:        PackageKit Entropy backend
241 Summary(pl.UTF-8):      Backend PackageKit Entropy
242 Group:          Libraries
243 Requires:       %{name} = %{version}-%{release}
244 Requires:       python3-packagekit = %{version}-%{release}
245 #Requires:      python3-entropy
246 Provides:       %{name}-backend = %{version}-%{release}
247
248 %description backend-entropy
249 A backend for PackageKit to enable Sabayon packages support through
250 Entropy package manager.
251
252 %description backend-entropy -l pl.UTF-8
253 Backend PackageKit dodający obsługę pakietów dystrybucji Sabayon przy
254 użyciu zarządcy pakietów Entropy.
255
256 %package backend-nix
257 Summary:        PackageKit Nix backend
258 Summary(pl.UTF-8):      Backend PackageKit oparty na zarządcy pakietów Nix
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261 Requires:       nix >= 2.9
262 Provides:       %{name}-backend = %{version}-%{release}
263
264 %description backend-nix
265 A backend for PackageKit to enable Nix packages support (used in
266 NixOS).
267
268 %description backend-nix -l pl.UTF-8
269 Backend PackageKit dodający obsługę pakietów Nix (używanych w NixOS).
270
271 %package backend-pisi
272 Summary:        PackageKit PiSi backend
273 Summary(pl.UTF-8):      Backend PackageKit PiSi
274 Group:          Libraries
275 Requires:       %{name} = %{version}-%{release}
276 Requires:       python3-packagekit = %{version}-%{release}
277 #Requires:      python3-piksemel
278 #Requires:      python3-pisi
279 Provides:       %{name}-backend = %{version}-%{release}
280
281 %description backend-pisi
282 A backend for PackageKit to enable PiSi packages support. PiSi
283 packages are originated in Pardus distribution.
284
285 %description backend-pisi -l pl.UTF-8
286 Backend PackageKit dodający obsługę pakietów PiSi. Pakiety PiSi
287 wywodzą się z dystrybucji Pardus.
288
289 %package backend-poldek
290 Summary:        PackageKit Poldek backend
291 Summary(pl.UTF-8):      Backend PackageKit oparty na Poldku
292 Group:          Libraries
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       poldek >= 0.30-1.rc6.4
295 Provides:       %{name}-backend = %{version}-%{release}
296
297 %description backend-poldek
298 A backend for PackageKit to enable RPM packages support through Poldek
299 - native PLD package manager.
300
301 %description backend-poldek -l pl.UTF-8
302 Backend PackageKit dodający obsługę pakietów RPM poprzez Poldka -
303 natywnego zarządcę pakietów dystrybucji PLD.
304
305 %package backend-portage
306 Summary:        PackageKit Portage backend
307 Summary(pl.UTF-8):      Backend PackageKit Portage
308 Group:          Libraries
309 Requires:       %{name} = %{version}-%{release}
310 Requires:       python3-packagekit = %{version}-%{release}
311 #Requires:      python3-portage
312 Provides:       %{name}-backend = %{version}-%{release}
313
314 %description backend-portage
315 A backend for PackageKit to enable Gentoo Portage support.
316
317 %description backend-portage -l pl.UTF-8
318 Backend PackageKit dodający obsługę systemu Portage dystrybucji
319 Gentoo.
320
321 %package backend-slack
322 Summary:        PackageKit Slack backend
323 Summary(pl.UTF-8):      Backend PackageKit Slack
324 Group:          Libraries
325 Requires:       %{name} = %{version}-%{release}
326 Provides:       %{name}-backend = %{version}-%{release}
327 Obsoletes:      PackageKit-backend-katja < 1.2
328
329 %description backend-slack
330 Slack backend for PackageKit to enable Slackware repositories support.
331
332 %description backend-slack -l pl.UTF-8
333 Backend PackageKit Slack dodający obsługę repozytoriów Slackware.
334
335 %package backend-zypp
336 Summary:        PackageKit Zypp backend
337 Summary(pl.UTF-8):      Backend PackageKit Zypp
338 Group:          Libraries
339 Requires:       %{name} = %{version}-%{release}
340 Requires:       libzypp >= 17.31.0
341 Provides:       %{name}-backend = %{version}-%{release}
342
343 %description backend-zypp
344 A backend for PackageKit to enable RPM packages support through Zypp
345 library (originated in openSUSE/SLE).
346
347 %description backend-zypp -l pl.UTF-8
348 Backend PackageKit dodający obsługę pakietów RPM poprzez bibliotekę
349 Zypp (pochodzącą z dystrybucji openSUSE/SLE).
350
351 %package gstreamer-plugin
352 Summary:        GStreamer codecs installer
353 Summary(pl.UTF-8):      Instalator kodeków GStreamera
354 Group:          Applications
355 Requires:       %{name} = %{version}-%{release}
356 Requires:       %{name}-gtk3-module = %{version}-%{release}
357
358 %description gstreamer-plugin
359 The PackageKit GStreamer plugin allows any GStreamer application to
360 install codecs from configured repositories using PackageKit.
361
362 %description gstreamer-plugin -l pl.UTF-8
363 Wtyczka GStreamer pozwala każdej aplikacji używającej GStreamera
364 zainstalować kodeki ze skonfigurowanych źródeł PackageKit.
365
366 %package gtk3-module
367 Summary:        GTK+ 3.x module to detect and install missing fonts
368 Summary(pl.UTF-8):      Moduł GTK+ 3.x do wykrywania i instalowania brakujących czcionek
369 Group:          X11/Libraries
370 Obsoletes:      PackageKit-gtk-module < 1.2.0
371
372 %description gtk3-module
373 The PackageKit GTK+ 3.x module allows any pango application to install
374 missing fonts from configured repositories using PackageKit.
375
376 %description gtk3-module -l pl.UTF-8
377 Moduł GTK+ 3.x pozwala każdej aplikacji używającej pango zainstalować
378 brakującą czcionkę ze skonfigurowanych źródeł PackageKit.
379
380 %package -n bash-completion-packagekit
381 Summary:        Bash completion for PackageKit console commands
382 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń konsolowych PackageKit
383 Group:          Applications/Shells
384 Requires:       %{name} = %{version}-%{release}
385 Requires:       bash-completion >= 1:2.0
386 BuildArch:      noarch
387
388 %description -n bash-completion-packagekit
389 This package provides bash-completion for PackageKit console commands.
390
391 %description -n bash-completion-packagekit -l pl.UTF-8
392 Pakiet ten dostarcza bashowe uzupełnianie parametrów dla poleceń
393 konsolowych PackageKit.
394
395 %package -n python3-packagekit
396 Summary:        PackageKit Python bindings
397 Summary(pl.UTF-8):      Wiązania PackageKit dla Pythona
398 Group:          Development/Languages/Python
399 Obsoletes:      python-packagekit < 1.2.7
400
401 %description -n python3-packagekit
402 PackageKit Python bindings.
403
404 %description -n python3-packagekit -l pl.UTF-8
405 Wiązania PackageKit dla Pythona.
406
407 %prep
408 %setup -q
409 %patch0 -p1
410 %patch2 -p1
411 %patch3 -p1
412
413 %{__sed} -i -e '1s,/usr/bin/python$,%{__python3},' backends/pisi/pisiBackend.py
414
415 %if %{with static_libs}
416 %{__sed} -i -e '/^packagekit_glib2_library =/ s/shared_library/library/' lib/packagekit-glib2/meson.build
417 %endif
418
419 %build
420 %meson build \
421         --python.bytecompile=2 \
422         -Dbash_command_not_found=false \
423         %{!?with_introspection:-Dgobject_introspection=false} \
424         %{?with_apidocs:-Dgtk_doc=true} \
425         -Dpackaging_backend=dummy%{?with_alpm:,alpm}%{?with_apt:,aptcc}%{?with_dnf:,dnf}%{?with_entropy:,entropy}%{?with_pisi:,pisi}%{?with_poldek:,poldek}%{?with_portage:,portage}%{?with_slack:,slack}%{?with_zypp:,zypp}%{?with_nix:,nix} \
426         %{!?with_python:-Dpython_backend=false} \
427         -Dsystemdsystemunitdir=%{systemdunitdir}
428
429 # TODO:
430 # -Ddnf_vendor=
431 # -Dpackagekit_user=
432
433 %ninja_build -C build
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437 install -d $RPM_BUILD_ROOT/var/cache/PackageKit/downloads
438
439 %ninja_install -C build
440
441 %{__rm} $RPM_BUILD_ROOT%{_libdir}/packagekit-backend/libpk_backend_test_*.so
442 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/PackageKit/helpers/test_spawn
443
444 # use pk-gstreamer-install as codec installer
445 ln -s pk-gstreamer-install $RPM_BUILD_ROOT%{_libexecdir}/gst-install-plugins-helper
446
447 install -d $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants
448 ln -sf ../packagekit-offline-update.service \
449         $RPM_BUILD_ROOT%{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
450
451 %find_lang %{name}
452
453 %clean
454 rm -rf $RPM_BUILD_ROOT
455
456 %post
457 %update_mime_database
458
459 %postun
460 %update_mime_database
461
462 %post   libs -p /sbin/ldconfig
463 %postun libs -p /sbin/ldconfig
464
465 %files -f %{name}.lang
466 %defattr(644,root,root,755)
467 %doc AUTHORS HACKING MAINTAINERS NEWS README
468 %attr(755,root,root) %{_bindir}/pkcon
469 %attr(755,root,root) %{_bindir}/pkmon
470 %attr(750,root,root) /etc/cron.daily/packagekit-background.cron
471 %attr(755,root,root) %{_libexecdir}/packagekit-direct
472 %attr(755,root,root) %{_libexecdir}/packagekitd
473 %attr(755,root,root) %{_libexecdir}/pk-offline-update
474 %dir %{_libdir}/packagekit-backend
475 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dummy.so
476 %dir %{_sysconfdir}/PackageKit
477 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/PackageKit.conf
478 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Vendor.conf
479 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/packagekit-background
480 %dir %{_datadir}/PackageKit
481 %dir %{_datadir}/PackageKit/helpers
482 %attr(755,root,root) %{_datadir}/PackageKit/pk-upgrade-distro.sh
483 %{_datadir}/polkit-1/actions/org.freedesktop.packagekit.policy
484 %{_datadir}/polkit-1/rules.d/org.freedesktop.packagekit.rules
485 %{_datadir}/dbus-1/system-services/org.freedesktop.PackageKit.service
486 %{_datadir}/dbus-1/system.d/org.freedesktop.PackageKit.conf
487 %{_datadir}/metainfo/org.freedesktop.packagekit.metainfo.xml
488 %{_mandir}/man1/pkcon.1*
489 %{_mandir}/man1/pkmon.1*
490 %{systemdunitdir}/packagekit.service
491 %{systemdunitdir}/packagekit-offline-update.service
492 %{systemdunitdir}/system-update.target.wants/packagekit-offline-update.service
493 %dir /var/cache/PackageKit
494 %dir /var/cache/PackageKit/downloads
495 %dir /var/lib/PackageKit
496 %ghost /var/lib/PackageKit/transactions.db
497
498 %files libs
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so.*.*.*
501 %attr(755,root,root) %ghost %{_libdir}/libpackagekit-glib2.so.18
502 %{_libdir}/girepository-1.0/PackageKitGlib-1.0.typelib
503 # NOTE: dbus interface xmls are commonly used:
504 # - at runtime by packagekitd
505 # - for development of applications using PK dbus interface
506 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.Transaction.xml
507 %{_datadir}/dbus-1/interfaces/org.freedesktop.PackageKit.xml
508
509 %files devel
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_libdir}/libpackagekit-glib2.so
512 %{_pkgconfigdir}/packagekit-glib2.pc
513 %dir %{_includedir}/PackageKit
514 %{_includedir}/PackageKit/packagekit-glib2
515 %{_datadir}/gir-1.0/PackageKitGlib-1.0.gir
516
517 %if %{with static_libs}
518 %files static
519 %defattr(644,root,root,755)
520 %{_libdir}/libpackagekit-glib2.a
521 %endif
522
523 %if %{with vala}
524 %files -n vala-packagekit
525 %defattr(644,root,root,755)
526 %{_datadir}/vala/vapi/packagekit-glib2.deps
527 %{_datadir}/vala/vapi/packagekit-glib2.vapi
528 %endif
529
530 %if %{with apidocs}
531 %files apidocs
532 %defattr(644,root,root,755)
533 %{_gtkdocdir}/PackageKit
534 %endif
535
536 %if %{with alpm}
537 %files backend-alpm
538 %defattr(644,root,root,755)
539 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_alpm.so
540 %dir %{_sysconfdir}/PackageKit/alpm.d
541 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/groups.list
542 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/pacman.conf
543 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/alpm.d/repos.list
544 # FIXME: dirs should be owned by alpm?
545 %dir %{_datadir}/libalpm
546 %dir %{_datadir}/libalpm/hooks
547 %{_datadir}/libalpm/hooks/90-packagekit-refresh.hook
548 %endif
549
550 %if %{with apt}
551 %files backend-aptcc
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_aptcc.so
554 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apt/apt.conf.d/20packagekit
555 %dir %{_datadir}/PackageKit/helpers/aptcc
556 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/get-distro-upgrade.py
557 %attr(755,root,root) %{_datadir}/PackageKit/helpers/aptcc/pkconffile
558 %{_datadir}/PackageKit/helpers/aptcc/pkconffile.nodiff
559 %endif
560
561 %if %{with dnf}
562 %files backend-dnf
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_dnf.so
565 %attr(755,root,root) %{_libexecdir}/packagekit-dnf-refresh-repo
566 %{py3_sitescriptdir}/dnf-plugins/notify_packagekit.py
567 %{py3_sitescriptdir}/dnf-plugins/__pycache__/notify_packagekit.cpython-*.py[co]
568 %endif
569
570 %if %{with entropy}
571 %files backend-entropy
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_entropy.so
574 %dir %{_datadir}/PackageKit/helpers/entropy
575 %attr(755,root,root) %{_datadir}/PackageKit/helpers/entropy/entropyBackend.py
576 %endif
577
578 %if %{with nix}
579 %files backend-nix
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_nix.so
582 %endif
583
584 %if %{with pisi}
585 %files backend-pisi
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_pisi.so
588 %dir %{_datadir}/PackageKit/helpers/pisi
589 %attr(755,root,root) %{_datadir}/PackageKit/helpers/pisi/pisiBackend.py
590 %endif
591
592 %if %{with poldek}
593 %files backend-poldek
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_poldek.so
596 %endif
597
598 %if %{with portage}
599 %files backend-portage
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_portage.so
602 %dir %{_datadir}/PackageKit/helpers/portage
603 %attr(755,root,root) %{_datadir}/PackageKit/helpers/portage/portageBackend.py
604 %endif
605
606 %if %{with slack}
607 %files backend-slack
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_slack.so
610 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/PackageKit/Slackware.conf
611 %dir /var/cache/PackageKit/metadata
612 %ghost /var/cache/PackageKit/metadata/metadata.db
613 %endif
614
615 %if %{with zypp}
616 %files backend-zypp
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_libdir}/packagekit-backend/libpk_backend_zypp.so
619 %endif
620
621 %files gstreamer-plugin
622 %defattr(644,root,root,755)
623 %doc contrib/gstreamer-plugin/README
624 %attr(755,root,root) %{_libexecdir}/gst-install-plugins-helper
625 %attr(755,root,root) %{_libexecdir}/pk-gstreamer-install
626
627 %files gtk3-module
628 %defattr(644,root,root,755)
629 %doc contrib/gtk-module/{GLASS.txt,README}
630 %attr(755,root,root) %{_libdir}/gtk-3.0/modules/libpk-gtk-module.so
631 %{_libdir}/gnome-settings-daemon-3.0/gtk-modules/pk-gtk-module.desktop
632
633 %files -n bash-completion-packagekit
634 %defattr(644,root,root,755)
635 %{bash_compdir}/pkcon
636
637 %if %{with python}
638 %files -n python3-packagekit
639 %defattr(644,root,root,755)
640 %{py3_sitescriptdir}/packagekit
641 %endif
This page took 0.102695 seconds and 4 git commands to generate.