]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
add format-security hack
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #BuildRequires: autoconf
19 #BuildRequires: automake
20 #BuildRequires: intltool
21 #BuildRequires: libtool
22 #Requires(postun):      -
23 #Requires(pre,post):    -
24 #Requires(preun):       -
25 #Requires:      -
26 #Provides:      -
27 #Obsoletes:     -
28 #Conflicts:     -
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # do not keep them in newly created specs
32 # these are only here to help fixing quickly broken specs
33 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
34 %define         filterout_ld    -Wl,--as-needed
35 # do not commit spec containing this (use for local testing only):
36 %define         filterout_c     -Werror=format-security
37
38 # Ignore file in __spec_install_post_check_so
39 BuildRequires:  rpmbuild(macros) >= 1.583
40 %define         skip_post_check_so      libunresolved.so.*
41
42 %description
43
44 #%description -l pl.UTF-8
45
46 %package common
47 Summary:        Common files for %{name} library
48 Summary(pl.UTF-8):      Wspólne pliki biblioteki %{name}
49 Group:          Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description common
53 Common files for %{name} library.
54
55 %description common -l pl.UTF-8
56 Wspólne pliki biblioteki %{name}.
57
58 %package devel
59 Summary:        Header files for %{name} library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63
64 %description devel
65 Header files for %{name} library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki %{name}.
69
70 %package static
71 Summary:        Static %{name} library
72 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static %{name} library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka %{name}.
81
82 %package apidocs
83 Summary:        %{name} API documentation
84 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
85 Group:          Documentation
86
87 %description apidocs
88 API documentation for %{name} library.
89
90 %description apidocs -l pl.UTF-8
91 Dokumentacja API biblioteki %{name}.
92
93 %prep
94 %setup -q
95 #%patch0 -p1
96
97 %build
98 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
99 # appropriate BuildRequires
100 #%{__libtoolize}
101 #%{__aclocal}
102 #%{__autoconf}
103 #%{__autoheader}
104 #%{__automake}
105 %configure \
106         %{!?with_static_libs:--disable-static}
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 # create directories if necessary
112 #install -d $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 # if library provides pkgconfig file containing proper {Requires,Libs}.private
118 # then remove .la pollution
119 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS CREDITS README THANKS
130 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
132
133 %files common
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/%{name}*
136 %{_datadir}/%{name}
137
138 %files devel
139 %defattr(644,root,root,755)
140 %doc devel-doc/* ChangeLog NEWS TODO
141 %attr(755,root,root) %{_libdir}/%{name}.so
142 # if no pkgconfig support, or it misses .private deps, then include .la file
143 #%{_libdir}/libFOO.la
144 %{_includedir}/%{name}
145 %{_aclocaldir}/%{name}.m4
146 %{_pkgconfigdir}/%{name}.pc
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/%{name}.a
152 %endif
153
154 %if %{with apidocs}
155 %files apidocs
156 %defattr(644,root,root,755)
157 %doc apidocs/*
158 %endif
This page took 0.063451 seconds and 4 git commands to generate.