]> git.pld-linux.org Git - projects/template-specs.git/blame - lib.spec
add format-security hack
[projects/template-specs.git] / lib.spec
CommitLineData
3cb1cd3d 1#
66df3cad
ER
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
aed9d573 4%bcond_without static_libs # don't build static libraries
66df3cad 5#
f9986cd5 6Summary: -
ce39d734 7Summary(pl.UTF-8): -
3f8f5e5b
ER
8Name: ---
9Version: 0.1
10Release: 0.1
f9986cd5
JB
11License: - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12Group: Libraries
13Source0: %{name}-%{version}.tar.gz
14# Source0-md5: -
3f8f5e5b
ER
15#Patch0: %{name}-what.patch
16#URL: -
17#BuildRequires: -
c53387e8
ER
18#BuildRequires: autoconf
19#BuildRequires: automake
20#BuildRequires: intltool
21#BuildRequires: libtool
3f8f5e5b
ER
22#Requires(postun): -
23#Requires(pre,post): -
24#Requires(preun): -
25#Requires: -
26#Provides: -
27#Obsoletes: -
28#Conflicts: -
f9986cd5
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
a1a32384
ER
31# do not keep them in newly created specs
32# these are only here to help fixing quickly broken specs
33%define filterout_ld -Wl,--no-copy-dt-needed-entries
34%define filterout_ld -Wl,--as-needed
31c122e0
ER
35# do not commit spec containing this (use for local testing only):
36%define filterout_c -Werror=format-security
a1a32384 37
20667fb2 38# Ignore file in __spec_install_post_check_so
5346ce74 39BuildRequires: rpmbuild(macros) >= 1.583
e24df1c5 40%define skip_post_check_so libunresolved.so.*
20667fb2 41
f9986cd5
JB
42%description
43
3f8f5e5b 44#%description -l pl.UTF-8
f9986cd5 45
41119926 46%package common
ca8abdb7
TP
47Summary: Common files for %{name} library
48Summary(pl.UTF-8): Wspólne pliki biblioteki %{name}
41119926
TP
49Group: Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description common
ca8abdb7 53Common files for %{name} library.
41119926
TP
54
55%description common -l pl.UTF-8
ca8abdb7 56Wspólne pliki biblioteki %{name}.
41119926 57
f9986cd5 58%package devel
ca8abdb7
TP
59Summary: Header files for %{name} library
60Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
f9986cd5 61Group: Development/Libraries
d7dd7729 62Requires: %{name} = %{version}-%{release}
f9986cd5
JB
63
64%description devel
ca8abdb7 65Header files for %{name} library.
f9986cd5 66
9be49f18 67%description devel -l pl.UTF-8
ca8abdb7 68Pliki nagłówkowe biblioteki %{name}.
f9986cd5
JB
69
70%package static
ca8abdb7
TP
71Summary: Static %{name} library
72Summary(pl.UTF-8): Statyczna biblioteka %{name}
f9986cd5 73Group: Development/Libraries
d7dd7729 74Requires: %{name}-devel = %{version}-%{release}
f9986cd5
JB
75
76%description static
ca8abdb7 77Static %{name} library.
f9986cd5 78
9be49f18 79%description static -l pl.UTF-8
ca8abdb7 80Statyczna biblioteka %{name}.
f9986cd5 81
66df3cad 82%package apidocs
ca8abdb7
TP
83Summary: %{name} API documentation
84Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
66df3cad
ER
85Group: Documentation
86
87%description apidocs
e077345b 88API documentation for %{name} library.
66df3cad 89
3cb1cd3d 90%description apidocs -l pl.UTF-8
ca8abdb7 91Dokumentacja API biblioteki %{name}.
3cb1cd3d 92
f9986cd5
JB
93%prep
94%setup -q
1c854c4b 95#%patch0 -p1
f9986cd5
JB
96
97%build
c42a30cf
JB
98# if ac/am/lt/* rebuilding is necessary, do it in this order and add
99# appropriate BuildRequires
100#%{__libtoolize}
101#%{__aclocal}
102#%{__autoconf}
103#%{__autoheader}
104#%{__automake}
f6de6810
ER
105%configure \
106 %{!?with_static_libs:--disable-static}
f9986cd5
JB
107%{__make}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111# create directories if necessary
112#install -d $RPM_BUILD_ROOT
113
114%{__make} install \
115 DESTDIR=$RPM_BUILD_ROOT
116
14750145
JB
117# if library provides pkgconfig file containing proper {Requires,Libs}.private
118# then remove .la pollution
4b532792
JR
119#%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
120
f9986cd5
JB
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(644,root,root,755)
41119926
TP
129%doc AUTHORS CREDITS README THANKS
130%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
131%attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
132
133%files common
134%defattr(644,root,root,755)
135%attr(755,root,root) %{_bindir}/%{name}*
f9986cd5
JB
136%{_datadir}/%{name}
137
138%files devel
139%defattr(644,root,root,755)
41119926
TP
140%doc devel-doc/* ChangeLog NEWS TODO
141%attr(755,root,root) %{_libdir}/%{name}.so
14750145
JB
142# if no pkgconfig support, or it misses .private deps, then include .la file
143#%{_libdir}/libFOO.la
41119926
TP
144%{_includedir}/%{name}
145%{_aclocaldir}/%{name}.m4
146%{_pkgconfigdir}/%{name}.pc
f9986cd5 147
f6de6810 148%if %{with static_libs}
f9986cd5
JB
149%files static
150%defattr(644,root,root,755)
41119926 151%{_libdir}/%{name}.a
f6de6810 152%endif
66df3cad 153
a5f7d790 154%if %{with apidocs}
66df3cad
ER
155%files apidocs
156%defattr(644,root,root,755)
157%doc apidocs/*
a5f7d790 158%endif
This page took 0.562777 seconds and 4 git commands to generate.