]> git.pld-linux.org Git - packages/yaml-cpp.git/blob - yaml-cpp.spec
- updated to 0.8.0 (new soname)
[packages/yaml-cpp.git] / yaml-cpp.spec
1 Summary:        YAML parser and emitter for C++
2 Summary(pl.UTF-8):      Biblioteka C++ analizująca i generująca YAML
3 Name:           yaml-cpp
4 Version:        0.7.0
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/jbeder/yaml-cpp/releases
9 Source0:        https://github.com/jbeder/yaml-cpp/archive/%{name}-%{version}.tar.gz
10 # Source0-md5:  74d646a3cc1b5d519829441db96744f0
11 Patch0:         %{name}-gtest-no-install.patch
12 Patch1:         %{name}-cmake-config.patch
13 URL:            https://github.com/jbeder/yaml-cpp/
14 BuildRequires:  cmake >= 3.4
15 BuildRequires:  libstdc++-devel >= 6:4.7
16 BuildRequires:  rpmbuild(macros) >= 1.605
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 YAML parser and emitter for C++.
21
22 %description -l pl.UTF-8
23 Biblioteka C++ analizująca i generująca YAML.
24
25 %package devel
26 Summary:        Header files for yaml-cpp library
27 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki yaml-cpp
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30 Requires:       libstdc++-devel >= 6:4.7
31
32 %description devel
33 Header files for yaml-cpp library.
34
35 %description devel -l pl.UTF-8
36 Pliki nagłówkowe biblioteki yaml-cpp.
37
38 %prep
39 %setup -q -n %{name}-%{name}-%{version}
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 install -d build
45 cd build
46 # .pc file requires relative INCLUDEDIR, LIBDIR
47 # DATADIR is used for arch-dependent .pc and cmake files
48 %cmake .. \
49         -DCMAKE_INSTALL_INCLUDEDIR=include \
50         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
51         -DCMAKE_INSTALL_DATADIR=%{_lib}
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} -C build install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %doc LICENSE README.md
69 %attr(755,root,root) %{_libdir}/libyaml-cpp.so.*.*.*
70 %attr(755,root,root) %ghost %{_libdir}/libyaml-cpp.so.0.7
71
72 %files devel
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_libdir}/libyaml-cpp.so
75 %{_includedir}/yaml-cpp
76 %{_pkgconfigdir}/yaml-cpp.pc
77 %{_libdir}/cmake/yaml-cpp
This page took 0.314175 seconds and 3 git commands to generate.