]> git.pld-linux.org Git - packages/yaml-cpp.git/blob - yaml-cpp.spec
- updated to 0.8.0 (new soname)
[packages/yaml-cpp.git] / yaml-cpp.spec
1 Summary:        YAML parser and emitter for C++
2 Summary(pl.UTF-8):      Biblioteka C++ analizująca i generująca YAML
3 Name:           yaml-cpp
4 Version:        0.8.0
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://github.com/jbeder/yaml-cpp/releases
9 Source0:        https://github.com/jbeder/yaml-cpp/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  1d2c7975edba60e995abe3c4af6480e5
11 Patch0:         %{name}-gtest-no-install.patch
12 URL:            https://github.com/jbeder/yaml-cpp/
13 BuildRequires:  cmake >= 3.4
14 BuildRequires:  libstdc++-devel >= 6:4.7
15 BuildRequires:  rpmbuild(macros) >= 1.605
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 YAML parser and emitter for C++.
20
21 %description -l pl.UTF-8
22 Biblioteka C++ analizująca i generująca YAML.
23
24 %package devel
25 Summary:        Header files for yaml-cpp library
26 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki yaml-cpp
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29 Requires:       libstdc++-devel >= 6:4.7
30
31 %description devel
32 Header files for yaml-cpp library.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe biblioteki yaml-cpp.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %build
42 install -d build
43 cd build
44 # .pc file requires relative INCLUDEDIR, LIBDIR
45 # DATADIR is used for arch-dependent .pc and cmake files
46 %cmake .. \
47         -DCMAKE_INSTALL_INCLUDEDIR=include \
48         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
49         -DCMAKE_INSTALL_DATADIR=%{_lib}
50 %{__make}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} -C build install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post   -p /sbin/ldconfig
62 %postun -p /sbin/ldconfig
63
64 %files
65 %defattr(644,root,root,755)
66 %doc LICENSE README.md
67 %attr(755,root,root) %{_libdir}/libyaml-cpp.so.*.*.*
68 %attr(755,root,root) %ghost %{_libdir}/libyaml-cpp.so.0.8
69
70 %files devel
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_libdir}/libyaml-cpp.so
73 %{_includedir}/yaml-cpp
74 %{_pkgconfigdir}/yaml-cpp.pc
75 %{_libdir}/cmake/yaml-cpp
This page took 0.112089 seconds and 4 git commands to generate.