]> git.pld-linux.org Git - packages/widelands.git/blob - widelands.spec
- massive change ( validate errors warrings from desktop-file-validate)
[packages/widelands.git] / widelands.spec
1 #
2 # TODO:
3 # - translations
4 #
5 %define         _build  11
6 Summary:        Game like Settlers II
7 Summary(pl.UTF-8):      Remake gry Settlers II
8 Name:           widelands
9 Version:        0.build%{_build}
10 Release:        0.1
11 License:        GPL
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/widelands/%{name}-build-%{_build}-source.tar.bz2
14 # Source0-md5:  ad41d917f7895b6212009ac584178b55
15 Source1:        %{name}.desktop
16 URL:            http://widelands.sourceforge.net/
17 BuildRequires:  SDL-devel >= 1.2.11
18 BuildRequires:  SDL_gfx-devel
19 BuildRequires:  SDL_image-devel
20 BuildRequires:  SDL_mixer-devel >= 1.2.7
21 BuildRequires:  SDL_net-devel
22 BuildRequires:  SDL_ttf-devel >= 2.0.0
23 BuildRequires:  libpng-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  sed >= 4.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 In Widelands, you are the regent of a small tribe. You start out with
30 nothing but your headquarters, a kind of castle in which all your
31 resources are stored. Every member of your tribe will do his or her
32 part to produce more resources - wood, food, iron, gold and more - to
33 further this growth. But you are not alone in the world, and you will
34 meet other tribes sooner or later. Some of them may be friendly and
35 trade with you. However, if you want to rule the world, you will have
36 to train soldiers and fight.
37
38 %description -l pl.UTF-8
39 W grze Widelands jesteś regentem niewielkiego plemienia. Rozpoczynasz
40 grę tylko z kwaterą główną, czymś w rodzaju zamku, w której
41 przechowywane są wszystkie Twoje zasoby. Każdy członek plemienia
42 wykona swoje zadanie w procesie produkcji tychże zasobów - drewna,
43 żywności, żelaza, złota i wielu innych - aby zapewnić rozwój. Jednak
44 nie jesteś sam na tym świecie i wcześniej lub później będziesz musiał
45 spotkać się z innymi plemionami. Niektóre z nich mogą być przyjaźnie
46 nastawione i rozpocząć z Tobą handel. Jednak, jeśli chcesz rządzić
47 światem, będziesz musiał wyszkolić żołnierzy i walczyć.
48
49 %prep
50 %setup -q -n %{name}
51 rm -f {campaigns,fonts,maps,music,pics,sound,tribes,txts,worlds}/SConscript
52 # Fixing path
53 find -type f "(" -name *.cc -or -name *.h ")" -exec sed -i \
54     -e 's|#include "filesystem.h"|#include "filesystem/filesystem.h"|g' \
55     -e 's|#include "layered_filesystem.h"|#include "filesystem/layered_filesystem.h"|g' \
56     -e 's|#include "zip_exceptions.h"|#include "filesystem/zip_exceptions.h"|g' \
57     -e 's|#include "zip_filesystem.h"|#include "filesystem/zip_filesystem.h"|g' \
58     "{}" ";"
59
60
61 %build
62 rm -f widelands
63 %{__make} \
64         CXX="%{__cxx}" \
65         CXXFLAGS="%{rpmcflags} -Isrc/ui/ui_basic -Isrc -Isrc/editor -Isrc/editor/ui_menus -Isrc/ui/ui_fs_menus -Isrc/editor/tools `sdl-config --cflags`" \
66         IMPLICIT_LIBINTL="YES"
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/games/%{name},%{_desktopdir},%{_pixmapsdir}}
71
72 install widelands $RPM_BUILD_ROOT%{_bindir}
73 install pics/wl-logo-64.png $RPM_BUILD_ROOT%{_pixmapsdir}/widelands.png
74 cp -r campaigns fonts maps music pics sound tribes txts worlds $RPM_BUILD_ROOT%{_datadir}/games/%{name}
75
76 cp %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc ChangeLog
84 %attr(755,root,root) %{_bindir}/widelands
85 %{_datadir}/games/widelands
86 %{_desktopdir}/widelands.desktop
87 %{_pixmapsdir}/widelands.png
This page took 0.078582 seconds and 4 git commands to generate.