]> git.pld-linux.org Git - packages/ruby-sshkit.git/blob - ruby-sshkit.spec
new, version 1.9.0
[packages/ruby-sshkit.git] / ruby-sshkit.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname sshkit
6 Summary:        SSHKit makes it easy to write structured, testable SSH commands in Ruby
7 Name:           ruby-%{pkgname}
8 Version:        1.9.0
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  4eb808cf5a4ac954328fdc1965f5e232
14 URL:            http://github.com/capistrano/sshkit
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-minitest >= 5.0.0
19 BuildRequires:  ruby-minitest-reporters
20 BuildRequires:  ruby-mocha
21 BuildRequires:  ruby-rake
22 BuildRequires:  ruby-rubocop
23 BuildRequires:  ruby-unindent
24 %endif
25 Requires:       ruby-net-scp >= 1.1.2
26 Requires:       ruby-net-ssh >= 2.8.0
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 A comprehensive toolkit for remotely running commands in a structured
32 manner on groups of servers.
33
34 %prep
35 %setup -q -n %{pkgname}-%{version}
36
37 %build
38 # write .gemspec
39 %__gem_helper spec
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
44 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
45 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %{ruby_vendorlibdir}/%{pkgname}.rb
53 %{ruby_vendorlibdir}/%{pkgname}
54 %dir %{ruby_vendorlibdir}/core_ext
55 %{ruby_vendorlibdir}/core_ext/array.rb
56 %{ruby_vendorlibdir}/core_ext/hash.rb
57 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.093457 seconds and 3 git commands to generate.