]> git.pld-linux.org Git - packages/ruby-sshkit.git/blame - ruby-sshkit.spec
new, version 1.9.0
[packages/ruby-sshkit.git] / ruby-sshkit.spec
CommitLineData
f3587102
ER
1#
2# Conditional build:
3%bcond_with tests # build without tests
4
5%define pkgname sshkit
6Summary: SSHKit makes it easy to write structured, testable SSH commands in Ruby
7Name: ruby-%{pkgname}
8Version: 1.9.0
9Release: 1
10License: MIT
11Group: Development/Languages
12Source0: http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13# Source0-md5: 4eb808cf5a4ac954328fdc1965f5e232
14URL: http://github.com/capistrano/sshkit
15BuildRequires: rpm-rubyprov
16BuildRequires: rpmbuild(macros) >= 1.656
17%if %{with tests}
18BuildRequires: ruby-minitest >= 5.0.0
19BuildRequires: ruby-minitest-reporters
20BuildRequires: ruby-mocha
21BuildRequires: ruby-rake
22BuildRequires: ruby-rubocop
23BuildRequires: ruby-unindent
24%endif
25Requires: ruby-net-scp >= 1.1.2
26Requires: ruby-net-ssh >= 2.8.0
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31A comprehensive toolkit for remotely running commands in a structured
32manner on groups of servers.
33
34%prep
35%setup -q -n %{pkgname}-%{version}
36
37%build
38# write .gemspec
39%__gem_helper spec
40
41%install
42rm -rf $RPM_BUILD_ROOT
43install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
44cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
45cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
46
47%clean
48rm -rf $RPM_BUILD_ROOT
49
50%files
51%defattr(644,root,root,755)
52%{ruby_vendorlibdir}/%{pkgname}.rb
53%{ruby_vendorlibdir}/%{pkgname}
54%dir %{ruby_vendorlibdir}/core_ext
55%{ruby_vendorlibdir}/core_ext/array.rb
56%{ruby_vendorlibdir}/core_ext/hash.rb
57%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.092442 seconds and 4 git commands to generate.