]> git.pld-linux.org Git - packages/ruby-activesupport.git/commitdiff
- up to 3.0.3 auto/th/ruby-activesupport-3_0_3-1
authoraredridel <aredridel@pld-linux.org>
Tue, 30 Nov 2010 22:19:07 +0000 (22:19 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ruby-activesupport-nogems.patch -> 1.4
    ruby-activesupport-thread.patch -> 1.2
    ruby-activesupport.spec -> 1.31

ruby-activesupport-nogems.patch [deleted file]
ruby-activesupport-thread.patch [deleted file]
ruby-activesupport.spec

diff --git a/ruby-activesupport-nogems.patch b/ruby-activesupport-nogems.patch
deleted file mode 100644 (file)
index 06a4694..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-diff --git a/lib/active_support.rb b/lib/active_support.rb
-index 7ebb3c4..63c76cc 100644
---- a/lib/active_support.rb
-+++ b/lib/active_support.rb
-@@ -51,7 +51,7 @@ module ActiveSupport
-   autoload :XmlMini, 'active_support/xml_mini'
- end
--require 'active_support/vendor'
-+require 'i18n'
- require 'active_support/core_ext'
- require 'active_support/dependencies'
- require 'active_support/json'
-diff --git a/lib/active_support/json/encoding.rb b/lib/active_support/json/encoding.rb
-index ffd2050..7b30ee8 100644
---- a/lib/active_support/json/encoding.rb
-+++ b/lib/active_support/json/encoding.rb
-@@ -81,10 +81,7 @@ module ActiveSupport
- end
- # Hack to load json gem first so we can overwrite its to_json.
--begin
-   require 'json'
--rescue LoadError
--end
- require 'active_support/json/variable'
- require 'active_support/json/encoders/date'
-diff --git a/lib/active_support/test_case.rb b/lib/active_support/test_case.rb
-index bde74fa..8421241 100644
---- a/lib/active_support/test_case.rb
-+++ b/lib/active_support/test_case.rb
-@@ -5,7 +5,6 @@ require 'active_support/testing/deprecation'
- require 'active_support/testing/declarative'
- begin
--  gem 'mocha', ">= 0.9.7"
-   require 'mocha'
- rescue LoadError
-   # Fake Mocha::ExpectationError so we can rescue it in #run. Bleh.
-diff --git a/lib/active_support/testing/performance.rb b/lib/active_support/testing/performance.rb
-index f8d12e8..38837a3 100644
---- a/lib/active_support/testing/performance.rb
-+++ b/lib/active_support/testing/performance.rb
-@@ -1,9 +1,6 @@
--require 'rubygems'
--gem 'ruby-prof', '>= 0.6.1'
- require 'ruby-prof'
- require 'fileutils'
--require 'rails/version'
- module ActiveSupport
-   module Testing
-@@ -124,6 +121,7 @@ module ActiveSupport
-         def environment
-           unless defined? @env
-+            require 'rails/version'
-             app = "#{$1}.#{$2}" if File.directory?('.git') && `git branch -v` =~ /^\* (\S+)\s+(\S+)/
-             rails = Rails::VERSION::STRING
diff --git a/ruby-activesupport-thread.patch b/ruby-activesupport-thread.patch
deleted file mode 100644 (file)
index 7a799e9..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -ur ruby-activesupport-2.3.5-o//lib/active_support/dependencies.rb ruby-activesupport-2.3.5/lib/active_support/dependencies.rb
---- ruby-activesupport-2.3.5-o//lib/active_support/dependencies.rb     2010-03-19 09:04:11.000000000 +0100
-+++ ruby-activesupport-2.3.5/lib/active_support/dependencies.rb        2010-11-23 18:01:20.000000000 +0100
-@@ -1,3 +1,4 @@
-+require 'thread'
- module ActiveSupport #:nodoc:
-   module Dependencies #:nodoc:
-     extend self
-Only in ruby-activesupport-2.3.5/lib/active_support: dependencies.rb~
index fa21aa046f0883674a9b07f7432985d1f109c16d..92ded5fd963cb0917cb12af43cdb6e4049f5a297 100644 (file)
@@ -1,14 +1,12 @@
 %define pkgname activesupport
 Summary:       Utility libraries for Ruby on Rails
 Name:          ruby-%{pkgname}
-Version:       2.3.5
+Version:       3.0.3
 Release:       1
 License:       Ruby-alike
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{pkgname}-%{version}.gem
-# Source0-md5: c4cbb7dd1ea612fd1c6b181a211cd468
-Patch0:                %{name}-nogems.patch
-Patch1:                %{name}-thread.patch
+# Source0-md5: 474ab3e5963afdad6a9c6c66ff08b16d
 URL:           http://rubyforge.org/projects/activesupport/
 BuildRequires: rpmbuild(macros) >= 1.277
 BuildRequires: ruby >= 1:1.8.6
@@ -62,11 +60,6 @@ Dokumentacji w formacie ri dla %{pkgname}.
 %prep
 %setup -q -c
 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
-find -newer README  -o -print | xargs touch --reference %{SOURCE0}
-%patch0 -p1
-%patch1 -p1
-
-%{__rm} -r lib/active_support/vendor*
 
 # JRuby crap
 rm lib/active_support/xml_mini/jdom.rb
@@ -76,10 +69,10 @@ rdoc --ri --op ri lib
 rdoc --op rdoc lib
 rm ri/created.rid
 rm -r ri/{CGI,Class,ClassInheritableAttributes,Date,DateTime} \
-       ri/{Enumerable,Exception,FalseClass,File,Float,Hash} \
-       ri/{HashWithIndifferentAccess,Integer,Kernel,Logger} \
-       ri/{LibXML,MissingSourceFile,Module,NameError,NilClass,Numeric} \
-       ri/{Object,Pathname,Proc,Range,Regexp,REXML,String} \
+       ri/{Enumerable,FalseClass,File,Float,Hash} \
+       ri/{Integer,Kernel,Logger} \
+       ri/{LibXML,Module,NameError,NilClass,Numeric} \
+       ri/{Object,Proc,Range,Regexp,REXML,String} \
        ri/{Symbol,Test,Time,TrueClass,Process,Array,BigDecimal}
 
 %install
@@ -98,7 +91,6 @@ rm -rf $RPM_BUILD_ROOT
 %doc CHANGELOG
 %{ruby_rubylibdir}/active_support
 %{ruby_rubylibdir}/active_support.rb
-%{ruby_rubylibdir}/activesupport.rb
 
 %files rdoc
 %defattr(644,root,root,755)
This page took 0.041247 seconds and 4 git commands to generate.