]> git.pld-linux.org Git - packages/ruby-activesupport.git/commitdiff
- Patch dependencies.rb to require thread properly
authoraredridel <aredridel@pld-linux.org>
Tue, 23 Nov 2010 17:06:14 +0000 (17:06 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ruby-activesupport-thread.patch -> 1.1
    ruby-activesupport.spec -> 1.30

ruby-activesupport-thread.patch [new file with mode: 0644]
ruby-activesupport.spec

diff --git a/ruby-activesupport-thread.patch b/ruby-activesupport-thread.patch
new file mode 100644 (file)
index 0000000..7a799e9
--- /dev/null
@@ -0,0 +1,9 @@
+diff -ur ruby-activesupport-2.3.5-o//lib/active_support/dependencies.rb ruby-activesupport-2.3.5/lib/active_support/dependencies.rb
+--- ruby-activesupport-2.3.5-o//lib/active_support/dependencies.rb     2010-03-19 09:04:11.000000000 +0100
++++ ruby-activesupport-2.3.5/lib/active_support/dependencies.rb        2010-11-23 18:01:20.000000000 +0100
+@@ -1,3 +1,4 @@
++require 'thread'
+ module ActiveSupport #:nodoc:
+   module Dependencies #:nodoc:
+     extend self
+Only in ruby-activesupport-2.3.5/lib/active_support: dependencies.rb~
index d5ff08c6a377e37d8a4590e253ff639af48c0c08..fa21aa046f0883674a9b07f7432985d1f109c16d 100644 (file)
@@ -8,6 +8,7 @@ Group:          Development/Languages
 Source0:       http://rubygems.org/downloads/%{pkgname}-%{version}.gem
 # Source0-md5: c4cbb7dd1ea612fd1c6b181a211cd468
 Patch0:                %{name}-nogems.patch
+Patch1:                %{name}-thread.patch
 URL:           http://rubyforge.org/projects/activesupport/
 BuildRequires: rpmbuild(macros) >= 1.277
 BuildRequires: ruby >= 1:1.8.6
@@ -63,6 +64,7 @@ Dokumentacji w formacie ri dla %{pkgname}.
 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
 find -newer README  -o -print | xargs touch --reference %{SOURCE0}
 %patch0 -p1
+%patch1 -p1
 
 %{__rm} -r lib/active_support/vendor*
 
This page took 0.083004 seconds and 4 git commands to generate.