]> git.pld-linux.org Git - packages/qt-creator.git/blob - qt-creator.spec
Update to 2.6.1
[packages/qt-creator.git] / qt-creator.spec
1 Summary:        An IDE tailored to the needs of Qt developers
2 Summary(pl.UTF-8):      IDE dostosowane do potrzeb developerow Qt
3 Name:           qt-creator
4 Version:        2.6.1
5 Release:        1
6 Epoch:          1
7 License:        LGPL v2.1
8 Group:          X11/Development/Tools
9 Source0:        http://releases.qt-project.org/qtcreator/2.6.1/%{name}-%{version}-src.tar.gz
10 # Source0-md5:  e4d6373335a80ddf7ffcacf92442e43c
11 Source1:        %{name}.desktop
12 Patch0:         %{name}-pluginpath64.patch
13 URL:            http://qt.digia.com/Product/Developer-Tools
14 BuildRequires:  QtDBus-devel
15 BuildRequires:  QtDeclarative-devel
16 BuildRequires:  QtDesigner-devel
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtHelp-devel
19 BuildRequires:  QtNetwork-devel
20 BuildRequires:  QtScript-devel
21 BuildRequires:  QtSql-sqlite3
22 BuildRequires:  QtSvg-devel
23 BuildRequires:  QtWebKit-devel
24 BuildRequires:  QtXml-devel
25 BuildRequires:  qt4-build >= 4.8.0
26 BuildRequires:  qt4-linguist
27 BuildRequires:  qt4-qmake >= 4.8.0
28 BuildRequires:  rpmbuild(macros) >= 1.602
29 Requires(post,postun):  desktop-file-utils
30 %requires_eq    QtCore
31 Requires:       QtSql-sqlite3
32 Requires:       hicolor-icon-theme
33 # for xdg-open
34 Suggests:       xdg-utils
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Qt Creator is a cross-platform integrated development environment (IDE)
39 tailored to the needs of Qt developers.
40
41 %description -l pl.UTF-8
42 Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
43
44 %prep
45 %setup -q -n %{name}-%{version}-src
46
47 %if "%{_lib}" == "lib64"
48 %patch0 -p1
49 %endif
50
51 # fix unresolved symbols in libQtcSsh
52 echo "LIBS += -ldl" > src/libs/ssh/ssh_dependencies.pri
53
54 %build
55 export QTDIR=%{_libdir}/qt4
56 # the qmakespec in qt4 is somewhat broken, need to look at this
57 #export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
58
59 qmake-qt4 qtcreator.pro \
60         QMAKE_CXX="%{__cxx}" \
61         QMAKE_LINK="%{__cxx}" \
62         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
63         QMAKE_RPATH=
64
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT%{_desktopdir}
70
71 export QTDIR=%{_libdir}/qt4
72 %{__make} install \
73         INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
74
75 %if "%{_lib}" == "lib64"
76 mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
77 %endif
78
79 install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
80 echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
81
82 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
83
84 # not supported by hicolor-icon-theme
85 rm -rf $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post
91 /sbin/ldconfig
92 %update_desktop_database
93 %update_icon_cache hicolor
94
95 %postun
96 /sbin/ldconfig
97 %update_desktop_database_postun
98 %update_icon_cache hicolor
99
100 %files
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_bindir}/qtcreator
103 %attr(755,root,root) %{_bindir}/qtcreator_process_stub
104 %attr(755,root,root) %{_bindir}/qtpromaker
105 %attr(755,root,root) %{_bindir}/sdktool
106 %{_sysconfdir}/ld.so.conf.d/qtcreator.conf
107 %dir %{_libdir}/qtcreator
108 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
109 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
110 %attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
111 %dir %{_libdir}/qtcreator/plugins
112 %dir %{_libdir}/qtcreator/plugins/QtProject
113 %dir %{_libdir}/qtcreator/plugins/RIM
114 %{_libdir}/qtcreator/plugins/QtProject/*.pluginspec
115 %{_libdir}/qtcreator/plugins/RIM/*.pluginspec
116 %attr(755,root,root) %{_libdir}/qtcreator/plugins/QtProject/*.so
117 %attr(755,root,root) %{_libdir}/qtcreator/plugins/RIM/*.so
118 %{_libdir}/qtcreator/qtcomponents
119 %{_datadir}/qtcreator
120 %{_desktopdir}/qt-creator.desktop
121 %{_iconsdir}/hicolor/*/*/*.png
This page took 0.060175 seconds and 4 git commands to generate.