]> git.pld-linux.org Git - packages/qt-creator.git/blob - qt-creator.spec
- up to 1.2.0
[packages/qt-creator.git] / qt-creator.spec
1 #
2
3 Summary:        An IDE tailored to the needs of Qt developers
4 Summary(pl.UTF-8):      IDE dostosowane do potrzeb developerow Qt
5 Name:           qt-creator
6 Version:        1.2.0
7 Release:        1
8 Epoch:          1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
12 # Source0-md5:  87315f83e37dc92dfb5730282d5ecb56
13 Patch0:         %{name}-pluginpath64.patch
14 URL:            http://www.qtsoftware.com/developer/qt-creator
15 BuildRequires:  QtDBus-devel
16 BuildRequires:  QtDesigner-devel
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtHelp-devel
19 BuildRequires:  QtNetwork-devel
20 BuildRequires:  QtScript-devel
21 BuildRequires:  QtSql-sqlite3
22 BuildRequires:  QtSvg-devel
23 BuildRequires:  QtWebKit-devel
24 BuildRequires:  QtXml-devel
25 BuildRequires:  qt4-build >= 4.5.0-3
26 BuildRequires:  qt4-qmake >= 4.5.0-3
27 BuildRequires:  unzip
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Qt Creator is a cross-platform integrated development environment (IDE) 
32 tailored to the needs of Qt developers.
33
34 %description -l pl.UTF-8
35 Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
36
37 %prep
38 %setup -q -n %{name}-%{version}-src
39
40 %if "%{_lib}" == "lib64"
41 %patch0 -p1
42 %endif
43
44 %build
45 export QTDIR=%{_libdir}/qt4
46 # the qmakespec in qt4 is somewhat broken, need to look at this
47 #export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
48
49 qmake-qt4 qtcreator.pro \
50         QMAKE_CXX="%{__cxx}" \
51         QMAKE_LINK="%{__cxx}" \
52         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
53         QMAKE_RPATH=    
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 export QTDIR=%{_libdir}/qt4
61 %{__make} install \
62         INSTALL_ROOT=$RPM_BUILD_ROOT/%{_prefix}
63
64 %if "%{_lib}" == "lib64"
65 mv -f $RPM_BUILD_ROOT/{%{_prefix}/lib,%{_libdir}}
66 %endif
67
68 install -d $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d
69 echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_bindir}/*
77 %{_sysconfdir}/ld.so.conf.d/qtcreator.conf
78 %dir %{_libdir}/qtcreator
79 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
80 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
81 %attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
82 %dir %{_libdir}/qtcreator/plugins
83 %dir %{_libdir}/qtcreator/plugins/Nokia
84 %{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
85 %attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
86 %{_datadir}/qtcreator
87 %{_defaultdocdir}/qtcreator
88 %{_pixmapsdir}/qtcreator_logo*.png
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
This page took 0.120914 seconds and 4 git commands to generate.