]> git.pld-linux.org Git - packages/qt-creator.git/blob - qt-creator.spec
- release 3
[packages/qt-creator.git] / qt-creator.spec
1 Summary:        An IDE tailored to the needs of Qt developers
2 Summary(pl.UTF-8):      IDE dostosowane do potrzeb developerow Qt
3 Name:           qt-creator
4 Version:        1.3.1
5 Release:        3
6 Epoch:          1
7 License:        LGPL v2.1
8 Group:          X11/Development/Tools
9 Source0:        http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
10 # Source0-md5:  b4c66810c591f62aa26739f997ffe88b
11 Source1:        %{name}.desktop
12 Patch0:         %{name}-pluginpath64.patch
13 URL:            http://www.qtsoftware.com/developer/qt-creator
14 BuildRequires:  QtDBus-devel
15 BuildRequires:  QtDesigner-devel
16 BuildRequires:  QtGui-devel
17 BuildRequires:  QtHelp-devel
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtScript-devel
20 BuildRequires:  QtSql-sqlite3
21 BuildRequires:  QtSvg-devel
22 BuildRequires:  QtWebKit-devel
23 BuildRequires:  QtXml-devel
24 BuildRequires:  qt4-build >= 4.6.0
25 BuildRequires:  qt4-linguist
26 BuildRequires:  qt4-qmake >= 4.6.0
27 BuildRequires:  unzip
28 Requires(post,postun):  desktop-file-utils
29 %requires_eq    QtCore
30 Requires:       QtSql-sqlite3
31 # for xdg-open
32 Suggests:       xdg-utils
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Qt Creator is a cross-platform integrated development environment (IDE) 
37 tailored to the needs of Qt developers.
38
39 %description -l pl.UTF-8
40 Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
41
42 %prep
43 %setup -q -n %{name}-%{version}-src
44
45 %if "%{_lib}" == "lib64"
46 %patch0 -p1
47 %endif
48
49 %build
50 export QTDIR=%{_libdir}/qt4
51 # the qmakespec in qt4 is somewhat broken, need to look at this
52 #export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
53
54 qmake-qt4 qtcreator.pro \
55         QMAKE_CXX="%{__cxx}" \
56         QMAKE_LINK="%{__cxx}" \
57         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
58         QMAKE_RPATH=    
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT%{_desktopdir}
65
66 export QTDIR=%{_libdir}/qt4
67 %{__make} install \
68         INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
69
70 %if "%{_lib}" == "lib64"
71 mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
72 %endif
73
74 mv -f $RPM_BUILD_ROOT%{_bindir}/{qtcreator.bin,qtcreator}
75
76 install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
77 echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
78
79 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 /sbin/ldconfig
86 %update_desktop_database
87
88 %postun
89 /sbin/ldconfig
90 %update_desktop_database_postun
91
92 %files
93 %defattr(644,root,root,755)
94 %attr(755,root,root) %{_bindir}/qtcreator
95 %attr(755,root,root) %{_bindir}/qtcreator_process_stub
96 %{_sysconfdir}/ld.so.conf.d/qtcreator.conf
97 %dir %{_libdir}/qtcreator
98 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
99 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
100 %attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
101 %dir %{_libdir}/qtcreator/plugins
102 %dir %{_libdir}/qtcreator/plugins/Nokia
103 %{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
104 %attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
105 %{_datadir}/qtcreator
106 %{_defaultdocdir}/qtcreator
107 %{_desktopdir}/qt-creator.desktop
108 %{_pixmapsdir}/qtcreator_logo*.png
This page took 0.042939 seconds and 4 git commands to generate.