]> git.pld-linux.org Git - packages/qt-creator.git/blob - qt-creator.spec
- more BRs
[packages/qt-creator.git] / qt-creator.spec
1 #
2
3 Summary:        An IDE tailored to the needs of Qt developers
4 Summary(pl.UTF-8):      IDE dostosowane do potrzeb developerow Qt
5 Name:           qt-creator
6 Version:        1.0.0
7 Release:        2
8 Epoch:          1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
12 # Source0-md5:  5478124035d80a90e66a3db67ab4477a
13 Patch0:         %{name}-pluginpath64.patch
14 URL:            http://www.qtsoftware.com/developer/qt-creator
15 BuildRequires:  QtDBus-devel
16 BuildRequires:  QtGui-devel
17 BuildRequires:  QtHelp-devel
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtScript-devel
20 BuildRequires:  QtSql-sqlite
21 BuildRequires:  QtSvg-devel
22 BuildRequires:  QtWebKit-devel
23 BuildRequires:  QtXml-devel
24 BuildRequires:  qt4-build >= 4.5.0-3
25 BuildRequires:  qt4-qmake >= 4.5.0-3
26 BuildRequires:  unzip
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Qt Creator is a cross-platform integrated development environment (IDE) 
31 tailored to the needs of Qt developers.
32
33 %description -l pl.UTF-8
34 Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
35
36 %prep
37 %setup -q -n %{name}-%{version}-src
38
39 %if "%{_lib}" == "lib64"
40 %patch0 -p1
41 %endif
42
43 %build
44 export QTDIR=%{_libdir}/qt4
45 # the qmakespec in qt4 is somewhat broken, need to look at this
46 #export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
47
48 qmake-qt4 qtcreator.pro \
49         QMAKE_CXX="%{__cxx}" \
50         QMAKE_LINK="%{__cxx}" \
51         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
52         QMAKE_RPATH=    
53
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 export QTDIR=%{_libdir}/qt4
60 #export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
61 %{__make} install \
62         INSTALL_ROOT=$RPM_BUILD_ROOT/%{_prefix}
63
64 mv -f $RPM_BUILD_ROOT/{%{_prefix}/lib,%{_libdir}}
65
66 install -d $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d
67 echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %attr(755,root,root) %{_bindir}/*
75 %{_sysconfdir}/ld.so.conf.d/qtcreator.conf
76 %dir %{_libdir}/qtcreator
77 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
78 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
79 %dir %{_libdir}/qtcreator/plugins
80 %dir %{_libdir}/qtcreator/plugins/Nokia
81 %{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
82 %attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
83 %{_datadir}/qtcreator
84 %{_defaultdocdir}/qtcreator
85 %{_pixmapsdir}/qtcreator_logo*.png
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
This page took 0.059924 seconds and 4 git commands to generate.