]> git.pld-linux.org Git - packages/qt-creator.git/blob - qt-creator.spec
- up to 1.2.1
[packages/qt-creator.git] / qt-creator.spec
1 #
2
3 Summary:        An IDE tailored to the needs of Qt developers
4 Summary(pl.UTF-8):      IDE dostosowane do potrzeb developerow Qt
5 Name:           qt-creator
6 Version:        1.2.1
7 Release:        1
8 Epoch:          1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
12 # Source0-md5:  41f044cf567db09153161403fbab4076
13 Patch0:         %{name}-pluginpath64.patch
14 URL:            http://www.qtsoftware.com/developer/qt-creator
15 BuildRequires:  QtDBus-devel
16 BuildRequires:  QtDesigner-devel
17 BuildRequires:  QtGui-devel
18 BuildRequires:  QtHelp-devel
19 BuildRequires:  QtNetwork-devel
20 BuildRequires:  QtScript-devel
21 BuildRequires:  QtSql-sqlite3
22 BuildRequires:  QtSvg-devel
23 BuildRequires:  QtWebKit-devel
24 BuildRequires:  QtXml-devel
25 BuildRequires:  qt4-build >= 4.5.0-3
26 BuildRequires:  qt4-linguist
27 BuildRequires:  qt4-qmake >= 4.5.0-3
28 BuildRequires:  unzip
29 %requires_eq    QtCore
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Qt Creator is a cross-platform integrated development environment (IDE) 
34 tailored to the needs of Qt developers.
35
36 %description -l pl.UTF-8
37 Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
38
39 %prep
40 %setup -q -n %{name}-%{version}-src
41
42 %if "%{_lib}" == "lib64"
43 %patch0 -p1
44 %endif
45
46 %build
47 export QTDIR=%{_libdir}/qt4
48 # the qmakespec in qt4 is somewhat broken, need to look at this
49 #export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
50
51 qmake-qt4 qtcreator.pro \
52         QMAKE_CXX="%{__cxx}" \
53         QMAKE_LINK="%{__cxx}" \
54         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
55         QMAKE_RPATH=    
56
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 export QTDIR=%{_libdir}/qt4
63 %{__make} install \
64         INSTALL_ROOT=$RPM_BUILD_ROOT/%{_prefix}
65
66 %if "%{_lib}" == "lib64"
67 mv -f $RPM_BUILD_ROOT/{%{_prefix}/lib,%{_libdir}}
68 %endif
69
70 mv -f $RPM_BUILD_ROOT/%{_bindir}/{qtcreator.bin,qtcreator}
71
72 install -d $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d
73 echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_bindir}/qtcreator
81 %attr(755,root,root) %{_bindir}/qtcreator_process_stub
82 %{_sysconfdir}/ld.so.conf.d/qtcreator.conf
83 %dir %{_libdir}/qtcreator
84 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
85 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
86 %attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
87 %dir %{_libdir}/qtcreator/plugins
88 %dir %{_libdir}/qtcreator/plugins/Nokia
89 %{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
90 %attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
91 %{_datadir}/qtcreator
92 %{_defaultdocdir}/qtcreator
93 %{_pixmapsdir}/qtcreator_logo*.png
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
This page took 0.046084 seconds and 4 git commands to generate.