]> git.pld-linux.org Git - packages/qt-creator.git/blob - qt-creator.spec
- added desktop file
[packages/qt-creator.git] / qt-creator.spec
1 Summary:        An IDE tailored to the needs of Qt developers
2 Summary(pl.UTF-8):      IDE dostosowane do potrzeb developerow Qt
3 Name:           qt-creator
4 Version:        1.3.0
5 Release:        1
6 Epoch:          1
7 License:        LGPL v2.1
8 Group:          X11/Development/Tools
9 Source0:        http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
10 # Source0-md5:  c4c0450099a76099917687f3f05604d9
11 Source1:        %{name}.desktop
12 Patch0:         %{name}-pluginpath64.patch
13 URL:            http://www.qtsoftware.com/developer/qt-creator
14 BuildRequires:  QtDBus-devel
15 BuildRequires:  QtDesigner-devel
16 BuildRequires:  QtGui-devel
17 BuildRequires:  QtHelp-devel
18 BuildRequires:  QtNetwork-devel
19 BuildRequires:  QtScript-devel
20 BuildRequires:  QtSql-sqlite3
21 BuildRequires:  QtSvg-devel
22 BuildRequires:  QtWebKit-devel
23 BuildRequires:  QtXml-devel
24 BuildRequires:  qt4-build >= 4.6.0
25 BuildRequires:  qt4-linguist
26 BuildRequires:  qt4-qmake >= 4.6.0
27 BuildRequires:  unzip
28 Requires(post,postun):  desktop-file-utils
29 %requires_eq    QtCore
30 # for xdg-open
31 Suggests:       xdg-utils
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Qt Creator is a cross-platform integrated development environment (IDE) 
36 tailored to the needs of Qt developers.
37
38 %description -l pl.UTF-8
39 Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
40
41 %prep
42 %setup -q
43
44 %if "%{_lib}" == "lib64"
45 %patch0 -p1
46 %endif
47
48 %build
49 export QTDIR=%{_libdir}/qt4
50 # the qmakespec in qt4 is somewhat broken, need to look at this
51 #export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
52
53 qmake-qt4 qtcreator.pro \
54         QMAKE_CXX="%{__cxx}" \
55         QMAKE_LINK="%{__cxx}" \
56         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
57         QMAKE_RPATH=    
58
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_desktopdir}
64
65 export QTDIR=%{_libdir}/qt4
66 %{__make} install \
67         INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
68
69 %if "%{_lib}" == "lib64"
70 mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
71 %endif
72
73 mv -f $RPM_BUILD_ROOT%{_bindir}/{qtcreator.bin,qtcreator}
74
75 install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
76 echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
77
78 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post
84 /sbin/ldconfig
85 %update_desktop_database
86
87 %postun
88 /sbin/ldconfig
89 %update_desktop_database_postun
90
91 %files
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/qtcreator
94 %attr(755,root,root) %{_bindir}/qtcreator_process_stub
95 %{_sysconfdir}/ld.so.conf.d/qtcreator.conf
96 %dir %{_libdir}/qtcreator
97 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
98 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
99 %attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
100 %dir %{_libdir}/qtcreator/plugins
101 %dir %{_libdir}/qtcreator/plugins/Nokia
102 %{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
103 %attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
104 %{_datadir}/qtcreator
105 %{_defaultdocdir}/qtcreator
106 %{_desktopdir}/qt-creator.desktop
107 %{_pixmapsdir}/qtcreator_logo*.png
This page took 0.076207 seconds and 4 git commands to generate.