]> git.pld-linux.org Git - packages/qt-creator.git/blame - qt-creator.spec
- updated to 2.2.1
[packages/qt-creator.git] / qt-creator.spec
CommitLineData
2aefa737 1Summary: An IDE tailored to the needs of Qt developers
2Summary(pl.UTF-8): IDE dostosowane do potrzeb developerow Qt
3Name: qt-creator
9ddce925 4Version: 2.2.1
d715c69d 5Release: 1
2aefa737 6Epoch: 1
7License: LGPL v2.1
0bdd3f4c 8Group: X11/Development/Tools
913e68eb 9Source0: http://get.qt.nokia.com/qtcreator/%{name}-%{version}-src.zip
9ddce925 10# Source0-md5: 8a3165f7f68d4932c9a902452993099d
0bdd3f4c 11Source1: %{name}.desktop
2b26ffea 12Patch0: %{name}-pluginpath64.patch
0bf5b59e 13URL: http://qt.nokia.com/products/developer-tools
a2bb26e4 14BuildRequires: QtDBus-devel
913e68eb 15BuildRequires: QtDeclarative-devel
99bec638 16BuildRequires: QtDesigner-devel
2aefa737 17BuildRequires: QtGui-devel
a2bb26e4
KK
18BuildRequires: QtHelp-devel
19BuildRequires: QtNetwork-devel
20BuildRequires: QtScript-devel
5eafeef8 21BuildRequires: QtSql-sqlite3
a2bb26e4
KK
22BuildRequires: QtSvg-devel
23BuildRequires: QtWebKit-devel
24BuildRequires: QtXml-devel
913e68eb 25BuildRequires: qt4-build >= 4.7.0
4208b10d 26BuildRequires: qt4-linguist
913e68eb 27BuildRequires: qt4-qmake >= 4.7.0
333344fa 28BuildRequires: rpmbuild(macros) >= 1.602
a2bb26e4 29BuildRequires: unzip
0bdd3f4c 30Requires(post,postun): desktop-file-utils
4208b10d 31%requires_eq QtCore
1f8887fa 32Requires: QtSql-sqlite3
333344fa 33Requires: hicolor-icon-theme
0bdd3f4c
MB
34# for xdg-open
35Suggests: xdg-utils
2aefa737 36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
913e68eb 39Qt Creator is a cross-platform integrated development environment (IDE)
2aefa737 40tailored to the needs of Qt developers.
41
42%description -l pl.UTF-8
43Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
44
45%prep
8fd6a200 46%setup -q -n %{name}-%{version}-src
2aefa737 47
2b26ffea 48%if "%{_lib}" == "lib64"
49%patch0 -p1
50%endif
51
2aefa737 52%build
53export QTDIR=%{_libdir}/qt4
54# the qmakespec in qt4 is somewhat broken, need to look at this
55#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
56
57qmake-qt4 qtcreator.pro \
58 QMAKE_CXX="%{__cxx}" \
59 QMAKE_LINK="%{__cxx}" \
60 QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
913e68eb 61 QMAKE_RPATH=
2aefa737 62
63%{__make}
64
65%install
66rm -rf $RPM_BUILD_ROOT
0bdd3f4c 67install -d $RPM_BUILD_ROOT%{_desktopdir}
2aefa737 68
69export QTDIR=%{_libdir}/qt4
2aefa737 70%{__make} install \
08788771 71 INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
2aefa737 72
5eafeef8 73%if "%{_lib}" == "lib64"
08788771 74mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
5eafeef8 75%endif
2aefa737 76
08788771
KK
77install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
78echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2b26ffea 79
0bdd3f4c
MB
80install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
81
333344fa
MB
82for i in 16 24 32 48 64 128 256
83do
84 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
85 ln -s ../../../../pixmaps/qtcreator_logo_${i}.png \
86 $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/qtcreator.png
87done
88
2aefa737 89%clean
90rm -rf $RPM_BUILD_ROOT
91
0bdd3f4c
MB
92%post
93/sbin/ldconfig
94%update_desktop_database
333344fa 95%update_icon_cache hicolor
0bdd3f4c
MB
96
97%postun
98/sbin/ldconfig
99%update_desktop_database_postun
333344fa 100%update_icon_cache hicolor
0bdd3f4c 101
2aefa737 102%files
103%defattr(644,root,root,755)
4208b10d
KK
104%attr(755,root,root) %{_bindir}/qtcreator
105%attr(755,root,root) %{_bindir}/qtcreator_process_stub
d715c69d 106%attr(755,root,root) %{_bindir}/qtpromaker
2b26ffea 107%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2aefa737 108%dir %{_libdir}/qtcreator
2b26ffea 109%attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
110%attr(755,root,root) %{_libdir}/qtcreator/lib*.so
5eafeef8 111%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
2aefa737 112%dir %{_libdir}/qtcreator/plugins
113%dir %{_libdir}/qtcreator/plugins/Nokia
a2bb26e4 114%{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
2aefa737 115%attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
116%{_datadir}/qtcreator
2b26ffea 117%{_defaultdocdir}/qtcreator
0bdd3f4c 118%{_desktopdir}/qt-creator.desktop
2aefa737 119%{_pixmapsdir}/qtcreator_logo*.png
333344fa 120%{_iconsdir}/hicolor/*/*/*.png
This page took 0.086386 seconds and 4 git commands to generate.