]> git.pld-linux.org Git - packages/qt-creator.git/blame - qt-creator.spec
- fix search path for 64bit systems
[packages/qt-creator.git] / qt-creator.spec
CommitLineData
2aefa737 1#
2
3Summary: An IDE tailored to the needs of Qt developers
4Summary(pl.UTF-8): IDE dostosowane do potrzeb developerow Qt
5Name: qt-creator
6Version: 1.0.0
7Release: 1
8Epoch: 1
9License: LGPL v2.1
10Group: Libraries
11Source0: http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
12# Source0-md5: 5478124035d80a90e66a3db67ab4477a
13URL: http://www.qtsoftware.com/developer/qt-creator
14BuildRequires: libstdc++-devel
15BuildRequires: qt4-qmake >= 4.5.0-3
16BuildRequires: QtSql-sqlite
17BuildRequires: QtGui-devel
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Qt Creator is a cross-platform integrated development environment (IDE)
22tailored to the needs of Qt developers.
23
24%description -l pl.UTF-8
25Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
26
27%prep
28%setup -q -n %{name}-%{version}-src
29
30%build
31export QTDIR=%{_libdir}/qt4
32# the qmakespec in qt4 is somewhat broken, need to look at this
33#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
34
35qmake-qt4 qtcreator.pro \
36 QMAKE_CXX="%{__cxx}" \
37 QMAKE_LINK="%{__cxx}" \
38 QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
39 QMAKE_RPATH=
40
41%{__make}
42
43%install
44rm -rf $RPM_BUILD_ROOT
45
46export QTDIR=%{_libdir}/qt4
47#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
48%{__make} install \
49 INSTALL_ROOT=$RPM_BUILD_ROOT/%{_prefix}
50
51mv -f $RPM_BUILD_ROOT/{%{_prefix}/lib,%{_libdir}}
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%attr(755,root,root) %{_bindir}/*
59%dir %{_libdir}/qtcreator
60%attr(755,root,root) %{_libdir}/qtcreator/lib*.so*
61%dir %{_libdir}/qtcreator/plugins
62%dir %{_libdir}/qtcreator/plugins/Nokia
63%{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
64%attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
65%{_datadir}/qtcreator
66%{_pixmapsdir}/qtcreator_logo*.png
This page took 0.044902 seconds and 4 git commands to generate.