]> git.pld-linux.org Git - packages/php.git/commitdiff
Rel 38. Add workaround for https://bugs.php.net/bug.php?id=79589 auto/th/php52-5.2.17-20130717.38
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 29 Mar 2022 14:47:25 +0000 (16:47 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 29 Mar 2022 14:47:25 +0000 (16:47 +0200)
openssl.patch
php.spec

index 9cbb65063ff324339ab1a195d1debf5ecd488b89..f203bd6dda0c4e59c13ac831ee2270c9a12bed61 100644 (file)
@@ -440,3 +440,18 @@ diff -ur php-5.2.17/ext/openssl.org/xp_ssl.c php-5.2.17/ext/openssl/xp_ssl.c
        REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
        REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
  
+--- php-5.2.17/ext/openssl/xp_ssl.c~   2022-03-29 16:34:52.000000000 +0200
++++ php-5.2.17/ext/openssl/xp_ssl.c    2022-03-29 16:36:05.936548953 +0200
+@@ -391,7 +391,11 @@ static inline int php_openssl_setup_cryp
+               return -1;
+       }
+-      SSL_CTX_set_options(sslsock->ctx, SSL_OP_ALL);
++      SSL_CTX_set_options(sslsock->ctx, SSL_OP_ALL
++#ifdef SSL_OP_IGNORE_UNEXPECTED_EOF
++              | SSL_OP_IGNORE_UNEXPECTED_EOF
++#endif
++      );
+       sslsock->ssl_handle = php_SSL_new_from_context(sslsock->ctx, stream TSRMLS_CC);
+       if (sslsock->ssl_handle == NULL) {
index c79453678a68334f67d7dd46ad32925953520c93..0cd2983fecdf10557b24c05f973eeb4d2daee365 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel     37
+%define                rel     38
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
This page took 1.239176 seconds and 4 git commands to generate.