]> git.pld-linux.org Git - packages/php.git/commitdiff
Rel 37; fix openssl 3 build auto/th/php52-5.2.17-20130717.37
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 31 Oct 2021 18:13:12 +0000 (19:13 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 31 Oct 2021 18:13:12 +0000 (19:13 +0100)
openssl.patch
php.spec

index 4030bc5a203c981cc5bfe6408a367438faf64006..9cbb65063ff324339ab1a195d1debf5ecd488b89 100644 (file)
@@ -428,3 +428,15 @@ diff -ur php-5.2.17/ext/openssl.org/xp_ssl.c php-5.2.17/ext/openssl/xp_ssl.c
        PHP_EVAL_INCLINE($OPENSSL_INCS)
      fi
    fi
+--- php-5.3.29/ext/openssl/openssl.c~  2021-10-23 19:18:21.000000000 +0200
++++ php-5.3.29/ext/openssl/openssl.c   2021-10-23 19:19:01.483125024 +0200
+@@ -1044,7 +1044,9 @@ PHP_MINIT_FUNCTION(openssl)
+       REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+       REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+       REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
index ac3dc505f5509178d157960c790c04f37de151af..c79453678a68334f67d7dd46ad32925953520c93 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel     36
+%define                rel     37
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
This page took 1.798826 seconds and 4 git commands to generate.