]> git.pld-linux.org Git - packages/php-xcache.git/blob - php-xcache.spec
- converted to UTF-8
[packages/php-xcache.git] / php-xcache.spec
1 %define         _modname        xcache
2 Summary:        %{_modname} - PHP opcode cacher
3 Summary(pl.UTF-8):   %{_modname} - buforowanie opcodów PHP
4 Name:           php-%{_modname}
5 Version:        1.2.0
6 Release:        0.1
7 License:        BSD
8 Group:          Development/Languages/PHP
9 URL:            http://trac.lighttpd.net/xcache/
10 Source0:        http://210.51.190.228/pub/XCache/rc/1.2.0-rc1/xcache-%{version}-rc1.tar.bz2
11 # Source0-md5:  a518400a879d8904771867b9f50a650d
12 BuildRequires:  php-devel >= 3:5.0
13 BuildRequires:  rpmbuild(macros) >= 1.344
14 BuildRequires:  sed >= 4.0
15 %{?requires_zend_extension}
16 Requires:       php-common >= 4:5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 XCache is a fast, stable PHP opcode cacher that has been tested and is
21 now running on production servers under high load.
22
23 %description -l pl.UTF-8
24 XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
25 działające na produkcyjnych serwerach o dużym obciążeniu.
26
27 %prep
28 %setup -q -n xcache
29
30 %build
31 phpize
32 %configure
33 %{__make}
34 %{__sed} -i -e '
35         s,zend_extension =.*,zend_extension = %{php_extensiondir}/xcache.so,
36         s,zend_extension_ts = .*,zend_extension_ts = %{php_extensiondir}/xcache.so,
37 ' xcache.ini
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
42
43 %{__make} install \
44         INSTALL_ROOT=$RPM_BUILD_ROOT
45
46 install xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %php_webserver_restart
53
54 %postun
55 if [ "$1" = 0 ]; then
56         %php_webserver_restart
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc AUTHORS README THANKS
62 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
63 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.328287 seconds and 4 git commands to generate.