]> git.pld-linux.org Git - packages/php-xcache.git/blob - php-xcache.spec
- release 3
[packages/php-xcache.git] / php-xcache.spec
1 %define         modname xcache
2 Summary:        %{modname} - PHP opcode cacher
3 Summary(pl.UTF-8):      %{modname} - buforowanie opcodów PHP
4 Name:           php-%{modname}
5 Version:        1.3.0
6 Release:        3
7 License:        BSD
8 Group:          Development/Languages/PHP
9 URL:            http://xcache.lighttpd.net/
10 Source0:        http://xcache.lighttpd.net/pub/Releases/%{version}/xcache-%{version}.tar.bz2
11 # Source0-md5:  3aea4b1e3bd38b19cd9ae6a82db4cb8d
12 Source1:        %{modname}-apache.conf
13 Source2:        %{modname}-lighttpd.conf
14 BuildRequires:  php-devel >= 3:5.1
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 BuildRequires:  sed >= 4.0
17 %{?requires_zend_extension}
18 Requires:       php-common >= 4:5.0.4
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _webapps        /etc/webapps
22 %define         _webapp         %{modname}
23 %define         _sysconfdir     %{_webapps}/%{_webapp}
24 %define         _appdir         %{_datadir}/%{_webapp}
25
26 %description
27 XCache is a fast, stable PHP opcode cacher that has been tested and is
28 now running on production servers under high load.
29
30 %description -l pl.UTF-8
31 XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
32 działające na produkcyjnych serwerach o dużym obciążeniu.
33
34 %package web
35 Summary:        WEB interface for xCache
36 Group:          Libraries
37 Requires:       %{name} = %{epoch}:%{version}-%{release}
38 Requires:       webapps
39 Requires:       webserver(php) >= 5.0
40
41 %description web
42 Via this web interface script you can manage and view statistics of
43 xCache.
44
45 More information you can find at %{url}.
46
47 %prep
48 %setup -q -n %{modname}-%{version}
49 %{__sed} -i -e '
50         s,zend_extension =.*,zend_extension = %{php_extensiondir}/xcache.so,
51         s,zend_extension_ts = .*,zend_extension_ts = %{php_extensiondir}/xcache.so,
52 ' xcache.ini
53
54 %build
55 phpize
56 %configure \
57         --enable-xcache \
58         --enable-xcache-optimizer \
59         --enable-xcache-coverager
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{_sysconfdir}}
65
66 %{__make} install \
67         INSTALL_ROOT=$RPM_BUILD_ROOT
68
69 # The cache directory where pre-compiled files will reside
70 install -d $RPM_BUILD_ROOT/var/cache/php-%{modname}
71 install -d $RPM_BUILD_ROOT%{_appdir}
72
73 # Drop in the bit of configuration
74 cp -a xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
75 cp -a admin/* $RPM_BUILD_ROOT%{_appdir}
76
77 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
78 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
79 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 %php_webserver_restart
86
87 %postun
88 if [ "$1" = 0 ]; then
89         %php_webserver_restart
90 fi
91
92 %triggerin web -- apache1 < 1.3.37-3, apache1-base
93 %webapp_register apache %{_webapp}
94
95 %triggerun web -- apache1 < 1.3.37-3, apache1-base
96 %webapp_unregister apache %{_webapp}
97
98 %triggerin web -- apache < 2.2.0, apache-base
99 %webapp_register httpd %{_webapp}
100
101 %triggerun web -- apache < 2.2.0, apache-base
102 %webapp_unregister httpd %{_webapp}
103
104 %triggerin web -- lighttpd
105 %webapp_register lighttpd %{_webapp}
106
107 %triggerun web -- lighttpd
108 %webapp_unregister lighttpd %{_webapp}
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS README THANKS
113 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
114 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
115
116 # XXX: what for this dir is used?
117 %dir %attr(775,root,http) /var/cache/php-xcache
118
119 %files web
120 %defattr(644,root,root,755)
121 %dir %attr(750,root,http) %{_sysconfdir}
122 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
123 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
124 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
125 %{_appdir}
This page took 0.075993 seconds and 4 git commands to generate.