]> git.pld-linux.org Git - packages/php-xcache.git/blob - php-xcache.spec
Revert "- migrated to apache 2.4"
[packages/php-xcache.git] / php-xcache.spec
1 # TODO
2 # - verify %lang codes
3 %define         php_name        php%{?php_suffix}
4 %define         modname xcache
5 Summary:        %{modname} - PHP opcode cacher
6 Summary(pl.UTF-8):      %{modname} - buforowanie opcodów PHP
7 Name:           %{php_name}-%{modname}
8 Version:        3.0.1
9 Release:        1
10 License:        BSD
11 Group:          Development/Languages/PHP
12 Source0:        http://xcache.lighttpd.net/pub/Releases/%{version}/xcache-%{version}.tar.bz2
13 # Source0-md5:  45086010bc4f82f506c08be1c556941b
14 Source1:        %{modname}-apache.conf
15 Source2:        %{modname}-lighttpd.conf
16 Patch0:         config.patch
17 URL:            http://xcache.lighttpd.net/
18 BuildRequires:  %{php_name}-devel >= 4:5.2.17-8
19 BuildRequires:  rpmbuild(macros) >= 1.344
20 BuildRequires:  sed >= 4.0
21 %{?requires_zend_extension}
22 Requires:       php(core) >= 5.0.4
23 Requires(triggerpostun):        sed >= 4.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _webapps        /etc/webapps
27 %define         _webapp         %{modname}
28 %define         _sysconfdir     %{_webapps}/%{_webapp}
29 %define         _appdir         %{_datadir}/%{_webapp}
30
31 %description
32 XCache is a fast, stable PHP opcode cacher that has been tested and is
33 now running on production servers under high load.
34
35 %description -l pl.UTF-8
36 XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
37 działające na produkcyjnych serwerach o dużym obciążeniu.
38
39 %package web
40 Summary:        WEB interface for xCache
41 Group:          Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       webapps
44 Requires:       webserver(php) >= 5.0
45
46 %description web
47 Via this web interface script you can manage and view statistics of
48 xCache.
49
50 More information you can find at %{url}.
51
52 %prep
53 %setup -q -n %{modname}-%{version}
54 %patch0 -p1
55 %{__sed} -i.bak -e '
56         s,@extensiondir@,%{php_extensiondir},
57 ' xcache.ini
58
59 mv htdocs/config{.default,}.php
60 mv htdocs/config.example.php config.example.php
61 mv htdocs/cacher/config{.default,}.php
62 mv htdocs/cacher/config.example.php cacher.config.example.php
63 mv htdocs/coverager/config{.default,}.php
64 mv htdocs/coverager/config.example.php coverager.config.example.php
65
66 %{__rm} htdocs/common/lang/*.po
67 %{__rm} htdocs/coverager/lang/*.po
68 %{__rm} htdocs/cacher/lang/*.po
69
70 # wtf?
71 %{__rm} htdocs/diagnosis/lang/zh-tranditional.php
72
73 %build
74 phpize
75 %configure \
76         --enable-xcache \
77         --enable-xcache-optimizer \
78         --enable-xcache-coverager
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} install \
84         INSTALL_ROOT=$RPM_BUILD_ROOT
85
86 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
87 cp -p xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
88
89 # The cache directory where pre-compiled files will reside
90 install -d $RPM_BUILD_ROOT/var/cache/php-%{modname}
91
92 # web app
93 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}
94 cp -a htdocs/* $RPM_BUILD_ROOT%{_appdir}
95 %{__rm} $RPM_BUILD_ROOT%{_appdir}/diagnosis/lang/*.po
96
97 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/config.php
98 mv $RPM_BUILD_ROOT{%{_appdir}/cacher/config.php,%{_sysconfdir}/cacher.config.php}
99 mv $RPM_BUILD_ROOT{%{_appdir}/coverager/config.php,%{_sysconfdir}/coverager.config.php}
100 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
101 ln -s %{_sysconfdir}/cacher.config.php $RPM_BUILD_ROOT%{_appdir}/cacher/config.php
102 ln -s %{_sysconfdir}/coverager.config.php $RPM_BUILD_ROOT%{_appdir}/coverager/config.php
103 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
104 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
105 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 %php_webserver_restart
112
113 %postun
114 if [ "$1" = 0 ]; then
115         %php_webserver_restart
116 fi
117
118 %triggerpostun -- %{name} < 3.0.0-0.8
119 %{__sed} -i -e 's,zend_extension,extension,' %{php_sysconfdir}/conf.d/%{modname}.ini
120
121 %triggerin web -- apache1 < 1.3.37-3, apache1-base
122 %webapp_register apache %{_webapp}
123
124 %triggerun web -- apache1 < 1.3.37-3, apache1-base
125 %webapp_unregister apache %{_webapp}
126
127 %triggerin web -- apache < 2.2.0, apache-base
128 %webapp_register httpd %{_webapp}
129
130 %triggerun web -- apache < 2.2.0, apache-base
131 %webapp_unregister httpd %{_webapp}
132
133 %triggerin web -- lighttpd
134 %webapp_register lighttpd %{_webapp}
135
136 %triggerun web -- lighttpd
137 %webapp_unregister lighttpd %{_webapp}
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS README THANKS
142 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
143 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
144
145 # XXX: what for this dir is used?
146 %dir %attr(775,root,http) /var/cache/php-xcache
147
148 %files web
149 %defattr(644,root,root,755)
150 %doc config*.example.php
151 %dir %attr(750,root,http) %{_sysconfdir}
152 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
153 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
154 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
155 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
156 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cacher.config.php
157 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/coverager.config.php
158 %dir %{_appdir}
159 %{_appdir}/*.php
160
161 %dir %{_appdir}/common
162 %{_appdir}/common/*.css
163 %{_appdir}/common/*.php
164 %{_appdir}/common/*.png
165 %dir %{_appdir}/common/lang
166 %{_appdir}/common/lang/en.php
167 %lang(cn) %{_appdir}/common/lang/zh-simplified.php
168 %lang(cn) %{_appdir}/common/lang/zh-traditional.php
169
170 %dir %{_appdir}/cacher
171 %{_appdir}/cacher/*.css
172 %{_appdir}/cacher/*.js
173 %{_appdir}/cacher/*.php
174 %{_appdir}/cacher/sub
175 %dir %{_appdir}/cacher/lang
176 %{_appdir}/cacher/lang/en.php
177 %lang(zh_CN) %{_appdir}/cacher/lang/zh-simplified.php
178 %lang(zh_CN) %{_appdir}/cacher/lang/zh-traditional.php
179
180 %dir %{_appdir}/coverager
181 %{_appdir}/coverager/*.css
182 %{_appdir}/coverager/*.php
183 %dir %{_appdir}/coverager/lang
184 %{_appdir}/coverager/lang/en.php
185 %lang(zh_CN) %{_appdir}/coverager/lang/zh-simplified.php
186 %lang(zh_CN) %{_appdir}/coverager/lang/zh-traditional.php
187
188 %dir %{_appdir}/diagnosis
189 %{_appdir}/diagnosis/*.css
190 %{_appdir}/diagnosis/*.php
191 %dir %{_appdir}/diagnosis/lang
192 %{_appdir}/diagnosis/lang/en.php
193 %lang(zh_CN) %{_appdir}/diagnosis/lang/zh-simplified.php
194 %lang(zh_CN) %{_appdir}/diagnosis/lang/zh-traditional.php
This page took 0.220624 seconds and 4 git commands to generate.