]> git.pld-linux.org Git - packages/php-xcache.git/blob - php-xcache.spec
multi apache version config
[packages/php-xcache.git] / php-xcache.spec
1 # TODO
2 # - verify %lang codes
3 %define         php_name        php%{?php_suffix}
4 %define         modname xcache
5 Summary:        %{modname} - PHP opcode cacher
6 Summary(pl.UTF-8):      %{modname} - buforowanie opcodów PHP
7 Name:           %{php_name}-%{modname}
8 Version:        3.0.1
9 Release:        3
10 License:        BSD
11 Group:          Development/Languages/PHP
12 Source0:        http://xcache.lighttpd.net/pub/Releases/%{version}/xcache-%{version}.tar.bz2
13 # Source0-md5:  45086010bc4f82f506c08be1c556941b
14 Source1:        %{modname}-apache.conf
15 Source2:        %{modname}-lighttpd.conf
16 Patch0:         config.patch
17 URL:            http://xcache.lighttpd.net/
18 BuildRequires:  %{php_name}-devel >= 4:5.2.17-8
19 BuildRequires:  rpmbuild(macros) >= 1.344
20 BuildRequires:  sed >= 4.0
21 %{?requires_zend_extension}
22 Requires:       php(core) >= 5.0.4
23 Requires(triggerpostun):        sed >= 4.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _webapps        /etc/webapps
27 %define         _webapp         %{modname}
28 %define         _sysconfdir     %{_webapps}/%{_webapp}
29 %define         _appdir         %{_datadir}/%{_webapp}
30
31 %description
32 XCache is a fast, stable PHP opcode cacher that has been tested and is
33 now running on production servers under high load.
34
35 %description -l pl.UTF-8
36 XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
37 działające na produkcyjnych serwerach o dużym obciążeniu.
38
39 %package web
40 Summary:        WEB interface for xCache
41 Group:          Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       webapps
44 Requires:       webserver(access)
45 Requires:       webserver(php) >= 5.0
46
47 %description web
48 Via this web interface script you can manage and view statistics of
49 xCache.
50
51 More information you can find at %{url}.
52
53 %prep
54 %setup -q -n %{modname}-%{version}
55 %patch0 -p1
56 %{__sed} -i.bak -e '
57         s,@extensiondir@,%{php_extensiondir},
58 ' xcache.ini
59
60 mv htdocs/config{.default,}.php
61 mv htdocs/config.example.php config.example.php
62 mv htdocs/cacher/config{.default,}.php
63 mv htdocs/cacher/config.example.php cacher.config.example.php
64 mv htdocs/coverager/config{.default,}.php
65 mv htdocs/coverager/config.example.php coverager.config.example.php
66
67 %{__rm} htdocs/common/lang/*.po
68 %{__rm} htdocs/coverager/lang/*.po
69 %{__rm} htdocs/cacher/lang/*.po
70
71 # wtf?
72 %{__rm} htdocs/diagnosis/lang/zh-tranditional.php
73
74 %build
75 phpize
76 %configure \
77         --enable-xcache \
78         --enable-xcache-optimizer \
79         --enable-xcache-coverager
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %{__make} install \
85         INSTALL_ROOT=$RPM_BUILD_ROOT
86
87 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
88 cp -p xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
89
90 # The cache directory where pre-compiled files will reside
91 install -d $RPM_BUILD_ROOT/var/cache/php-%{modname}
92
93 # web app
94 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}
95 cp -a htdocs/* $RPM_BUILD_ROOT%{_appdir}
96 %{__rm} $RPM_BUILD_ROOT%{_appdir}/diagnosis/lang/*.po
97
98 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/config.php
99 mv $RPM_BUILD_ROOT{%{_appdir}/cacher/config.php,%{_sysconfdir}/cacher.config.php}
100 mv $RPM_BUILD_ROOT{%{_appdir}/coverager/config.php,%{_sysconfdir}/coverager.config.php}
101 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
102 ln -s %{_sysconfdir}/cacher.config.php $RPM_BUILD_ROOT%{_appdir}/cacher/config.php
103 ln -s %{_sysconfdir}/coverager.config.php $RPM_BUILD_ROOT%{_appdir}/coverager/config.php
104 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
105 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
106 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %php_webserver_restart
113
114 %postun
115 if [ "$1" = 0 ]; then
116         %php_webserver_restart
117 fi
118
119 %triggerpostun -- %{name} < 3.0.0-0.8
120 %{__sed} -i -e 's,zend_extension,extension,' %{php_sysconfdir}/conf.d/%{modname}.ini
121
122 %triggerin web -- apache1 < 1.3.37-3, apache1-base
123 %webapp_register apache %{_webapp}
124
125 %triggerun web -- apache1 < 1.3.37-3, apache1-base
126 %webapp_unregister apache %{_webapp}
127
128 %triggerin web -- apache < 2.2.0, apache-base
129 %webapp_register httpd %{_webapp}
130
131 %triggerun web -- apache < 2.2.0, apache-base
132 %webapp_unregister httpd %{_webapp}
133
134 %triggerin web -- lighttpd
135 %webapp_register lighttpd %{_webapp}
136
137 %triggerun web -- lighttpd
138 %webapp_unregister lighttpd %{_webapp}
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS README THANKS
143 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
144 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
145
146 # XXX: what for this dir is used?
147 %dir %attr(775,root,http) /var/cache/php-xcache
148
149 %files web
150 %defattr(644,root,root,755)
151 %doc config*.example.php
152 %dir %attr(750,root,http) %{_sysconfdir}
153 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
154 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
155 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
156 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
157 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cacher.config.php
158 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/coverager.config.php
159 %dir %{_appdir}
160 %{_appdir}/*.php
161
162 %dir %{_appdir}/common
163 %{_appdir}/common/*.css
164 %{_appdir}/common/*.php
165 %{_appdir}/common/*.png
166 %dir %{_appdir}/common/lang
167 %{_appdir}/common/lang/en.php
168 %lang(cn) %{_appdir}/common/lang/zh-simplified.php
169 %lang(cn) %{_appdir}/common/lang/zh-traditional.php
170
171 %dir %{_appdir}/cacher
172 %{_appdir}/cacher/*.css
173 %{_appdir}/cacher/*.js
174 %{_appdir}/cacher/*.php
175 %{_appdir}/cacher/sub
176 %dir %{_appdir}/cacher/lang
177 %{_appdir}/cacher/lang/en.php
178 %lang(zh_CN) %{_appdir}/cacher/lang/zh-simplified.php
179 %lang(zh_CN) %{_appdir}/cacher/lang/zh-traditional.php
180
181 %dir %{_appdir}/coverager
182 %{_appdir}/coverager/*.css
183 %{_appdir}/coverager/*.php
184 %dir %{_appdir}/coverager/lang
185 %{_appdir}/coverager/lang/en.php
186 %lang(zh_CN) %{_appdir}/coverager/lang/zh-simplified.php
187 %lang(zh_CN) %{_appdir}/coverager/lang/zh-traditional.php
188
189 %dir %{_appdir}/diagnosis
190 %{_appdir}/diagnosis/*.css
191 %{_appdir}/diagnosis/*.php
192 %dir %{_appdir}/diagnosis/lang
193 %{_appdir}/diagnosis/lang/en.php
194 %lang(zh_CN) %{_appdir}/diagnosis/lang/zh-simplified.php
195 %lang(zh_CN) %{_appdir}/diagnosis/lang/zh-traditional.php
This page took 0.041599 seconds and 4 git commands to generate.