]> git.pld-linux.org Git - packages/php-xcache.git/blob - php-xcache.spec
- 1.2.0-release, but i fail to build it
[packages/php-xcache.git] / php-xcache.spec
1 %define         _modname        xcache
2 Summary:        %{_modname} - PHP opcode cacher
3 Summary(pl.UTF-8):      %{_modname} - buforowanie opcodów PHP
4 Name:           php-%{_modname}
5 Version:        1.2.0
6 Release:        0.2
7 License:        BSD
8 Group:          Development/Languages/PHP
9 URL:            http://xcache.lighttpd.net/
10 Source0:        http://210.51.190.228/pub/XCache/Releases/xcache-%{version}.tar.bz2
11 # Source0-md5:  ffeaa9547037e098d9b041eb9741b51e
12 BuildRequires:  php-devel >= 3:5.1
13 BuildRequires:  rpmbuild(macros) >= 1.344
14 BuildRequires:  sed >= 4.0
15 %{?requires_zend_extension}
16 Requires:       php-common >= 4:5.0.4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 XCache is a fast, stable PHP opcode cacher that has been tested and is
21 now running on production servers under high load.
22
23 %description -l pl.UTF-8
24 XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
25 działające na produkcyjnych serwerach o dużym obciążeniu.
26
27 %prep
28 %setup -q -n xcache
29 %{__sed} -i -e '
30         s,zend_extension =.*,zend_extension = %{php_extensiondir}/xcache.so,
31         s,zend_extension_ts = .*,zend_extension_ts = %{php_extensiondir}/xcache.so,
32 ' xcache.ini
33
34 %build
35 phpize
36 %configure \
37         --enable-xcache \
38         --enable-xcache-optimizer \
39         --enable-xcache-coverager
40 %{__make} -j1
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
45
46 %{__make} install \
47         INSTALL_ROOT=$RPM_BUILD_ROOT
48
49 # The cache directory where pre-compiled files will reside
50 install -d $RPM_BUILD_ROOT/var/cache/php-xcache
51 install -d $RPM_BUILD_ROOT%{_datadir}/xcache
52
53 # Drop in the bit of configuration
54 install xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
55 install -D admin/* $RPM_BUILD_ROOT%{_datadir}/xcache
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %php_webserver_restart
62
63 %postun
64 if [ "$1" = 0 ]; then
65         %php_webserver_restart
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS README THANKS
71 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
72 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
73 %{_datadir}/xcache
74 %dir %attr(775,root,http) /var/cache/php-xcache
This page took 0.069435 seconds and 4 git commands to generate.