]> git.pld-linux.org Git - packages/php-xcache.git/blob - php-xcache.spec
- migrated to apache 2.4
[packages/php-xcache.git] / php-xcache.spec
1 # TODO
2 # - verify %lang codes
3 %define         php_name        php%{?php_suffix}
4 %define         modname xcache
5 Summary:        %{modname} - PHP opcode cacher
6 Summary(pl.UTF-8):      %{modname} - buforowanie opcodów PHP
7 Name:           %{php_name}-%{modname}
8 Version:        3.0.1
9 Release:        2
10 License:        BSD
11 Group:          Development/Languages/PHP
12 URL:            http://xcache.lighttpd.net/
13 Source0:        http://xcache.lighttpd.net/pub/Releases/%{version}/xcache-%{version}.tar.bz2
14 # Source0-md5:  45086010bc4f82f506c08be1c556941b
15 Source1:        %{modname}-apache.conf
16 Source2:        %{modname}-lighttpd.conf
17 Source3:        %{modname}-httpd.conf
18 Patch0:         config.patch
19 BuildRequires:  %{php_name}-devel >= 4:5.2.17-8
20 BuildRequires:  rpmbuild(macros) >= 1.344
21 BuildRequires:  sed >= 4.0
22 %{?requires_zend_extension}
23 Requires:       php(core) >= 5.0.4
24 Requires(triggerpostun):        sed >= 4.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _webapps        /etc/webapps
28 %define         _webapp         %{modname}
29 %define         _sysconfdir     %{_webapps}/%{_webapp}
30 %define         _appdir         %{_datadir}/%{_webapp}
31
32 %description
33 XCache is a fast, stable PHP opcode cacher that has been tested and is
34 now running on production servers under high load.
35
36 %description -l pl.UTF-8
37 XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
38 działające na produkcyjnych serwerach o dużym obciążeniu.
39
40 %package web
41 Summary:        WEB interface for xCache
42 Group:          Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       webapps
45 Requires:       webserver(php) >= 5.0
46 Conflicts:      apache-base < 2.4.0-1
47
48 %description web
49 Via this web interface script you can manage and view statistics of
50 xCache.
51
52 More information you can find at %{url}.
53
54 %prep
55 %setup -q -n %{modname}-%{version}
56 %patch0 -p1
57 %{__sed} -i.bak -e '
58         s,@extensiondir@,%{php_extensiondir},
59 ' xcache.ini
60
61 mv htdocs/config{.default,}.php
62 mv htdocs/config.example.php config.example.php
63 mv htdocs/cacher/config{.default,}.php
64 mv htdocs/cacher/config.example.php cacher.config.example.php
65 mv htdocs/coverager/config{.default,}.php
66 mv htdocs/coverager/config.example.php coverager.config.example.php
67
68 %{__rm} htdocs/common/lang/*.po
69 %{__rm} htdocs/coverager/lang/*.po
70 %{__rm} htdocs/cacher/lang/*.po
71
72 # wtf?
73 %{__rm} htdocs/diagnosis/lang/zh-tranditional.php
74
75 %build
76 phpize
77 %configure \
78         --enable-xcache \
79         --enable-xcache-optimizer \
80         --enable-xcache-coverager
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} install \
86         INSTALL_ROOT=$RPM_BUILD_ROOT
87
88 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
89 cp -p xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
90
91 # The cache directory where pre-compiled files will reside
92 install -d $RPM_BUILD_ROOT/var/cache/php-%{modname}
93
94 # web app
95 install -d $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}
96 cp -a htdocs/* $RPM_BUILD_ROOT%{_appdir}
97 %{__rm} $RPM_BUILD_ROOT%{_appdir}/diagnosis/lang/*.po
98
99 mv $RPM_BUILD_ROOT{%{_appdir},%{_sysconfdir}}/config.php
100 mv $RPM_BUILD_ROOT{%{_appdir}/cacher/config.php,%{_sysconfdir}/cacher.config.php}
101 mv $RPM_BUILD_ROOT{%{_appdir}/coverager/config.php,%{_sysconfdir}/coverager.config.php}
102 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.php
103 ln -s %{_sysconfdir}/cacher.config.php $RPM_BUILD_ROOT%{_appdir}/cacher/config.php
104 ln -s %{_sysconfdir}/coverager.config.php $RPM_BUILD_ROOT%{_appdir}/coverager/config.php
105 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
106 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
107 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 %php_webserver_restart
114
115 %postun
116 if [ "$1" = 0 ]; then
117         %php_webserver_restart
118 fi
119
120 %triggerpostun -- %{name} < 3.0.0-0.8
121 %{__sed} -i -e 's,zend_extension,extension,' %{php_sysconfdir}/conf.d/%{modname}.ini
122
123 %triggerin web -- apache1 < 1.3.37-3, apache1-base
124 %webapp_register apache %{_webapp}
125
126 %triggerun web -- apache1 < 1.3.37-3, apache1-base
127 %webapp_unregister apache %{_webapp}
128
129 %triggerin web -- apache-base
130 %webapp_register httpd %{_webapp}
131
132 %triggerun web -- apache-base
133 %webapp_unregister httpd %{_webapp}
134
135 %triggerin web -- lighttpd
136 %webapp_register lighttpd %{_webapp}
137
138 %triggerun web -- lighttpd
139 %webapp_unregister lighttpd %{_webapp}
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS README THANKS
144 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
145 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
146
147 # XXX: what for this dir is used?
148 %dir %attr(775,root,http) /var/cache/php-xcache
149
150 %files web
151 %defattr(644,root,root,755)
152 %doc config*.example.php
153 %dir %attr(750,root,http) %{_sysconfdir}
154 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
155 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
156 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
157 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
158 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cacher.config.php
159 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/coverager.config.php
160 %dir %{_appdir}
161 %{_appdir}/*.php
162
163 %dir %{_appdir}/common
164 %{_appdir}/common/*.css
165 %{_appdir}/common/*.php
166 %{_appdir}/common/*.png
167 %dir %{_appdir}/common/lang
168 %{_appdir}/common/lang/en.php
169 %lang(cn) %{_appdir}/common/lang/zh-simplified.php
170 %lang(cn) %{_appdir}/common/lang/zh-traditional.php
171
172 %dir %{_appdir}/cacher
173 %{_appdir}/cacher/*.css
174 %{_appdir}/cacher/*.js
175 %{_appdir}/cacher/*.php
176 %{_appdir}/cacher/sub
177 %dir %{_appdir}/cacher/lang
178 %{_appdir}/cacher/lang/en.php
179 %lang(zh_CN) %{_appdir}/cacher/lang/zh-simplified.php
180 %lang(zh_CN) %{_appdir}/cacher/lang/zh-traditional.php
181
182 %dir %{_appdir}/coverager
183 %{_appdir}/coverager/*.css
184 %{_appdir}/coverager/*.php
185 %dir %{_appdir}/coverager/lang
186 %{_appdir}/coverager/lang/en.php
187 %lang(zh_CN) %{_appdir}/coverager/lang/zh-simplified.php
188 %lang(zh_CN) %{_appdir}/coverager/lang/zh-traditional.php
189
190 %dir %{_appdir}/diagnosis
191 %{_appdir}/diagnosis/*.css
192 %{_appdir}/diagnosis/*.php
193 %dir %{_appdir}/diagnosis/lang
194 %{_appdir}/diagnosis/lang/en.php
195 %lang(zh_CN) %{_appdir}/diagnosis/lang/zh-simplified.php
196 %lang(zh_CN) %{_appdir}/diagnosis/lang/zh-traditional.php
This page took 0.066402 seconds and 3 git commands to generate.