]> git.pld-linux.org Git - packages/php-pear-HTML_Template_Flexy.git/blob - php-pear-HTML_Template_Flexy.spec
- spelling fixes, uppercases, etc.
[packages/php-pear-HTML_Template_Flexy.git] / php-pear-HTML_Template_Flexy.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       Template
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}_Flexy
6
7 Summary:        %{_pearname} - a flexible caching template engine based on SimpleTemplate
8 Summary(pl):    %{_pearname} - elastyczny buforuj±cy silnik szablonów oparty na SimpleTemplate
9 Name:           php-pear-%{_pearname}
10 Version:        1.0.1
11 Release:        1
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  ac684af4c1f06230f6c261a6bbd2c262
16 Patch0:         %{name}-case_fix.patch
17 URL:            http://pear.php.net/package/HTML_Template_Flexy/
18 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
19 Requires:       php-pear
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 HTML_Template_Flexy started it's life as a simplification of HTML_Template_Xipe,
25 however in Version 0.2, It became one of the first template engine to use a real Lexer,
26 rather than regex'es, making it possible to do things like ASP.net or Cold Fusion tags.
27 However, it still has a very simple set of goals.
28 - Very Simple API,
29    o easy to learn...
30    o prevents to much logic going in templates
31 - Easy to write document'able code
32    o By using object vars for a template rather than 'assign', you
33      can use PHPDoc comments to list what variable you use.
34 - Editable in WYSIWYG editors
35    o you can create full featured templates, that doesnt get broken every time you edit with
36      Dreamweaver(tm) or Mozzila editor
37    o Uses namespaced attributes to add looping/conditionals
38 - Extremely Fast,
39    o runtime is at least 4 time smaller than most other template engines (eg. Smarty)
40    o uses compiled templates, as a result it is many times faster on blocks and loops than
41      than Regex templates (eg. IT/phplib)
42 - Safer (for cross site scripting attacks)
43    o All variables default to be output as HTML escaped (overridden with the :h modifier)
44 - Multilanguage support
45    o Parses strings out of template, so you can build translation tools
46    o Compiles language specific templates (so translation is only done once, not on every request)
47 - Full dynamic element support (like ASP.NET), so you can pick elements to replace at runtime
48
49 Features:
50 - {variable} to echo $object->variable
51 - {method()} to echo $object->method();
52 - {foreach:var,key,value} to PHP foreach loops
53 - tag attributes FLEXY:FOREACH, FLEXY:IF for looping and conditional HTML inclusion
54 - {if:variable} to PHP If statement
55 - {if:method()} to PHP If statement
56 - {else:} and {end:} to close or alternate If statements
57 - FORM to HTML_Template_Flexy_Element's
58 - replacement of INPUT, TEXTAREA and SELECT tags with HTML_Template_Flexy_Element code
59   use FLEXY:IGNORE (inherited) and FLEXY:IGNOREONLY (single) to prevent replacements
60 - FLEXY:START/FLEXY:STARTCHILDREN tags to define where template starts/finishes
61 - support for urlencoded braces {} in HTML attributes.
62 - documentation in the pear manual
63
64 - examples at http://cvs.php.net/cvs.php/pear/HTML_Template_Flexy/tests/
65
66 The long term plan for Flexy is to be integrated as a backend for the Future
67 Template Package (A BC wrapper will be made available - as I need to use it
68 too!)
69
70 In PEAR status of this package is: %{_status}.
71
72 %description -l pl
73 Flexy Template to silnik szablonów do konwertera kodu PHP, oparty na
74 Simple Template i podobny do Smarty. Powinien byæ bardzo szybki, jest
75 ³atwy w rozszerzaniu, rozwijaniu i u¿ywaniu dowolnej sk³adni
76 szablonów. Domy¶lny filtr (SimpleTags) zawiera: zmienne, pêtle
77 foreach, warunki, wywo³ania metod, w³±czanie kodu, obs³uguje znaczniki
78 zakodowane w URL-ach - wiêc mo¿e modyfikowaæ szablony w Mozilli itp.
79 Inne filtry to:
80  - RtfSimpletags - do tworzenia dokumentów RTF dla Worda,
81  - BodyOnly - wycinaj±cy nag³ówek i stopkê z szablonu,
82  - Php - wycinaj±cy kod PHP z szablonu,
83  - Email - do przetwarzania szablonów e-mail.
84
85 Ta klasa ma w PEAR status: %{_status}.
86
87 %prep
88 %setup -q -c
89 cd %{_pearname}-%{version}
90 %patch0 -p1
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/Flexy/{Compiler/{Flexy,Standard,Regex},Token}
95         
96 install %{_pearname}-%{version}/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}
97 install %{_pearname}-%{version}/Flexy/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/Flexy
98 install %{_pearname}-%{version}/Flexy/Compiler/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/Flexy/Compiler
99 install %{_pearname}-%{version}/Flexy/Compiler/Flexy/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/Flexy/Compiler/Flexy
100 install %{_pearname}-%{version}/Flexy/Compiler/Standard/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/Flexy/Compiler/Standard
101 install %{_pearname}-%{version}/Flexy/Compiler/Regex/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/Flexy/Compiler/Regex
102 install %{_pearname}-%{version}/Flexy/Token/*.php $RPM_BUILD_ROOT%{php_pear_dir}/%{_class}/%{_subclass}/Flexy/Token
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %files
108 %defattr(644,root,root,755)
109 %doc %{_pearname}-%{version}/{Flexy/example.ini,tests}
110 %{php_pear_dir}/%{_class}/%{_subclass}/Flexy
111 %{php_pear_dir}/%{_class}/%{_subclass}/Flexy.php
This page took 0.044334 seconds and 4 git commands to generate.