]> git.pld-linux.org Git - packages/php-pear-HTML_Table_Matrix.git/blob - php-pear-HTML_Table_Matrix.spec
- rel 3
[packages/php-pear-HTML_Table_Matrix.git] / php-pear-HTML_Table_Matrix.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          HTML
3 %define         _subclass       Table
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}_Matrix
6
7 Summary:        %{_pearname} - autofill a table with data
8 Summary(pl.UTF-8):      %{_pearname} - automatycznie wypełnianie tabeli danymi
9 Name:           php-pear-%{_pearname}
10 Version:        1.0.9
11 Release:        3
12 License:        PHP 2.02
13 Group:          Development/Languages/PHP
14 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
15 # Source0-md5:  6202f9b43a13b2104b4db8622002f455
16 URL:            http://pear.php.net/package/HTML_Table_Matrix/
17 BuildRequires:  php-pear-PEAR
18 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
19 BuildRequires:  rpmbuild(macros) >= 1.300
20 Requires:       php-pear
21 Requires:       php-pear-HTML_Table
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # exclude optional dependencies
26 %define         _noautoreq      'pear(Numbers/Words.*)'
27
28 %description
29 HTML_Table_Matrix is an extension to HTML_Table which allows you to
30 easily fill up a table with data. Features:
31 - It uses Filler classes to determine how the data gets filled in the
32   table. With a custom Filler, you can fill data in up, down,
33   forwards, backwards, diagonally, randomly or any other way you like.
34 - Comes with Fillers to fill left-to-right-top-to-bottom and
35   right-to-left-top-to-bottom.
36 - Abstract Filler methods keep the code clean & easy to understand.
37 - Table height or width may be omitted, and it will figure out the
38   correct table size based on the data you provide.
39 - It integrates handily with Pager to create pleasant pageable table
40   layouts, such as for an image gallery. Just specify a height or
41   width, Filler, and feed it the data returned from Pager.
42 - Table may be constrained to a specific height or width, and excess
43   data will be ignored.
44 - Fill offset may be specified, to leave room for a table header, or
45   other elements in the table.
46 - Fully documented with PHPDoc.
47 - Includes fully functional example code.
48
49 In PEAR status of this package is: %{_status}.
50
51 %description -l pl.UTF-8
52 HTML_Table_Matrix to rozszerzenie HTML_Table pozwalające na łatwe
53 wypełnianie tabel danymi. Cechy pakietu:
54 - Używa klas Filler do określenia sposobu wypełniania tabeli danymi.
55   Przy użyciu własnego Fillera można wypełniać danymi do góry, w dół,
56   do przodu, do tyłu, po przekątnej, losowo lub w dowolny inny sposób.
57 - Zawiera klasy Filler do wypełniania od lewej do prawej, od góry do
58   dołu oraz od prawej do lewej, od góry do dołu.
59 - Wyabstrahowane metody Filler pozwalają utrzymać kod czystym i łatwym
60   do zrozumienia.
61 - Wysokość lub szerokość tabeli może być pominięta, a właściwy rozmiar
62   tabel oparty na dostarczonych danych.
63 - Zręcznie integruje się z klasą Pager tworząc przyjemne stronnicowane
64   tabele, takie jak dla galerii obrazków. Wystarczy podać wysokość lub
65   szerokość, klasę Filler i dostarczyć dane zwrócone przez Pager.
66 - Tabele mogą być ograniczane do określonej wysokości lub szerokości,
67   a nadmiarowe dane zostaną zignorowane.
68 - Można podać offset wypełnienia aby zostawić miejsce na nagłówek lub
69   inne elementy tabeli.
70 - Jest w pełni udokumentowany przy użyciu PHPDoc.
71 - Zawiera w pełni funkcjonalny kod przykładowy.
72
73 Ta klasa ma w PEAR status: %{_status}.
74
75 %prep
76 %pear_package_setup
77
78 mv ./%{php_pear_dir}/doc docs
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT%{php_pear_dir}
83 %pear_package_install
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post
89 if [ -f %{_docdir}/%{name}-%{version}/optional-packages.txt ]; then
90         cat %{_docdir}/%{name}-%{version}/optional-packages.txt
91 fi
92
93 %files
94 %defattr(644,root,root,755)
95 %doc install.log optional-packages.txt
96 %doc docs/%{_pearname}/examples
97 %{php_pear_dir}/.registry/*.reg
98 %{php_pear_dir}/%{_class}/%{_subclass}/Matrix.php
99 %{php_pear_dir}/%{_class}/%{_subclass}/Matrix
This page took 0.078022 seconds and 3 git commands to generate.