]> git.pld-linux.org Git - packages/php-pear-HTML_Table_Matrix.git/blob - php-pear-HTML_Table_Matrix.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/php-pear-HTML_Table_Matrix.git] / php-pear-HTML_Table_Matrix.spec
1 %define         _class          HTML
2 %define         _subclass       Table
3 %define         _status         stable
4 %define         _pearname       %{_class}_%{_subclass}_Matrix
5 Summary:        %{_pearname} - autofill a table with data
6 Summary(pl.UTF-8):      %{_pearname} - automatycznie wypełnianie tabeli danymi
7 Name:           php-pear-%{_pearname}
8 Version:        1.0.10
9 Release:        2
10 License:        PHP 2.02
11 Group:          Development/Languages/PHP
12 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
13 # Source0-md5:  563aa076399bcaa6d690bbe24fe90090
14 URL:            http://pear.php.net/package/HTML_Table_Matrix/
15 BuildRequires:  php-pear-PEAR >= 1:1.4.0-0.b1
16 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
17 BuildRequires:  rpmbuild(macros) >= 1.300
18 Requires:       php-pear
19 Requires:       php-pear-HTML_Table
20 Requires:       php-pear-PEAR-core >= 1:1.4.0
21 Suggests:       php-pear-Numbers_Words
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # exclude optional dependencies
26 %define         _noautoreq      'pear(Numbers/Words.*)'
27
28 %description
29 HTML_Table_Matrix is an extension to HTML_Table which allows you to
30 easily fill up a table with data. Features:
31 - It uses Filler classes to determine how the data gets filled in the
32   table. With a custom Filler, you can fill data in up, down, forwards,
33   backwards, diagonally, randomly or any other way you like.
34 - Comes with Fillers to fill left-to-right-top-to-bottom and
35   right-to-left-top-to-bottom.
36 - Abstract Filler methods keep the code clean & easy to understand.
37 - Table height or width may be omitted, and it will figure out the
38   correct table size based on the data you provide.
39 - It integrates handily with Pager to create pleasant pageable table
40   layouts, such as for an image gallery. Just specify a height or width,
41   Filler, and feed it the data returned from Pager.
42 - Table may be constrained to a specific height or width, and excess
43   data will be ignored.
44 - Fill offset may be specified, to leave room for a table header, or
45   other elements in the table.
46 - Fully documented with PHPDoc.
47 - Includes fully functional example code.
48
49 In PEAR status of this package is: %{_status}.
50
51 %description -l pl.UTF-8
52 HTML_Table_Matrix to rozszerzenie HTML_Table pozwalające na łatwe
53 wypełnianie tabel danymi. Cechy pakietu:
54 - Używa klas Filler do określenia sposobu wypełniania tabeli danymi.
55   Przy użyciu własnego Fillera można wypełniać danymi do góry, w dół, do
56   przodu, do tyłu, po przekątnej, losowo lub w dowolny inny sposób.
57 - Zawiera klasy Filler do wypełniania od lewej do prawej, od góry do
58   dołu oraz od prawej do lewej, od góry do dołu.
59 - Wyabstrahowane metody Filler pozwalają utrzymać kod czystym i łatwym
60   do zrozumienia.
61 - Wysokość lub szerokość tabeli może być pominięta, a właściwy rozmiar
62   tabel oparty na dostarczonych danych.
63 - Zręcznie integruje się z klasą Pager tworząc przyjemne stronnicowane
64   tabele, takie jak dla galerii obrazków. Wystarczy podać wysokość lub
65   szerokość, klasę Filler i dostarczyć dane zwrócone przez Pager.
66 - Tabele mogą być ograniczane do określonej wysokości lub szerokości,
67   a nadmiarowe dane zostaną zignorowane.
68 - Można podać offset wypełnienia aby zostawić miejsce na nagłówek lub
69   inne elementy tabeli.
70 - Jest w pełni udokumentowany przy użyciu PHPDoc.
71 - Zawiera w pełni funkcjonalny kod przykładowy.
72
73 Ta klasa ma w PEAR status: %{_status}.
74
75 %prep
76 %pear_package_setup
77
78 # examples fixups
79 mv ./%{php_pear_dir}/examples .
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{php_pear_dir},%{_examplesdir}/%{name}-%{version}}
84 %pear_package_install
85
86 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 if [ -f %{_docdir}/%{name}-%{version}/optional-packages.txt ]; then
93         cat %{_docdir}/%{name}-%{version}/optional-packages.txt
94 fi
95
96 %files
97 %defattr(644,root,root,755)
98 %doc install.log optional-packages.txt
99 %{php_pear_dir}/.registry/*.reg
100 %{php_pear_dir}/%{_class}/%{_subclass}/Matrix.php
101 %{php_pear_dir}/%{_class}/%{_subclass}/Matrix
102
103 %{_examplesdir}/%{name}-%{version}
This page took 0.105355 seconds and 4 git commands to generate.