]> git.pld-linux.org Git - packages/perl.git/blame - perl.spec
- added PerlIO, directory list fix, rel. 2
[packages/perl.git] / perl.spec
CommitLineData
6d45ca4e 1#
2# Conditional build:
361d5527
JB
3%bcond_without tests # do not perform "make test"
4%bcond_without threads # build without support for threads
5%bcond_without gdbm # build without the GDBM_File module
c3a42fee 6%bcond_without microperl # don't build microperl
6d45ca4e 7#
8# TODO:
6d45ca4e 9# - fix "FIXME"s, review "XXX"s
3d18c4ab 10# - add the {O,N}DBM_File modules
469f90c5 11# - review the perldiag.pod issue
12# - consider disabling ithreads by default
f10a6a7a 13# - consider introducing perl-dirs
361d5527 14# - what about "prove" (binary+manual)? (conflicts with standalone Test-Harness)
410c7955 15# - patch MakeMaker to get rid of empty *.bs files (MM_Unix::dynamic_bs())
469f90c5 16#
17# TODO for perl-dependent packages:
18# - change all "R/BR: perl" to one of perl-{base,modules,devel}
6d45ca4e 19#
20
d5dcea79 21%define _abi 5.8.0
22
361d5527 23%define perlthread %{?with_threads:-thread-multi}
3eb80867 24
6d45ca4e 25%define perl_privlib %{_datadir}/perl5/%{version}
26%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 27%define perl_sitelib %{_usr}/local/share/perl5
d5dcea79 28%define perl_sitearch %{_usr}/local/lib/perl5/%{_abi}/%{_target_platform}%{perlthread}
01393b52 29%define perl_vendorlib %{_datadir}/perl5/vendor_perl
d5dcea79 30%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{_abi}/%{_target_platform}%{perlthread}
3eb80867 31
557db02e 32Summary: Practical Extraction and Report Language (Perl)
7095bd2b 33