]> git.pld-linux.org Git - packages/perl.git/blame - perl.spec
- removed build dependency on itself
[packages/perl.git] / perl.spec
CommitLineData
6d45ca4e 1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4# _without_threads - build without support for threads
5# _without_largefiles - build without large file support
6#
7# TODO:
8# - Think about unicore. If uf8*.pm, encode.pm, charnamess.pm (and
9# probably others) are in the perl-base package, unicore should also
10# be there. But it's 5MB...
11# - Think about the package separation. Split between perl, perl-base
12# and perl-modules is far from obvius.
13# - find out why *.so and *.bs files for some pragmas are ,,listed twice''
14# - merge some fixes from 5.6.1 on HEAD
15# - fix "FIXME"s, review "XXX"s
16# - fix perl.prov's handling in rpm -- it should use the __perl macro
17# - include gdbm-dependent modules, they aren't distributed standalone
18# anymore
19# - *TESTING*
20#
21
22%define __find_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
23%define perlthread %{?!_without_threads:-thread-multi}
3eb80867 24
6d45ca4e 25%define perl_privlib %{_datadir}/perl5/%{version}
26%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
27%define perl_sitelib %{_usr}/local/share/perl5/
28%define perl_sitearch %{_usr}/local/lib/perl5/%{version}/%{_target_platform}%{perlthread}
29%define perl_vendorlib %{_datadir}/perl5/vendor_perl/
30%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{version}/%{_target_platform}%{perlthread}
3eb80867 31
557db02e 32Summary: Practical Extraction and Report Language (Perl)
7095bd2b 33