]> git.pld-linux.org Git - packages/perl.git/blame - perl.spec
- reverted last change, it doesn't work as I expected
[packages/perl.git] / perl.spec
CommitLineData
6d45ca4e 1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4# _without_threads - build without support for threads
5# _without_largefiles - build without large file support
3d18c4ab 6# _without_gdbm - build without the GDBM_File module
6d45ca4e 7#
8# TODO:
9# - Think about unicore. If uf8*.pm, encode.pm, charnamess.pm (and
10# probably others) are in the perl-base package, unicore should also
11# be there. But it's 5MB...
12# - Think about the package separation. Split between perl, perl-base
13# and perl-modules is far from obvius.
6d45ca4e 14# - fix "FIXME"s, review "XXX"s
15# - fix perl.prov's handling in rpm -- it should use the __perl macro
80a1a2f4 16# - fix some duplicate files
3d18c4ab 17# - add the {O,N}DBM_File modules
6d45ca4e 18# - *TESTING*
19#
20
00721c68 21%if 0%(if [ %{__perl_requires} ]; then echo 1; fi)
6044ad0c 22%undefine __perl_requires
23%define __perl_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
00721c68 24%else
25%define __find_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
26%endif
6044ad0c 27
6d45ca4e 28%define perlthread %{?!_without_threads:-thread-multi}
3eb80867 29
6d45ca4e 30%define perl_privlib %{_datadir}/perl5/%{version}
31%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 32%define perl_sitelib %{_usr}/local/share/perl5
6d45ca4e 33%define perl_sitearch %{_usr}/local/lib/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 34%define perl_vendorlib %{_datadir}/perl5/vendor_perl
6d45ca4e 35%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{version}/%{_target_platform}%{perlthread}
3eb80867 36
557db02e 37Summary: Practical Extraction and Report Language (Perl)
7095bd2b 38