]> git.pld-linux.org Git - packages/perl.git/blame - perl.spec
- massive attack, adding Source-md5
[packages/perl.git] / perl.spec
CommitLineData
6d45ca4e 1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4# _without_threads - build without support for threads
5# _without_largefiles - build without large file support
3d18c4ab 6# _without_gdbm - build without the GDBM_File module
6d45ca4e 7#
8# TODO:
469f90c5 9# - Think about unicore. If uf8*.pm, encode.pm, charnames.pm (and
6d45ca4e 10# probably others) are in the perl-base package, unicore should also
11# be there. But it's 5MB...
469f90c5 12# - profile the perl-base vs. perl-modules separation
6d45ca4e 13# - fix "FIXME"s, review "XXX"s
14# - fix perl.prov's handling in rpm -- it should use the __perl macro
469f90c5 15# - fix some duplicate files (are there any left?)
3d18c4ab 16# - add the {O,N}DBM_File modules
469f90c5 17# - review the perldiag.pod issue
18# - consider disabling ithreads by default
19# - move the perl_vendorarch directories to perl-base (?)
20#
21# TODO for perl-dependent packages:
22# - change all "R/BR: perl" to one of perl-{base,modules,devel}
23# - use the requires_eq(perl-base) for all packages strictly depending
24# on the perl version used for building (files in perl_vendorarch
25# directories; dependency on libperl.so.* often doesn't exist)
26# (should this be done on Ra-branch, too?)
6d45ca4e 27#
28
00721c68 29%if 0%(if [ %{__perl_requires} ]; then echo 1; fi)
6044ad0c 30%undefine __perl_requires
31%define __perl_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
00721c68 32%else
33%define __find_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
34%endif
6044ad0c 35
6d45ca4e 36%define perlthread %{?!_without_threads:-thread-multi}
3eb80867 37
6d45ca4e 38%define perl_privlib %{_datadir}/perl5/%{version}
39%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 40%define perl_sitelib %{_usr}/local/share/perl5
6d45ca4e 41%define perl_sitearch %{_usr}/local/lib/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 42%define perl_vendorlib %{_datadir}/perl5/vendor_perl
6d45ca4e 43%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{version}/%{_target_platform}%{perlthread}
3eb80867 44
557db02e 45Summary: Practical Extraction and Report Language (Perl)
7095bd2b 46