]> git.pld-linux.org Git - packages/perl-prefork.git/blob - perl-prefork.spec
- pl desc
[packages/perl-prefork.git] / perl-prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    prefork
7 Summary:        prefork - optimize module loading across forking and non-forking scenarios
8 Summary(pl):    prefork - optymalizacja ³adowania modu³ów dla rozwidlonych i nierozwidlonych scenariuszy
9 Name:           perl-prefork
10 Version:        0.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/A/AD/ADAMK/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  040b340931bd8190b87c81130ea5f8d0
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.24-2
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The prefork pragma is intended to allow module writers to optimise
25 module loading for both scenarios with as little additional code as
26 possible.
27
28 The prefork.pm is intended to serve as a central and optional
29 marshalling point for state detection (are we running in procedural or
30 pre-forking mode) and to act as a relatively light-weight module
31 loader.
32
33 %description -l pl
34 prefork ma umo¿liwiæ pisz±cym modu³y zoptymalizowanie ³adowania
35 modu³ów dla obu scenariuszy przy u¿yciu jak najmniejszego dodatkowego
36 kodu.
37
38 prefork.pm ma s³u¿yæ jako centralny i opcjonalnie prowadz±cy punkt dla
39 wykrywania stanów (czy program dzia³a w trybie proceduralnym, czy
40 pre-fork) i dzia³aæ jako relatywnie lekki modu³ do wczytywania
41 modu³ów.
42
43 %prep
44 %setup -q -n %{pdir}-%{version}
45
46 %build
47 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"%{pdir}")' \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes
65 %{perl_vendorlib}/*.pm
66 %{_mandir}/man3/*
This page took 0.471309 seconds and 4 git commands to generate.