]> git.pld-linux.org Git - packages/perl-prefork.git/blob - perl-prefork.spec
- updated to 1.05
[packages/perl-prefork.git] / perl-prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    prefork
6 Summary:        prefork - optimize module loading across forking and non-forking scenarios
7 Summary(pl.UTF-8):      prefork - optymalizacja ładowania modułów dla rozwidlonych i nierozwidlonych scenariuszy
8 Name:           perl-prefork
9 Version:        1.05
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/E/ET/ETHER/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  60d97a66a1e6e4ccfa51f8662a511048
16 URL:            https://metacpan.org/release/prefork
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.24-2
18 %if %{with tests}
19 BuildRequires:  perl-Scalar-List-Utils >= 0.18
20 BuildRequires:  perl-Test-Simple
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  rpmbuild(macros) >= 1.745
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The prefork pragma is intended to allow module writers to optimise
30 module loading for both scenarios with as little additional code as
31 possible.
32
33 The prefork.pm is intended to serve as a central and optional
34 marshalling point for state detection (are we running in procedural or
35 pre-forking mode) and to act as a relatively light-weight module
36 loader.
37
38 %description -l pl.UTF-8
39 prefork ma umożliwić piszącym moduły zoptymalizowanie ładowania
40 modułów dla obu scenariuszy przy użyciu jak najmniejszego dodatkowego
41 kodu.
42
43 prefork.pm ma służyć jako centralny i opcjonalnie prowadzący punkt dla
44 wykrywania stanów (czy program działa w trybie proceduralnym, czy
45 pre-fork) i działać jako relatywnie lekki moduł do wczytywania
46 modułów.
47
48 %prep
49 %setup -q -n %{pdir}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 #rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
65 #rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/prefork/.packlist
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes
73 %{perl_vendorlib}/prefork.pm
74 %{_mandir}/man3/prefork.3pm*
This page took 0.15784 seconds and 4 git commands to generate.